Jump to content
3D Coat Forums
Sign in to follow this  
laberg

model import problems

Recommended Posts

Hi,

I am evaluating 3D Coat. So Far so good but I have one problem that happened on two different imported models when trying the Paint UV Mapped Mesh option. After selecting the file and using the default import option the model appears with triangles added. This happened for both .fbx and .obj exports. 

Any ideas what goes wrong?

Thanks!

Share this post


Link to post
Share on other sites

Hello.

Importing to Sculpt workspace 3DCoat triangulate any mesh at import by default, there isnt any option to disable it.

Share this post


Link to post
Share on other sites

Thank you for the quick reply

What I meant was that triangles are added additional to the triangles in the .obj. 

Or do you mean it will retriangulate the mesh and not respect the triangles in the .obj?

Meanwhile I had a look at the Retopo option to see if these added triangles can be removed easily. Watched this video:

 

When following this I don't get the same behaviour, regardless whether vertices, edges or faces is selected moving the mouse over the mesh doesn't highlight anything. Vertices, edges, traingles are unselectable.

Is this an object selection issue? I assume the "RetopoGroup1" in the Retopo Groups popup is the initial object. it cannot be deleted, it can be deleted after adding a layer. But the mesh is still visible afterwards. 

I was having fun using the paint options avoiding these added triangles at first. But this corrupted mesh display is stopping things. I was hoping not to get into these noob situations... :(

Additional to my initial question, any ideas what is going on here?

Share this post


Link to post
Share on other sites

Version 4.5.20 is outdated, please test version 4.8.23

Many bug fixes have already been made from that version to the current one.

 

Share this post


Link to post
Share on other sites

I am using 4.8.20, not  4.5.2,  If you are referring to that video link, that is the link that opens after hitting F1 in the 3D Coat editor with "Select" active. 

Do you have feedback specific to my problems? Do you need more info from me?

 

Share this post


Link to post
Share on other sites

Yes please, your model have uDims ?

If you import for Paint workspca, UV can be modified on UV Workspace, no Retopo Workspace 

On 10/30/2014 at 10:16 AM, AbnRanger said:

The UV tools in the Retopo Room are practically a mirror of those in the UV room. UV's on a model in the Paint room are to be edited in the UV room. UV's on a Retopo Mesh are done right inside that same workspace. The first part of this video helps to explain that a bit:

 

 

 

Share this post


Link to post
Share on other sites

Okay I think I get it.  What you want to do is just import a mesh for texture painting.  That is why you choose "Paint UV Mapped Mesh (Per Pixel)" in the Start Menu Popup. 

First make sure there are no subdivisions in "Initial Subdivision"

And there is a checkbox for triangulate.  Make sure it is not checked. 

There are a few other options concerning your smoothing, and UV's but this should take care of the additional triangle problem you have been having. 

 

I have also attached an obj file made in blender.  Here are the settings I did for it so you can see.

Normal Map Software Preset = Blender (Only because its what I used to model in)

Initial Subdivision = No Subdivision (Will mess up the mesh)

UV Map Typing = Keep UV (Note this is just because I have a UV set already on the two meshes)

UV Set Smoothing = Smooth, Keep Edges (May or may not apply to your mesh)

Nothing checked below except "Lock Normals" (Make sure "Triangulate" is not checked)

 

untitled.obj

untitled.mtl

Share this post


Link to post
Share on other sites

UDims, is that possibly related to the corrupted .obj import? 

Thanks for the video, that shines some light on workflow.

I will test some other models.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×