Jump to content
3D Coat Forums
Syntex3D

[Bug] Incorrect brush behaviour

Recommended Posts

With the default brush settings, the brush alpha is incorrect (Sharp shape: OFF).

In the screenshot below i used an alpha with smooth edges & when "Sharp Shape" is OFF, the result is incorrect because it has hard edges even though it's supposed to be a soft edged brush.

When "Sharp Shape" is ON, the brush has smooth edges like it's supposed to, but when the brush stroke intersects with itself & you don't lift up the pen, it creates weird looking corners.

With "Sharp Shape" OFF, the self intersect result is correct but the edges are hard even though it's a soft brush.

 

There is no way to get the correct result, either the brush alpha has hard edges even though it's supposed to have smooth edges or the self intersect result is incorrect.

(All strokes in the screenshot are drawn with the same alpha & same brush size, using the "depth & opacity" brush)

incorrect brush behaviour.png

Share this post


Link to post
Share on other sites

Hello 

Are you using Focal Shift at 100 % ?

FocalShift.jpg

Share this post


Link to post
Share on other sites

Hey,

The focal shift option was hidden & had to be enabled in preferences so I didn't find it before. 

To get the correct alpha & correct self intersection you have to use the default brush setting (Sharp Shape: OFF) and a negative focal shift value like -65%. It's not really correct because it blurs the whole alpha.

It only fixes the issue if you're using a medium brush size, because if you're using a smaller brush, the whole brush stroke gets very blurry. It's mostly visible when using the softest round brush alpha. There are also problems when using a big brush size, it creates dotted lines. 

Default brush with focal shift.png

blurry.png

dotted lines.png

Share this post


Link to post
Share on other sites

Thanks for your detailed report. 

Bug Reported.

Share this post


Link to post
Share on other sites

This issue was solved on latest version, Could you please give a try ? Thx.

Share this post


Link to post
Share on other sites

Hey,

I tested all new versions, even the beta 4.8.34 and I didn't see any difference in the brush behaviour. What exactly was changed? There isn't anything mentioned about the issue in the release notes either.

I attached some screenshots of my tests with the new version below.

I couldn't fit any text on the second screenshot so I'll write what's wrong with it here:

1. REFERENCE:
Sharp Shape (Old Style): ON, (Focal shift 0%)

This is what the alpha/ brush stroke should look like because the alpha is supposed to have very smooth edges.

These settings produce the correct alpha but it has the self intersecting issue shown in the first screenshot. If that issue would get fixed, it would behave correctly for texture painting purposes.

Another issue, but a minor one is that when the "Sharp Shape (Old Style)" setting is enabled, the brush doesn't draw anything if you just click on the object, you have to click & then drag to get anything to appear. This makes it impossible to draw dots with the setting enabled.

2.Default brush mode, Sharp Shape (Old Style): OFF,  (Focal Shift 0%)

This brush stroke uses the same alpha as 1. but looks totally different. The alpha is not supposed to have sharp edges like this.

3.Default brush mode, Sharp Shape (Old Style): OFF,  (Focal Shift -65%)

Here I tried to fix the incorrect alpha of the default brush mode by adjusting the Focal Shift, but changing the Focal Shift doesn't fix anything, it blurs the whole alpha texture, not just the edges. And it creates dotted lines in the middle of the brush stroke.

1.PNG

2.PNG

Share this post


Link to post
Share on other sites

Hi 

Reported.

Thx for your detailed comment.

Share this post


Link to post
Share on other sites

Could you please check latest version 4.8.35

Thx

Share this post


Link to post
Share on other sites

Hi @Carlosan,

I tested the latest version 4.8.35 like you asked me to, but the same issues/ bugs that I listed in my previous message are still there.

Nothing about the issue was mentioned in the changes list either so I wasn't too hopeful, but it was pretty disappointing to find out that it still hasn't been fixed. This was my third time testing a new version.

 

 @haikalle That is normal behaviour for a soft edged brush. When you use 100% opacity, it just means that you're using the original/ unchanged values of the alpha texture, which in this case has areas that are less than 100% opaque. For example the edges of the alpha could be 5% opaque, and when you press the brush stroke on the same spot multiple times, the opacity of that area increases each time (5% > 10% > 15% etc.), making the edges sharper.

Share this post


Link to post
Share on other sites

@haikalle Increasing spacing affects edge smoothness (very little), because the alphas are less on top of each other > lower opacity on the edges, but it doesn't fix the fact that the alpha itself is still incorrect in the default brush mode (Sharp Shape (Old Style): OFF) & It still has all of the same problems that I listed above.

I'm worried that there are gonna be too many replies in this thread & nobody is gonna find the message where i explained the issues & they will never get fixed.

Share this post


Link to post
Share on other sites

@Syntex3D  My apologies, I saw this ticket as solved. I have reopened it and sent it to dev team again.

Share this post


Link to post
Share on other sites

By the way, it works as expected in very old versions. Something like 4.0 - 4.1.xx. (i have 4.1.04A installed in parallel with newer versions)

 

3DC_4.1_04A.thumb.jpg.d1163548a2767e764e51d77a9f560fd5.jpg

 

3DC_4.1.04A_2.thumb.jpg.c584f8937a5f88dda4bcd8b98bae6afb.jpg

Edited by druh0o
  • Like 1

Share this post


Link to post
Share on other sites

@Carlosan

@druh0o

I don't think that's true. I tested the same old version that you are using & the same problems are still there.

Your screenshot shows that you did the self intersect test incorrectly. In your screenshot you have "Sharp Shape (Old Style)" setting disabled. When you have it disabled, the self intersect result is correct, there was never any problems with that. But the alpha texture is NOT correct. Try enabling Sharp Shape (Old Style) & compare the results. And try it with the softest brush alpha, there's a huge difference.

When the setting is enabled, you get the self intersect issue. There is no way to have the correct alpha & the correct self intersect result. 

Here are my tests with the old version (Softest brush alpha, both brush strokes use the same settings for brush size & everything).

 

Screenshot from Old 3D Coat.png

  • Like 1

Share this post


Link to post
Share on other sites

Dev team is working on it

  • Thanks 1

Share this post


Link to post
Share on other sites

I don't want to be too annoying, but is there any news on that?

  • Like 1

Share this post


Link to post
Share on other sites

Hi 

Dev team is working fast to finish a new version as stable as possible. Lot of bug fixing is done.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×