Jump to content
3DCoat Forums
Sign in to follow this  
Wasili

Textures are saved black

Recommended Posts

Your model have uvmap and shaders baked ?

If not, you are Vertex painting the model

 

 

  • Like 1

Share this post


Link to post
Share on other sites

If i remember well, was a bug on version 4.8.03

Try updating to latest version 4.8.28 and try again

 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, haikalle said:

If you use Textures->Export->Color map option, does that also give a black texture?

Yes, so I tried it too, the result is the same. I also deleted this folder on your advice but nothing has changed

Share this post


Link to post
Share on other sites

I wonder why your object is invisible in last video? 

I checked your first video again and it seams that your painting your voxel object in there.

Also I see that you have two objects in "paint objects" Does your object include two meshes?

Edited by haikalle

Share this post


Link to post
Share on other sites

You have 2 Surface Materials, delete the empty one Default1 

If you are using PBR metalness check if are working on the right workflow 

View > Metalness is showing that there isnt any map painted

Add metalness to paint over that map

 

 

 

 

 

 

Surface materials.jpg

workflow.jpg

8.jpg

Metalness.jpg

  • Like 1

Share this post


Link to post
Share on other sites

UVs are ok, process is correct.

 

UVs.jpg

  • Like 1

Share this post


Link to post
Share on other sites
On 11/29/2018 at 6:18 PM, Carlosan said:

You have 2 Surface Materials, delete the empty one Default1 

If you are using PBR metalness check if are working on the right workflow 

View > Metalness is showing that there isnt any map painted

Add metalness to paint over that map

 

 

 

 

 

 

Surface materials.jpg

workflow.jpg

8.jpg

Metalness.jpg

I checked everything you said but still don't know what the matter is and what I have to do. I still have textures saved black. And take a look, for some reason in the texture I can draw and on the model can not http://take.ms/iUlrf 

Share this post


Link to post
Share on other sites
1 hour ago, Carlosan said:

Deselect export constructor shown in picture. You will get a new menu.

Make sure "Store gloss/roughness in Metal alpha is deselected.

This will export all your maps correctly. 

cycles.PNG

Thank you! I removed this tick, now works) And why in texture editor paints and does not paints on the model?

  • Like 1

Share this post


Link to post
Share on other sites

Could you have set tiling = off ?

Share this post


Link to post
Share on other sites
7 hours ago, Carlosan said:

Не могли бы вы установить tiling = off ?

I can't find where it is. Somewhere in the texture editor?

Share this post


Link to post
Share on other sites
2 hours ago, Carlosan said:

Look at Preview Options

 

PreviewOptions.jpg

I can include this Preview options only together with the Smart Material. By the way I've been wanting to ask how to еnable this Preview options without Smart Materials?

Here I click on the tyling but how does it work?

   http://take.ms/P30Mc

Share this post


Link to post
Share on other sites

Preview options is included on Brush and fill tool only with the Smart Material.

Use camera projection -noy cube mapping- to see how tiling work.

Remember that all your questions are answered in the manual. Please take a look.

  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, Carlosan said:

Preview options is included on Brush and fill tool only with the Smart Material.

Use camera projection -noy cube mapping- to see how tiling work.

Remember that all your questions are answered in the manual. Please take a look.

Thanks for the link to the manual but still why does not draw on the model? Here's another record from the screen, here I change different projections http://take.ms/L1h0r

Share this post


Link to post
Share on other sites

Try deleting options.xml on ...\user\Documents\3D-CoatV48

If you still keep using version 4.8.03 i can not help anymore, because several bugs was fixed on latest version. Please use it , sorry.

Share this post


Link to post
Share on other sites
8 minutes ago, Carlosan said:

Try deleting options.xml on ...\user\Documents\3D-CoatV48

If you still keep using version 4.8.03 i can not help anymore, because several bugs was fixed on latest version. Please use it , sorry.

I understand, but I have the latest version does not display materials. I sent you a scene, you said you'd test and tell me why, but I didn't get a response from you.

Share this post


Link to post
Share on other sites

Sorry but i cant replicate this issue. 

I can paint without any trouble over your model.

What if you begin a new scene using any default model to test Paint room ? (Shift+M)

Paint.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Carlosan said:

Извините, но я не могу повторить эту проблему. 

Я могу рисовать без каких-либо проблем с вашей моделью.

Что делать, если вы начнете новую сцену, используя любую модель по умолчанию, чтобы протестировать комнату Paint? (Shift + M)

Paint.jpg

The new model draws without problem  http://take.ms/TJMRv  It seems to be a bug and I would gladly draw in the new version of 3d coat but in the new version I have all objects invisible

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×