Jump to content
3DCoat Forums
amaekt

[Solved] Mesh imported with differents results

Recommended Posts

Hi,

With a co-worker, we are working together on some sculpt, and at some point I needed to import one mesh of his own for sculpt.

But every time I import his mesh, the Clay shader looks very different from his 3D Coat scene from mine.

We checked scale, render settings and shader settings. We reset all settings too, but it still won't work.

Here are our steps when creating a new scene for sculpt:

1. New -> Surface sculpting

2. I choose my mesh here (.obj)

3. The "Tool Options" window is opened, I check nothing will change my scale and Apply

4. The window which ask me to keep dimensions for export is opened : I press "Yes"

5. I go in Draw mode, then assign the Clay shader

 

My co-worker did exactly the same and his result is very different from mine..

 

The only difference between us for settings is the object scale which is a value of 1 for my co-worker as mine turn to 0.03 when imported, and we can't explain why. 

3DC_Prb.thumb.jpg.e16f58d0beebb83b3378770fede886af.jpg

 

Share this post


Link to post
Share on other sites

I tried to apply the same HDR, with same light intensity but it doesn't help. The normal scale for the noise is much bigger than his, which is weird.

We are both in "GGX, Lambert", but even if we changed it for "GGX, Burley" with "Greyscale Panorama" activated, it won't change a bit.

And now a new problem appears: my light burns everything at 100% of intensity when I import a mesh with Clay shader assigned. My co-worker has the same amount of lighting but his scene is clean, I don't understand. I start to think the problem come from the Clay shader since the light won't burn my mesh with other shaders..

3DC_Prb_02.thumb.jpg.973c560d5eb331533b7d8656ca47bc71.jpg

I tried to uninstall 3D coat (V4.8.25), and I even tried to install V4.8.32 too, but the problem remains.

My co-worker had the same problem on his personal computer, but he installed the V4.8.32 and never met this problem again.

 

The only difference which keeps to occur is the "object scale" which is still different between our 2 scenes after a new import of the same mesh. Mine change all the time but my co-worker's stay at a value of 1. So I don't understand what is this "object scale"?

Share this post


Link to post
Share on other sites

Its possible to create the project on one machine and share .3b file opening it file with the other machine ? 

Some many variables, i am shotting in the dark, sorry.

 

Share this post


Link to post
Share on other sites

Yes, that's how we proceed for now: my co-worker create the scene where the mesh is imported, then share it with me.

This way the Clay shader is working perfectly, but not when I am the one to create the scene and import the mesh.

 

Thanks for your time in this case :)

Share this post


Link to post
Share on other sites

It seems that at one point you might have edited the permanent proprieties of your clay shaders, since you only have this issue on your machine, and only with this specific shader.

And since such user modifications are saved in a subfolder of your user account Documents, they are not deleted when uninstalling 3dCoat. Hence the persistence of this issue. That's where I'd suggest you to investigate, at least, as I don't see what else could be the cause.

Edited by Ambershore

Share this post


Link to post
Share on other sites

Are both computers using same contrast of lighting ?

Try reset settings command on both machines, hope it help.

 

Contrast.jpg

Reset settings.jpg

Share this post


Link to post
Share on other sites

That's what we thought, so we checked the permanent settings for the Clay shader, but they are both exactly the same.

And in fact, my light turn to be very violent for any shader, but I didn't see it since it wasn't burning as much as the Clay shader.

 

How could I delete these user modifications, so I could have clean settings when install 3D Coat again?

 

We checked for contrast, and even reset settings many times, but it won't change a thing.

 

Share this post


Link to post
Share on other sites

Both PCs use same graphic card  and drivers are up to date ?

Could try changing His computer to 3DC-DX version, not 3DC-GL version ?

Delete files options*.xml inside C:\Users\user\Documents\3D-CoatV48 to clean user settings

Share this post


Link to post
Share on other sites

Yes, we both have GeForce GTX 1050 Ti, and the last update (417.71).

We work on GL version since we met some problems when using DX version. But we already try to do the same with the DX version, and still have the same problem.

 

BUT! I just uninstalled 3D Coat again, but this time I deleted the 3D-CoatV48 folder too (thank you for the path) and now it's working!

Something probably turned bad at some point, I don't know why, but now it's working and it's all that matter.

 

Thank you greatly for your help, I would still be stucked here without you :)

Have a wonderful day!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×