Jump to content
3DCoat Forums
dreamparacite

[Solved] Single meshes import with multiple colors (UV room)

Recommended Posts

Hello 3D Coat forum,

I'm trying to use primarily 3D Coat and Blender at home and it has been going well so far, but on this one scene I'm working on some meshes I imported from blender will have different UV separations without any seams. Here is an example:

317836484_2019-01-2711_53_47-tricky_and_gorf_unwrap.3b_-3D-COAT4.8.25(DX64).thumb.png.ea4086885e5caabfdad2694f70af9542.png

This mesh has no seams marked and normally when this happens it is that the faces are not connected on the model. However, going back to blender I can grab a face and move it and it is clearly connected to the others. I also did a "remove doubles" action on all the vertices to make sure I didn't have any overlapping but unconnected vertexes, and nothing was wrong there. Does anyone know why this is happening, or how I could fix this in 3D-Coat or Blender 2.8? All I did to create this was I had the green faces originally, then I did an extrude by normals.

 

This happened on another piece of geometry as well but the different colored patch didn't reveal itself until I marked a seam loop, yet it was the same in that the faces were connected and I didn't seem to have any non-manifold geometry.

 

I've attached the obj to see if anyone knows what is up. Just open 3D-Coat and import it for uv mapping and it should import with the same face issues I mentioned. I'd like to know the real cause of this so I can fix my meshes before the uv mapping stage. Thanks in advance.

 

(Also unrelated but it would be nice if the Clear Seams button had an option to just clear seams from the active or visible paint object, sometimes objects import with ridiculous seams already marked and it takes quite a while to unmark the seams, but you don't want to lose seams from the objects you've already done. Just a suggestion.)

face_problems.obj

Share this post


Link to post
Share on other sites

Hi 

I imported the model in Blender and the faces are not connected on the model.

May be you exported the model with apply modifiers option switched on ?

 

cut.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites

Hello Carlosan, thanks for the reply! You know what, I think that's exactly what happened. I've already been tripped up from the "export selected" option being unchecked by default, and I didn't realize that the modifier I was using to get hard/soft edges (edge split) was being applied on export. I was using that modifier to get hard/smooth shading (I come from primarily using Maya). This also explains why my faces were connected in Blender but not in 3D-Coat. Thank you for the quick reply, I'll be wary of my modifiers when going between programs now.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×