Jump to content
3DCoat Forums

[Solved] 3DC-printing does not run on my Mac


Recommended Posts


Is this information useful for you ?

Ensure to check "System Preferences > Security & Privacy > click the "lock" > select "App Store and identified developers" (when only "App Store" is selected error message is displayed "3DCoat" can't be opened because it was not downloaded from the App Store)

3DCoat crashes on startup

Link to comment
Share on other sites

  • New Member

Thanks for your reply Carlosan!

Unfortunately, that is not the issue, I think. "App Store and identified developers" is currently checked in my Security & Privacy settings.


I opened the Package Contents of the application and ran the "3D-Coat" file inside the "MacOS" folder, and the application runs! (as long as I keep the terminal running.) It does give me this message in return, if anyone knows what it means:

objc[66672]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fff895fdcd0) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x11ea69cd8). One of the two will be used. Which one is undefined.


Any ideas?


Link to comment
Share on other sites

In Terminal clear quarantine attribute from folder "3DC-printing-1.1.09":
$ xattr -dr com.apple.quarantine /Applications/3DC-printing-1.1.09/*
If that didn't work do the following:
1. Check integrity of downloaded image:
File size is 142,312,944 bytes. Terminal command $ shasum 3DC-printing-1.1.09.dmg returns
2. Remove quarantine attribute from download image:
$ xattr -d com.apple.quarantine 3DC-printing-1.1.09.dmg
$ ls -l@ 3DC-printing-1.1.09.dmg
(attribute "com.apple.quarantine" should gone)
3. Remove previous folder "/Applications/3DC-printing-1.1.09". Copy "3DC-printing-1.1.09" from disk image with cleared quarantine attribute into "/Applications" again.

Link to comment
Share on other sites

  • Carlosan changed the title to [Solved] 3DC-printing does not run on my Mac

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...