Jump to content
3DCoat Forums

Recommended Posts

On 12/19/2020 at 12:30 AM, kevjon said:

I found a workaround solution to the missing smart materials (if you have the windows installation of 3dc)

Copy the folder "patterns" from 3D-CoatV49 (in windows) to 3D-CoatV49 (in Linux). For some reason the "patterns" file in the 4.9.66 linux download is 0 bytes when extracted.

Thanks, it worked!

After fiddling around a bit to get to a windows machine I tired it and it worked. It shouldn't have to be this way but, for now, it does the trick. Thanks again!

Edited by Allabulle

Share this post


Link to post
Share on other sites

Oh, sadly the issue with the missing Smart Materials is still there in the newer 4.9.68 build. Maybe for the next round, then.

Also, has anyone experienced quite low performance when voxel sculpting?

Here's how to check:

- Start a fresh scene

- Pick Voxel Sculpting from the Greeting Window

- Now, choose the Full Human Male figure (just to the left of the Head figure)

- Try to sculpt over the male figure with Vox Clay (with any brush)

- It lags considerably when trying any stroke length. At small bursh sizes it's working decenty, but not great. Not completely unusable, but almost.

[This on a system with an 8c/16th CPU, 32GB RAM, GTX 1080 and GTX Titan X, running Ubuntu 20.04 with 450.80.02 nVidia drivers]

Share this post


Link to post
Share on other sites
On 12/20/2020 at 10:48 PM, Allabulle said:

Oh, sadly the issue with the missing Smart Materials is still there in the newer 4.9.68 build. Maybe for the next round, then.

Also, has anyone experienced quite low performance when voxel sculpting?

Here's how to check:

- Start a fresh scene

- Pick Voxel Sculpting from the Greeting Window

- Now, choose the Full Human Male figure (just to the left of the Head figure)

- Try to sculpt over the male figure with Vox Clay (with any brush)

- It lags considerably when trying any stroke length. At small bursh sizes it's working decenty, but not great. Not completely unusable, but almost.

[This on a system with an 8c/16th CPU, 32GB RAM, GTX 1080 and GTX Titan X, running Ubuntu 20.04 with 450.80.02 nVidia drivers]

Update:

So I used a spare hard drive to install and try the same procedure in Windows, with current Nvidia drivers, and it behaves exactly the same. So not a regression for the Linux version.

It's been quite a while since using 3DCoat so not sure yet what's specific to the Linux builds that we can now use or what's expected from the software as a whole. It has evolved quite a lot.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 12/20/2020 at 3:48 PM, Allabulle said:

Oh, sadly the issue with the missing Smart Materials is still there in the newer 4.9.68 build. Maybe for the next round, then.

Also, has anyone experienced quite low performance when voxel sculpting?

Here's how to check:

- Start a fresh scene

- Pick Voxel Sculpting from the Greeting Window

- Now, choose the Full Human Male figure (just to the left of the Head figure)

- Try to sculpt over the male figure with Vox Clay (with any brush)

- It lags considerably when trying any stroke length. At small bursh sizes it's working decenty, but not great. Not completely unusable, but almost.

[This on a system with an 8c/16th CPU, 32GB RAM, GTX 1080 and GTX Titan X, running Ubuntu 20.04 with 450.80.02 nVidia drivers]

I wonder if missing Smart Materials in this new versions has to be with the new materials store. Ergo, a change of business model, similar to Quixel's model... What do you think?

Share this post


Link to post
Share on other sites
3 hours ago, 3dlancer said:

I wonder if missing Smart Materials in this new versions has to be with the new materials store. Ergo, a change of business model, similar to Quixel's model... What do you think?

So, I solve the smart material issue under Ubuntu 20.04 and 3DCoat 4.9.69. Just manually create the folder "pattern" under Documents/3d-CoatV49/ then copy the patterns files from my 4.8 version (home/3D-CoatV48/patterns/) from my home folder...

Now it shows my smart materials. Hope that made sense. Regards. 

  • Like 1

Share this post


Link to post
Share on other sites
On 12/20/2020 at 3:48 PM, Allabulle said:

Oh, sadly the issue with the missing Smart Materials is still there in the newer 4.9.68 build. Maybe for the next round, then.

Also, has anyone experienced quite low performance when voxel sculpting?

Here's how to check:

- Start a fresh scene

- Pick Voxel Sculpting from the Greeting Window

- Now, choose the Full Human Male figure (just to the left of the Head figure)

- Try to sculpt over the male figure with Vox Clay (with any brush)

- It lags considerably when trying any stroke length. At small bursh sizes it's working decenty, but not great. Not completely unusable, but almost.

[This on a system with an 8c/16th CPU, 32GB RAM, GTX 1080 and GTX Titan X, running Ubuntu 20.04 with 450.80.02 nVidia drivers]

Just installed 4.9.69 on Ubuntu and don't have any lag so far. I reproduce the scene and can sculpt without issue. Hope this version works for you as well. 

 

Share this post


Link to post
Share on other sites
14 hours ago, 3dlancer said:

Just installed 4.9.69 on Ubuntu and don't have any lag so far. I reproduce the scene and can sculpt without issue. Hope this version works for you as well. 

 

Thanks!

I've just tried again with 4.9.69 and it does, apparently, the same. In my case, it's mostly brush size dependant. Large radius brushes lag considerably. More moderate brush sizes work well, though.

Example: setting the brush size to approximately match the scale of the head, it lags. Setting the radius then to the scale of what would be an ear, it works pretty well. And a bit tinier and it works absolutely smoothly.

It may also depend on other factors, like machine, operating system... Just guessing.

Thanks again for trying it out, 3dlancer.

Edited by Allabulle

Share this post


Link to post
Share on other sites
5 hours ago, Allabulle said:

Thanks!

I've just tried again with 4.9.69 and it does, apparently, the same. In my case, it's mostly brush size dependant. Large radius brushes lag considerably. More moderate brush sizes work well, though.

Example: setting the brush size to approximately match the scale of the head, it lags. Setting the radius then to the scale of what would be an ear, it works pretty well. And a bit tinier and it works absolutely smoothly.

It may also depend on other factors, like machine, operating system... Just guessing.

Thanks again for trying it out, 3dlancer.

You're welcome. And I believe your guess is right. I had that kind of issue with my old machine, years ago. I tried again and change the size of the brush similar to the head, and still perform well. 

Also, I found a bug, not sure it is here where I should report it. On any conditions I can't make 3DCoat to calculate Curvature or Cavity data on Paint room. It close the program on each attempt. Using 4.9.69. 

Calculate Cavity is needed to use smart material. Wonder if anyone else has the same issue, or it is just me. Thank you!

 

Edited by 3dlancer

Share this post


Link to post
Share on other sites
On 1/6/2021 at 12:44 PM, 3dlancer said:

You're welcome. And I believe your guess is right. I had that kind of issue with my old machine, years ago. I tried again and change the size of the brush similar to the head, and still perform well. 

Also, I found a bug, not sure it is here where I should report it. On any conditions I can't make 3DCoat to calculate Curvature or Cavity data on Paint room. It close the program on each attempt. Using 4.9.69. 

Calculate Cavity is needed to use smart material. Wonder if anyone else has the same issue, or it is just me. Thank you!

 

Never mind, I found what cause that issue. My fault indeed. I didn't check on the option View ⇾ Show Voxels in Paint Room and also some of my sculpts parts was in ghost mode. 

So, if sculpts are not visible and solid in paint room, 3DCoat might crash when calculates Cavity/Curvature texture. A Dah! for me. LOL!

Share this post


Link to post
Share on other sites

Got linux version up and running on Ubuntu 20 but I don't have pressure sensitivity.  I changed the little mouse icon over to pen and locked it.  I also checked stroke type but that doesn't really matter because no amount of pressure makes a difference.  Any help/suggestions?

Share this post


Link to post
Share on other sites
8 hours ago, lambertj21 said:

Got linux version up and running on Ubuntu 20 but I don't have pressure sensitivity.  I changed the little mouse icon over to pen and locked it.  I also checked stroke type but that doesn't really matter because no amount of pressure makes a difference.  Any help/suggestions?

It works here, with two different Wacom tablets.

Could you elaborate on what doesn't work and what you do exactly, to test it?

Share this post


Link to post
Share on other sites

Thanks @Allabulle.  So, I downloaded the latest linux build and installed it on a fresh new Ubuntu 20 LTS setup.  I installed spacenavd and a few other libs called out here in this forum.  3DCoat launches perfectly but won't recognize pressure sensitivity (painting nor sculpting).  Krita and Blender both recognize pen pressure.

Share this post


Link to post
Share on other sites
On 1/30/2021 at 12:30 AM, lambertj21 said:

Thanks @Allabulle.  So, I downloaded the latest linux build and installed it on a fresh new Ubuntu 20 LTS setup.  I installed spacenavd and a few other libs called out here in this forum.  3DCoat launches perfectly but won't recognize pressure sensitivity (painting nor sculpting).  Krita and Blender both recognize pen pressure.

What input device are you using?

It works fine with my two wacom.

Share this post


Link to post
Share on other sites
10 hours ago, lambertj21 said:

@Allabulle, huion 16 pro.

Have you tried with these drivers? --> https://pypi.org/project/kamvas-driver/

There's an explanation in the disscussion about installing the drivers successfully in Ubuntu here: https://askubuntu.com/questions/1250689/is-huion-kamvas-pro-13-supported#1250692

I can't be of much help since I don't own a Huion tablet, but the problem looks like a driver issue to me. It may be worth a try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×