Jump to content
3DCoat Forums

[Solved] Import Mesh for retopology from Zbrush turns all weird and soft


aemanly
 Share

Recommended Posts

  • Member

Hello

I'm sculpting in zbrush, exporting as .obj and then importing to 3D Coat for manual retopololgy.  However, when I import the .obj in 3D Coat, what I get is like a soft, inflated version of my object.  It works fine when I open it zbrush again.  Any ideas?

Apologies if this is a dumb question or in the wrong spot, I'm new to 3D Coat and this forum

Thanks!

Mesh in 3D coat.png

Mesh in Zbrush.png

Link to comment
Share on other sites

  • Member

When you export form Zbrush as OBJ, you either export with or without smoothing normals, so 3DCoat not seeing anything probably applies the smoothing automatically. That's what you do when you import as reference object, you don't get any setting, so you can't import it with the "auto smoothing groups" set to 0, like you could if you imported as a normal paint object.

You can also try to do it with Importing the mesh into the Sculpt room w/o voxelization which is better to import in my opinion, then you can do the shader trick. Which is always nice since you can always go and add more detail and keep sculpting.

But you have to understand ZBrush doesn't do smoothing groups inside ZBrush, so you are the one who tell Zbrush what to do, like you usually want soft edges everywhere but in this case you don't. So,  the only way to do what you want is to use FBX since you can export with smoothing set to 0 or 100. so it always exports with smoothing groups on it and 3DCoat will be able to read them well. With OBJ, only exporting to Maya or whatever software you use and then re-export it with the hard edges would be the only way.

 

 

Edited by Emi
Link to comment
Share on other sites

  • Member
43 minutes ago, Emi said:

You can also try to do it with Importing the mesh into the Sculpt room w/o voxelization which is better to import in my opinion, then you can do the shader trick. Which is always nice since you can always go and add more detail and keep sculpting.

 

When I try to import the mesh for Voxelization, all i see is the transform gizmo, no mesh.  I'm not sure what I'm doing wrong

 

Link to comment
Share on other sites

  • Member

If I do file>Import Object into the retopo room, and then do the same thing in the sculpt room, I am able to get the object to come up in the sculpt room with the correct looking topology.  However, going back to the retopo room brings back the smoothed model.  I feel I'm getting close.  If I can just get the correct one in the correct room.

Link to comment
Share on other sites

  • Advanced Member
6 minutes ago, aemanly said:

Thanks for the pictures.  Those were helpful.  But the shaders don't seem to be doing anything.  Even why I try to apply to visible.

The object can be already on default shader so you don't see any change.  Try edit the shader setting see if it changes to flat shade.

Link to comment
Share on other sites

  • Member
Just now, animk said:

The object can be already on default shader so you don't see any change.  Try edit the shader setting see if it changes to flat shade.

Does not do anything.  I try applying different shaders and nothing changes

Link to comment
Share on other sites

  • Advanced Member
4 minutes ago, aemanly said:

Does not do anything.  I try applying different shaders and nothing changes

did you hit "apply" button in tool option menu when you import your obj?

Edited by animk
Link to comment
Share on other sites

  • Member
6 minutes ago, animk said:

did you hit "apply" button in tool option menu when you import your obj?

Ah! that worked! Kind of... It has kind of a double mesh thing going on but I think it's good enough for me to do my retopology on!  Thank you so much!  Can't wait to get going with this one!

Screen Shot 2019-04-09 at 10.30.15 PM.png

Screen Shot 2019-04-09 at 10.30.00 PM.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...