Jump to content
3D Coat Forums
Sign in to follow this  
polynut

[Solved] Making alpha from current sculpt not working ?

Recommended Posts

Hi guy's,

Trying to make an alpha brush from my sculpt and the use 3d model window doesn't show my object, i tried fiddling with the various axis, rotation and depth but nothing show up. I did another one that was from a sphere where i did some cutoff and it work but this one in the image don't show at all so any help would be appreciated.

I also tried to rotate the cube so the sculpt appear on top instead of front view and again nothing show in the alpha capture window.

I managed to make it work but honestly i don't have single clue why it finally work since i was simply drag and dropping from voxel layer to model palette and the dialog box for decimating open after many try.

I also have another issue since the hand sculpture appear very fainted and when i edit it in 16 bits in photoshop it"s almost not visible even playing with levels or exposure the sculpted hand was not pronounce like the former alpha i made who was clearly visible and i notice with the same procedure that when clicking on edit 16 bits i get 4 alpha channels in photoshop instead of 1?

It is very frustrating since i cannot get to speed at all since i always need to come here making a post since i cannot find any info by typing it in Google.

 

 

alpha problem.jpg

Edited by polynut

Share this post


Link to post
Share on other sites

The method you are using is for a external model to be used as an alpha creation.  It will not create an alpha out of a sculpt room object.

To create an alpha from a sculpt room object do this:

File menu in the sculpt room.

Choose export depth along  Y.

Make sure your model is facing Y up and centered in world space. 

 Set your texture size and the patch size which is the size of the alpha in the image.  Smaller patch size numbers will increase the amount your sculpt alpha fills the inside of your texture image space.

Test a few times till you get the hang of it.

I like to use tiff as it creates a 16 bit image. 

Note: Color can be deselected in the dialog box unless you want a separate color image too.

Share this post


Link to post
Share on other sites
6 hours ago, digman said:

The method you are using is for a external model to be used as an alpha creation.  It will not create an alpha out of a sculpt room object.

To create an alpha from a sculpt room object do this:

File menu in the sculpt room.

Choose export depth along  Y.

Make sure your model is facing Y up and centered in world space. 

 Set your texture size and the patch size which is the size of the alpha in the image.  Smaller patch size numbers will increase the amount your sculpt alpha fills the inside of your texture image space.

Test a few times till you get the hang of it.

I like to use tiff as it creates a 16 bit image. 

Note: Color can be deselected in the dialog box unless you want a separate color image too.

Hi Digman and thank for pointing this out since you are a god sent on this forum with your astounding knowledge of 3d coat that is unfortunately not very well documented.

I managed to play with it but there is few thing i don't understand about it :

1- When i chose tif or tiff format it's show as an 8 bits in photoshop and i don't see any options to set the tif bits in the export window?

2-Upon export it's look like a normal map image with the purple color and i don't see any depth image so if i just desaturate it will it act as a heightmap?

There is also the exr option so i will try this to see what i can get out of it.

Edit: Exr work well except that it is a 32 bits format making huge file and you have to do another manipulation in Photoshop if you want to drop it to 16 bits.

Edited by polynut
more info

Share this post


Link to post
Share on other sites

I get a 16 bit tiff in my exporting. 3DC version 4.08.40.  Affinity Photo and Irfanview both read the tiff file as 16 bits.

Maybe you have selected to export a normal  map as well as you stated you also have a blue color image. There needs to be no selection of any other image type in the dialog panel. By default it will export the alpha.

If you are invoking Photoshop inside of 3DC to adjust the alpha it will be converted to 8 bits. 

I do my adjusting outside of 3DC for the alphas so they retain 16 bits.

Share this post


Link to post
Share on other sites

Hi Digman,

You were right it was 8 bits because i still had the normal map selected in the export dialog now it show as a 16 bits depth image in photoshop.

I did a quick gif to help other if they stumble in this post so many thank to you for clearing this one up

 

export-depth.gif

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×