Jump to content
3D Coat Forums
Sign in to follow this  
polynut

How can i hide wireframe on retopo object?

Recommended Posts

Hi guy's,

I did some quick test with the autopo algorithm but i cannot figure out how to hide the black wireframe on the autopo object and it made it impossible to visualize the model retopo properly?

Also how can i change the color for the retopo mesh?

I hope i am not going to be obligate to send the model to my 3d app to be able to see it properly since it is counter productive.

autopo wireframe.jpg

Share this post


Link to post
Share on other sites

As far i remember, is not possible to hide wireframe on retopo objects.

Share this post


Link to post
Share on other sites
5 hours ago, Carlosan said:

As far i remember, is not possible to hide wireframe on retopo objects.

I am stunned since this is consider basic feature in most 3d app!

Share this post


Link to post
Share on other sites

I found a dirty workaround for those who might stumble on this thread :

It's not elegant but for quick preview without annoying wireframe it work and it is faster than having to export in 3D app.

This feature should be basic in retopo room ; hiding wireframe for preview and having option to change retopo mesh color.

retopo_preview.gif

Share this post


Link to post
Share on other sites
14 hours ago, polynut said:

I am stunned since this is consider basic feature in most 3d app!

I done a lot of Retopo work over the years and not once have I ever needed to turn wireframe off, during the Retopo phase. You do that in the Sculpt and Paint Room, but in the Retopo workspace, it has no real use, nor does applying shaders or materials....until you are done with the Retopo phase.

Share this post


Link to post
Share on other sites
11 hours ago, AbnRanger said:

I done a lot of Retopo work over the years and not once have I ever needed to turn wireframe off, during the Retopo phase. You do that in the Sculpt and Paint Room, but in the Retopo workspace, it has no real use, nor does applying shaders or materials....until you are done with the Retopo phase.

Many artists like to hide the wireframe when in retopo mode and they also change the retopo mesh color. Any software should always give the option to the artist to hide certain features or change color.

Previewing the mesh without wireframe has many advantages like seeing proper edge flow and contour on certain type of geometry or simply to see if certain details are correctly showing specially with autopo.

My dirty workaround was inspire by the one you show me in my thread about grabbing depth object.

Share this post


Link to post
Share on other sites
On 7/9/2019 at 10:36 AM, polynut said:

I am stunned since this is consider basic feature in most 3d app!

We can't be talking about the 'eye' in Retopo objects panel? It hides the mesh in that object.

Share this post


Link to post
Share on other sites
9 hours ago, Tony Nemo said:

We can't be talking about the 'eye' in Retopo objects panel? It hides the mesh in that object.

He's talking about previewing the retopo mesh without Wireframe. That's just not practical in a RETOPO-ONLY environment. That's why I've personally never seen a need for it, nor has anyone else bothered to request it, AFAIK. You generally bake (3DCoat bakes and sends a copy to the Paint Room, ready to paint) to preview the mesh. If you don't like the bake result, you delete the Paint Object > clear any empty paint layers by clicking the X icon at the bottom of the LAYERS panel > go back to the Retopo Workspace > make adjustments to the mesh or baking cages and try again.

One reason why there is no wireframe toggle is because it would be too hard to distinguish between the underlying voxel object, while creating the Retopo meshes. I have no problem with such a request, just the criticism of the app for not already having it. It's for a reason.

Share this post


Link to post
Share on other sites

Well if i am the only one who think this feature would be welcome than who are the other who vote for it on trello? I come from 3ds max and in max we really appreciate the ability to toggle the wireframe on  and off and to change object color for previewing purpose. I am not talking about the doing the whole retopo with wireframe hidden just having the option for previewing purpose without having to change room or export model to other app.

Also i am not bashing 3d coat in any way here i was just stunned like i have said because we are so use to this kind of features in other apps that we think it's somewhere in the options.

3D coat is an amazing set of tools but i realize like every other app out there that i would need to use multiple software in my pipeline since not a single one is a complete solution unfortunately.

Share this post


Link to post
Share on other sites

Ok another workaround.

Go to the Sculpt room----"Import tool" in the left sidebar tool panel under "Objects"

From the dialog box, choose "PIck from Retopo". This will show you a non-wireframe view. Hide the sculpt room object first.

Keep the dialog box open and switch back to the Retopo room. Make any adjustments if needed. 

Return to the sculpt room and pick from retopo again in the dialog box. The mesh will be updated. 

Once done, simply choose another tool and the retopo mesh will not be imported into the sculpt room.

 

Side Note:  If you want to import the retopo mesh and look at it as a sculpt object using the same method just Choose import without voxelization.  Do not subdivide. This way your imported retopo model will not change shape.

The above is a workaround but you do not need to leave 3DC. 

You can change the retopo color. Top Tool panel  after (after opacity) "Colors"- Select the very first color in the top left row. Double click it to change the color. That will become the default retopo color before adding any uv seams. I use a darker grey as the neon green blows my eyes out. LOL.

Add your feature request for a non wireframe toggle switch.

 

  • Like 1

Share this post


Link to post
Share on other sites

By the way sorry for the English orthographic mistake since for some reasons i am not aware i cannot edit my posts anymore! I often come back to my threads to correct my bad English.

Edited by polynut
error

Share this post


Link to post
Share on other sites
1 hour ago, digman said:

Ok another workaround.

Go to the Sculpt room----"Import tool" in the left sidebar tool panel under "Objects"

From the dialog box, choose "PIck from Retopo". This will show you a non-wireframe view. Hide the sculpt room object first.

Keep the dialog box open and switch back to the Retopo room. Make any adjustments if needed. 

Return to the sculpt room and pick from retopo again in the dialog box. The mesh will be updated. 

Once done, simply choose another tool and the retopo mesh will not be imported into the sculpt room.

 

Side Note:  If you want to import the retopo mesh and look at it as a sculpt object using the same method just Choose import without voxelization.  Do not subdivide. This way your imported retopo model will not change shape.

The above is a workaround but you do not need to leave 3DC. 

You can change the retopo color. Top Tool panel  after (after opacity) "Colors"- Select the very first color in the top left row. Double click it to change the color. That will become the default retopo color before adding any uv seams. I use a darker grey as the neon green blows my eyes out. LOL.

Add your feature request for a non wireframe toggle switch.

 

Thank a lot Digman i will give it a shot tomorrow.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×