Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.9 BETA testing thread

Recommended Posts

I have some issues with 4.9.15 build:

- tangent smooth doesn't work - there is notification, that I'm trying to paint on invisible layer.

- it seems that sculpt layers are active(paint room), while disabled in preferences

- gpu whine - doesn't matter if VSync is enabled in 3DC preferences or NVidia Control Panel

Share this post


Link to post
Share on other sites

23.12.19 4.9.17 (stable)

- Much much faster Res+ command

- Cube retopo primitive parameters fixed

- Fixed black areas outsode the realtime padding (not so critical, but looks better in UV window).

  • Like 4

Share this post


Link to post
Share on other sites
5 hours ago, Andrew Shpagin said:

- Much much faster Res+ command

Thank you for making Subdivision (RES +) faster.

@Andrew Shpagin Unfortunately, I need to report to you the following error that happened to me:
I just chose the (bigger) ball on the Surface Mode Splash Screen. After that I started working with Clay Brush (nothing serious) to test the subdivision (VoxTree = Res +).


1) Positive point:
Up to 34.4 million polygons, 3D-Coat was able to subdivide faster. (Just a little delay when it reached 34.4 million, but successfully.)

2) Negative point:
I tried to subdivide one more time and 3D-Coat gave me an error and crashed the program.

PC Configuration:
Ryzen 3900X, 128GB RAM, SSD 2TB M.2 ADATA pro and RADEON VII graphics card (windows 10 pro).

image.thumb.png.a26f70890018f3ac64187915bd69eb38.png

image.thumb.png.cb287bc7a91deb5420e7b83f6afbb4e5.png

Share this post


Link to post
Share on other sites

4.9.17: For both DX and GL versions Ctrl+Z still doesnt work properly for the carve tool especially when you stroke away from the base model into the empty space. Usually deletes a previous stroke and sometimes leave voxels behind. Even deletes the base model if you undo your first stroke.

You guys keep ignoring this so I'll keep checking every new version and post the results.

 

Share this post


Link to post
Share on other sites

Is anyone aware of the bug in the retopo room where occasionally you will become unable to select/hide retopology object layers, and  have to switch to the sculpt room and then back in order to 'reset' things?

 

like the first indicator that something has gone wrong just visually is layers will either have their names duplicated, or move in the layer stack. Then, when you attempt to select a layer, or hide/show one, nothing will happen. When you then click on the sculpt room (presumably any other room outside of the retopo room) and then back, the problem will be solved temporarily.

Share this post


Link to post
Share on other sites

Hi, Unfortunately, I can't get past 30 million polygons in 3D-Coat. And that's if 3D-Coat allows me to have 30 million polygons.
I don't know if this is an error, but every time I try I get a critical error and before a message to increase virtual memory.

This is hard to understand because I tested and got in Blender 2.81:
201.326.595 triangles, but still sculpting.

image.thumb.png.786af8e480c60fa1c0b9a1def7404b3d.png

And by my curiosity, I tried one more subdivision level and Blender was able to subdivide and I got the result of 805.306.368 triangles (a little unstable).
image.png.2137d32c3109b91f4aea0fe9638b375f.png

So I don't know what to think... It's hard to think about, but isn't 3D-Coat able to subdivide into high amounts of polygons???  :(

Of course, it would not be to sculpt with a mesh with more than 30 million polygons, but so that I could be able to detail the surface of the mesh that I would have already sculpted and ready for the detailing process.

Share this post


Link to post
Share on other sites

I thought this was some kind of problem on new versions, but I also noticed that on my computer (gtx 1080 ti, 32 gb ram), on version 4.9.05 (stable) in the same mesh in surface mode, I can not even reach 20 million + polygons. When I try to split the mesh by more than 12-15 million, the program just freezes (I tried to wait 15 unforgettable and fun minutes in the hope that the program would "hang". This did not work). (gtx 1080 ti, 32 gb ram)

Edited by Dmitry Bedrik

Share this post


Link to post
Share on other sites

I thought this was still a problem with res+ in surface mode.
So, I tried to reach 200 million in voxels then switch to surface.
I was surprised, I could not achieve that.
I managed to reach 45 million with difficulty in voxel mode. Trying to get to 200 million from that using the pose tool resulted in a warning to save my work. So I didn't even get to try turning that to surface.

Share this post


Link to post
Share on other sites

 @lesaint I forgot to say that I tried to subdivide (Res +) in Surface Mode.
I totally forgot to test in Voxels mode because I was seeing that in Surface Mode it wasn't working as it could.

@Dmitry Bedrik  The same thing happened to me until the penultimate version.
The 3D-Coat simply crashed and kept calculating forever until "Not Responding ..." appears. I always had to leave the program since he didn't answer anymore.
In this latest version, 3D-Coat can subdivide (res +) faster to some extent, but it can't get past 16 - 30 million polygons.

My configuration is a Radeon VII, 128GB ram, ryzen 3900x, ssd m.2 2TB adata pro.
So it's odd to say that, but I'm glad I'm not alone in this situation, because otherwise I would be worried about a possible hardware issue.

I fear it is really a problem with this new version that has been redone.  :(
I would very much like these basic functions that exist in a 3d sculpting program to be seen. I believe developers will fix this in future releases.

I would just like to talk about this matter of the millions of polygons that 3D-Coat is failing to get, but I also need to share with you other things that I realized that are not working.

I don't know how many people use this tool, but in Surface Mode, there is the Copy tool.
This tool is able to copy details from one area to another and also has the advantage of simulating something similar to a "vector displacement", since you can select a part you want (eg ear) with the Freeze Tool and then paste as many times as possible you want and anywhere else on the surface of the mesh.
Unfortunately, this Copy Tool (which has existed within 3d-coat for many years) is completely full of bugs and errors to this day.
It is one of the most powerful tools within 3D-Coat, but unfortunately it is abandoned...

Share this post


Link to post
Share on other sites

Am I crazy, or does the color picker now pick ALL channels instead of just color now? Did it always do that, because I don't recall fighting the software for painting?

Share this post


Link to post
Share on other sites
5 minutes ago, Hdharris said:

Am I crazy, or does the color picker now pick ALL channels instead of just color now? Did it always do that, because I don't recall fighting the software for painting?

Yes It's been picking roughness/metal for a long time and that's really cool

Share this post


Link to post
Share on other sites
6 minutes ago, lesaint said:

Yes It's been picking roughness/metal for a long time and that's really cool

it's not for me because now I have to constantly reset things back or else my colors are wrong when I paint, and I have to constantly reset the roughness manually in order to paint according to the materials I use for handpainting, I'm pretty sure it used to JUST pick the color, is there any way to make it do just that? as it is it's pretty much unusable for handpainting like I used to do if this is intended behavior.

 

Unless there was a change in how it's handling material switching, because when I pick a material with a different roughness than I had before it just stays at the original roughness and doesn't work, and then when I use the v shortcut to color pick it acts as if the stroke has multiplication on and darkens the colors. I don't know what's going on but it wasn't doing this recently, like say 4.9.05

Edited by Hdharris
further clarification

Share this post


Link to post
Share on other sites
4 minutes ago, Hdharris said:

it's not for me because now I have to constantly reset things back or else my colors are wrong when I paint, and I have to constantly reset the roughness manually in order to paint according to the materials I use for handpainting, I'm pretty sure it used to JUST pick the color, is there any way to make it do just that? as it is it's pretty much unusable for handpainting like I used to do if this is intended behavior.

Yes of course, simply disable the black ball image.png.fb46af7c78b4d8de69b8fac9f9480aac.png

On the other hand, if you are using a smart material, it shouldn't be affected at all, surely ? so maybe there is a change there and that's what you're seeing

Edited by lesaint

Share this post


Link to post
Share on other sites

At bottom of Windows>panels menu you find an item that is there for the sole purpose of redefining the color picker key. If you look at its name you see clearly that it is picking all those channels

image.png.cb3920efd227752e0868c3c2a98fbb1f.png

Share this post


Link to post
Share on other sites

Version 4.9.17, Stamp  mode(E panel) is very choppy/laggy - it's very hard to control it's behaviour and it also changes depth while dragging.

Edited by Mihu83

Share this post


Link to post
Share on other sites

1.1.20 4.9.18 (beta)

- Res+ works correctly for really large meshes (may subdivide up to 160 m with 32 gb ram).

- Delete Material Editor layer crash fixed, restored possibility to mode layer up/down and move materials window.

- Baking of intersecting objects without "blur" between layers.

- Correct stamp in the sculpting room.

  • Like 2

Share this post


Link to post
Share on other sites

Ok, I don't know what is going on but once again I can't work on objects - there is always message that I'm trying to work on invisible layer... while it's visible and worked perfectly, atleast yesterday.

Share this post


Link to post
Share on other sites

Could be a little more specific please ? Thx

Share this post


Link to post
Share on other sites

Well, whenever I try to sculpt on an object(Sculpt Room, Surface mode) there is pop-up message on top of a screen "you attempt to paint on invisible layer..." and I can't do nothing. When I switch to Voxel mode it works ok.

Share this post


Link to post
Share on other sites

×