Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.9 BETA testing thread

Recommended Posts

5 minutes ago, Rygaard said:

1. When you press SHIFT key to Move, Rotate or Climb child Curves nothing happens. It is as if there is no such function. Just like with the CTRL key to snap.

Sorry ... let me fix what I said above ...
Now, the shortcut key is no longer SHIFT as described tip using the Curve Tool.

Now if the user wants to ROTATE child curves ... have to press the CTRL key.

Move and Scale does nothing in relation to child curves...
The SHIFT hotkey does nothing.

Edited by Rygaard

Share this post


Link to post
Share on other sites

Pose Tool:

image.png.88642b31bcab8358a26eee91f6ced835.png

One strange thing that happened to me is that in Pose Tool, after I chose transpose "PAINT" mode from the tool's function submenu, and then I wanted to switch to transpose Line mode, the Transpose Mode submenu disappeared.
image.png.bf025fdee89c167bc1e2a69bf278ecc5.png
I tried changing tools or brush, went back to Pose Tool and the transpose mode was still gone.
I tried to resize the Pose Tool palette to see if the problem was a palette bug, but nothing happened and Transpose Mode was still missing.


When I restarted 3d-coat, transpose mode came back. I do not know what that was.
I tested more often to see if the Pose Tool's Transpose Mode function would disappear again and it happened ....

If you choose Transpose Mode: PAINT, AUTOMATICALLY the transpose Mode submenu will disappear and will no longer allow you to choose any Transpose Mode function.
I tried switching to another tool or brush, but when you return to Pose Tool the transpose mode is still gone and locked in the PAINT option.

The solution for anyone who wants to choose another Pose Tool Transpose Mode option is to RESTART 3D-Coat.

Share this post


Link to post
Share on other sites
On 12/10/2019 at 10:11 AM, Carlosan said:

Confirmed using GL version on Windows too.

//edit

* Solved on 4.9.14

This bug is still happening on version 4.9.17.

Adjusting lighting is not working for the GL version.

Share this post


Link to post
Share on other sites

I just tested Res+ in 4.9.19, and I don't see any speed improvements. It takes incredibly long to upres if you are in the 5mil range going up.
I am talking about many minutes, which makes this way to slow for film work.

Share this post


Link to post
Share on other sites

I forgot to mention, that Res+ test was on a Surface Mesh.  Resample to 20mil meshes takes just as long. :(
I tested subdivision in zbrush on a 12mil poly model and it took 3 seconds to go to 45mil.

Edited by Werner_Z

Share this post


Link to post
Share on other sites

I believe 3D-Coat is having trouble making a simple conversion of a 1.5 million polygon mesh in Surface Mode to Voxels Mode.
I am almost 1 hour waiting and 3D-Coat does not leave the calculation screen: Not Responding. I will have to restart the program.

My Steps to the above problem:
- I merged two arms into the character's body (using Boolean operation) in Surface Mode and then I pressed the Convert to Voxels button. I had 1.5 million polygons and in converting to Voxels I set 700,000 polygons, Close Holes and Subdivide the mesh by 2 times.
After these steps, Not Responding Screen....and 3d-coat not work more.

As I said, just to remind you of some other 3d-Coat issues I'm going through:
- Problems with Res + (It takes too long to subdivide and does not support high amounts of polygons and Performance is not good).

- When the mesh has large amounts of polygons the performance of the brushes is very low.

- Drag Stroke is with problems.

- Problems using the Resample command (taking too long);

   Just like when you hit the ENTER button while in Surface Mode.

- Problems converting a Surface Mode mesh to Voxels.

Edited by Rygaard

Share this post


Link to post
Share on other sites
14 minutes ago, Rygaard said:

I believe 3D-Coat is having trouble making a simple conversion of a 1.5 million polygon mesh in Surface Mode to Voxels Mode.

To me, it makes much more sense to create a new vox layer, choose a resolution for it, and then right click > merge visible.
This method is :
-
quasi instantaneous,
- it gives you much more control than simply entering a number in the box and praying that the outcome will be what you want.
- It preserves the original surface mode object
- It gives you a vox layer that has a density that is compatible with your other layers (1 - 2 - 4 - 8, etc)

 

Share this post


Link to post
Share on other sites
1 hour ago, lesaint said:

To me, it makes much more sense to create a new vox layer, choose a resolution for it, and then right click > merge visible.
This method is :
-
quasi instantaneous,
- it gives you much more control than simply entering a number in the box and praying that the outcome will be what you want.
- It preserves the original surface mode object
- It gives you a vox layer that has a density that is compatible with your other layers (1 - 2 - 4 - 8, etc)

 

You're right. There is this possibility and I confess that I had forgotten it.

To be honest, I'm testing the possibilities that 3D-Coat offers us and whether those possibilities will work if we need to use them.

It's good to know that this technique of setting resolution on a layer and using the Merge Visible command works as you described it. I will still test.

But the functions I tested are basic 3D-Coat functions and could be working with a high performance and stable. Unfortunately, as you said, we still have to pray ...

Share this post


Link to post
Share on other sites

I usually take a pragmatic approach and look for workarounds. But yes I agree that the most intuitive commands, the ones that first come to mind *should* work...

When you test the merge visible method you will see that it works best when the surface mesh is watertight.
When it is not, it creates artifacts that sometimes ruin/hide part of the mesh.

The solution to that can be quite tedious and time consuming.

Again we stumble accross a simple function that *should* work, but doesn't, in most cases.
I always dread to try this, and I make sure I save my file before I attempt to use the "close holes" function from the geometry menu.

Sometimes it works like a charm, but too often it just fails, but that is nothing compared to the numerous times it leads to 3d-c freezing and you have no other option but to end the process.

So, you need to thicken the surface mesh, just enough, not too much or it will spill over to the wrong side in thin areas.

After you have thickened the mesh you can use merge visible on a vox layer without any artifacts.

Then comes the tedious part : you have to fill the inside by hand somehow, without altering the surface.

 

Edited by lesaint

Share this post


Link to post
Share on other sites

I agree with you.
Always saving the work or project before performing a 3D-Coat operation / function that requires calculation is more than necessary, I would say vital!

Right now, for the sake of just doing "sculpture drafts" that could turn into more serious projects, I'm not so careful that I keep testing the commands, functions, brushes ... because I already know in advance that I'm going to have great chances of having a problem, critical error or bug in an unstable 3D-Coat version.
My biggest intention is to report these problems.

Thank you for the explanation.
 

Share this post


Link to post
Share on other sites

Yes when doodling, just experimenting with shapes and all, having to always be afraid to perform an action is quite distracting and can break the mood...

That is why I stay away from surface mode as much as I can. Because it is surface mode operations that are the most dangerous.
There are bugs with undo that can break a voxel layer too, though. And I feel it is absolutely impossible to train onself to use undo carefully.

Share this post


Link to post
Share on other sites

Attention:
Serious problem when using VoxTree's visibility button (hiding a Layer object), save the project and then reopen the project.

When I saved a project in 3D-Coat, with two geometries hidden (each in its own layer) by the VoxTree visibility icon (button), 3D-Coat erased my two geometries from the project's VoxTree layer, leaving only the two layers (
Both geometries were in Voxels Mode).

Because when I went to open the project again and I pressed the visibility icon to make the geometries visible again and restart the work on them, the two geometries no longer existed in their respective VoxTree layers, only consisting of zero polygons in each layer.

This is not the first time that this huge problem has happened to me.

I don't know if it's happening only when the layer is Voxels Mode. I don't remember when I lost geometry in the past if it was in Surface Mode.

Therefore, CAUTION, you users when saving a project with hidden objects (VoxTree visibility button).
You are at a great risk of losing the geometry of your work.

Share this post


Link to post
Share on other sites
16 minutes ago, Rygaard said:

Attention:
Serious problem when using VoxTree's visibility button (hiding a Layer object), save the project and then reopen the project.


Don't erase the file


Edit : AND DON't SAVE IT!

Edited by lesaint

Share this post


Link to post
Share on other sites

Follow these steps :
-create a new layer with geometry in roughly the same space as your lost voxels.

-Select a layer with lost voxels.

-Select the fill tool and set its depth to 0

-"paint" with the fill tool on the geometry you created in the first step for that purpose, but with the empty layer selected.

The lost voxels should start reappearing where you paint.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
27 minutes ago, lesaint said:


Don't erase the file


Edit : AND DON't SAVE IT!

I had saved and was already recreating the geometries. Lucky I had enough UNDOs and it didn't crash.

24 minutes ago, lesaint said:

Follow these steps :

I did not know this tip!
Thank you so much for the steps!
My two geometries (voxels mode) have returned from the "land of erased"!
So far, I do not believe this worked!
Thank you again!

BUT......

This problem could be fixed!
Please fix this big error.

Share this post


Link to post
Share on other sites
3 minutes ago, Rygaard said:

 

So far, I do not believe this worked!

Not sure I understand, what do you mean?

You recovered your voxels through this method, yes ? (lucky about the undo's, saving makes the lost voxels vanish for good)

Share this post


Link to post
Share on other sites

When I am in voxel mode and do a proxy, and then restore it, it enters voxel mode as it should.

But, if I do the same thing, but actually edit the proxy(like using the move brush for example), and then restores it, it always goes into surface mode instead of voxels as it should.

This is on the MacOS build 4.9.04.

Best regards
//Morgan

Share this post


Link to post
Share on other sites
19 minutes ago, lesaint said:

Not sure I understand, what do you mean?

You recovered your voxels through this method, yes ? (lucky about the undo's, saving makes the lost voxels vanish for good)

I meant that the steps you passed me worked and I was able to recover my geometries!

Before you wrote the tip, I had already saved the project with new geometries (one on each new layer) that I was going to work on.

So, I read the steps you wrote.
And I pressed CTRL + Z until the moment I had the two layers of geometries that were erased and from this point I followed what you told me.
And it worked correctly. I had no problems.

  • Like 1

Share this post


Link to post
Share on other sites
15 minutes ago, MorganNilsson said:

When I am in voxel mode and do a proxy, and then restore it, it enters voxel mode as it should.

But, if I do the same thing, but actually edit the proxy(like using the move brush for example), and then restores it, it always goes into surface mode instead of voxels as it should.

This is on the MacOS build 4.9.04.

This behavior seems to be normal in new versions of 3D-Coat.
I had already been through this, and I noticed the same thing as you.

Currently, when you are in Voxels Mode and using Proxy Mode, not only Move Brush, but also Pose Tool and probably other tools... when you return from Proxy Mode, automatically the mesh will be converted to Surface Mode.
And you were right earlier when I was working on Voxels and returning from Proxy Mode, if I'm not mistaken the mesh remained on Voxels ...

I don't know if this is a bug or if it is the current behavior of 3D-Coat.

Share this post


Link to post
Share on other sites
3 minutes ago, Rygaard said:

This behavior seems to be normal in new versions of 3D-Coat.
I had already been through this, and I noticed the same thing as you.

Currently, when you are in Voxels Mode and using Proxy Mode, not only Move Brush, but also Pose Tool and probably other tools... when you return from Proxy Mode, automatically the mesh will be converted to Surface Mode.
And you were right earlier when I was working on Voxels and returning from Proxy Mode, if I'm not mistaken the mesh remained on Voxels ...

I don't know if this is a bug or if it is the current behavior of 3D-Coat.

Well, it is a behaviour that is really annoying, so I hope it is a bug... Either way, it is reported now, I think... This is the place to report beta bugs, right?

Share this post


Link to post
Share on other sites
53 minutes ago, MorganNilsson said:

Well, it is a behaviour that is really annoying, so I hope it is a bug... Either way, it is reported now, I think... This is the place to report beta bugs, right?

Sure! You're in the right place!
Feel free to help report any bugs or malfunctions of 3D-Coat!

Only in this way will we have a more stable program.

Share this post


Link to post
Share on other sites

the old curves (green) seem to have vanished ? :(

disabling beta tools only removes the curves menu : if you select closed spine stroke mode it still brings up the new (red) curves, without their menu.

Share this post


Link to post
Share on other sites

×