Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.9 BETA testing thread

Recommended Posts

Noticing in v4.9.28  , in paint. If you freeze some polygons, then invert and then hide frozen polygons it hides some unfrozen polygons.

Share this post


Link to post
Share on other sites

10.03.20 4.9.29 [beta]

- Bend Volume polished, accurate and uniform model deformation. Support of spline profiles (Splines palette).

- 'H' hotkey works in curves editor as well.

I marked this build as BETA, but I think it is stable enough. Very probably I will set this or next build to official downloads.

  • Like 1

Share this post


Link to post
Share on other sites

Flat Mode display

Faces disappear when rotate the camera

Flat.jpg

Share this post


Link to post
Share on other sites

Paint Room

View > Show displacement mesh

Strokes destroy geometry making hole

 

Holes.jpg

Share this post


Link to post
Share on other sites

The BaseBrush Copy/Paste Alpha bug seems to be back. You can perform this function once, but it won't allow you to make another adjustment to the curve and then copy/paste a second time.

Share this post


Link to post
Share on other sites

15.03.20 4.9.30 (beta, very close to stable)

- 3D-Coat imports external maps during PPP import much more smartly. It recognizes gloss/roughness/metalness maps and puts them to the corresponding layers.

- Fixed a lot of stuff related to AppLinks. Now Blender AppLink works as expected, all maps transferred to Blender as expected. Anyway you need to set in preferences "Blender" normalmap preset.

- Fixed problem of choosing new attached material by single click.

- FBX & multiple UV sets problem fixed.

- Correct text via F9 moved to Help menu.

- Fixed lag during the 3D mouse navigation

And, I really hope this build should be better than 4.9.05 in terms ofstability. A lot of stabilization job was done. Anyway, we need to check carefully.

  • Like 3

Share this post


Link to post
Share on other sites
On 3/11/2020 at 1:40 AM, Andrew Shpagin said:

Please send me the scene.

Hi , Scene sent. Issue still present - view flat mode-

 

FlatMode.jpg

Share this post


Link to post
Share on other sites

When you brush around the vertices of your retopo mesh on top of your high poly, using the brush tool, the vertex normals get recalculated at every stroke, which is immensely useful.
The shading on the retopo mesh then lets you see precisely the angle of each face relative to neighbouring faces.

All is well, except that brushing is often not enough. You often need to edit the geometry. It then becomes necessary to switch to the Add/split tool.

I don't know about all of you, but having to switch between tools repeatedly is a pain.
So, when I am with the add/split tool in an area that I know will require some more editing, I prefer to continue the brushing work with the add/split tool instead of the brush tool, until there is not more editing to do.

And here is the trouble : When you move vertices holding RMB with the add/split tool, the vertex normals do not get recalculated when you release. Thus, the shading of the faces remains unchanged until you make an actual edit.
Until then, you do not really see how your changes are affecting the angle of the faces relative to each other.

Fairly recently, I stumbled upon a workaround : if you pressed LMB while dragging a vertex and still holding RMB with the add/split tool, no action would occur, but the normals would get recalculated.

Saddly, this behaviour changed since V4_9-27 and still today with 4.9.30
Now, doing a left click while dragging a vertex and holding RMB counts as a regular left click, which means you are starting an edge, requiring to press escape to abort... making the nice workaround completely impractical.

Share this post


Link to post
Share on other sites

Attach to current layer IF model was painted before, give this square glitches.

Attach.jpg

Share this post


Link to post
Share on other sites

What is the reason why 3d-Coat won't bake vertex color from textures at import in the sculpt room in surface mode if you subdivide in tool options before apply ?

I am looking for a standalone software to subdivide scans before import, but I can't find any. Doing this in Blender takes a tremendous amount of time and often leads to crashes, Blender just can't handle very large meshes like 3dc does.

Would it be feasible to subdivide at import and still bake vertex color, or is that just too complex ?

Share this post


Link to post
Share on other sites

1- Shift+M

VertexPainting

Import vertex painted mesh

2- Bake > Paint mesh->Subdivide->Sculpt mesh 

Reduction Percent = 0

Apply

3- Commands > Res+ Res+ Res+....

Hope it help

 

Share this post


Link to post
Share on other sites

With new BaseBrush tool. If I build basic Clay Brush. How I can make CTRL effect to work.?

Share this post


Link to post
Share on other sites

Right Regular Tab is CTRL Action command

CTRL.jpg

Share this post


Link to post
Share on other sites

But does that work as expected. I don't get good results when I try to use CTRL. it feels totally different tool.

Share this post


Link to post
Share on other sites
19 minutes ago, haikalle said:

But does that work as expected. I don't get good results when I try to use CTRL. it feels totally different tool.

For you to have the effect you are looking for, in Regular mode, you can activate Plane Offset (with the mouse icon - a single slide) and enter a value above 1.0 manually by typing in the field.
 
In my tests, when you set the value of the plane Offset = 1.0, the Brush digging (CTRL Action) will be similar to a Flatten Brush or something that you won't dig right.

So, when you set the Plane Offset to > 1.5 or 2.0 automatically you will have the strongest digging behavior, just the way you are looking for (just find a value good for you).
 
You will not need to enter in CTRL Action mode and use the "Copy Settings from the" Regular "button.
You will only do something like this if you want to make a more specific configuration that achieves your goal.
If this is the case, you only have to enter a negative number (-2.0, -3.0) in the Plane Offset.

I particularly just set a higher value in Planne Offset and automatically Ctrl Action will do the digging normally.

Share this post


Link to post
Share on other sites
2 hours ago, Carlosan said:

1- Shift+M

VertexPainting

Import vertex painted mesh

2- Bake > Paint mesh->Subdivide->Sculpt mesh 

Reduction Percent = 0

Apply

3- Commands > Res+ Res+ Res+....

Hope it help

 

so I've been experimenting with that now, I'm not entirely sure I understand how this works, but if you don't have a paint mesh it does seem to make a copy of the sculpt mesh, albeit at a different scale from original.
Anyway, following these steps you can get a copy with the same vertex colors.. only if you don't subdivide before apply (just like when importing direcly).

So if you don't subdivide before apply like you suggest, you do get the vertex color, but subsequently using res+ won't extract more data from the original texture, it only copies nearby vertex color.

-----

Let me explain my purpose maybe. Let's say I have a scan with 1 8k texture. I want to transfer all that data (16 million pixels) to vertex colour. I thus need a mesh with 16 million vertices to hold all that data.

So far, the only way I have found to achieve this is to import a mesh that is already subdivided to my needs beforehand, and that has to be done outside of 3d-Coat. Sadly.

Unless, (hopefully), I am missing something obvious.

 

Edited by lesaint

Share this post


Link to post
Share on other sites
15 minutes ago, haikalle said:

I still don't fully understand how I can remove that "buildup" effect from inverse(ctrl)

https://youtu.be/BJNoQ5E9WHY 

I don't use plane offset. I just use the "copy settings from the Regular" and make sure I have a negative number in the degree settings.

Share this post


Link to post
Share on other sites

I tried. I just 15% in regular and when I change it into -15%, the brush feels like -15% x 100.

Share this post


Link to post
Share on other sites
11 minutes ago, haikalle said:

I tried. I just 15% in regular and when I change it into -15%, the brush feels like -15% x 100.

Try increase your brush spacing to .200. You can also lower the degree setting or adjust the degree curve.

Share this post


Link to post
Share on other sites

17.03.20 4.9.31 (beta)

- Fixed painting with a rectangle over UV window

- If several UV sets using the same name, the user will be asked to rename.

- Tweaking vertex position with RMB updates mesh normals correctly.

- Invisible faces in "flat" mode issue fixed.

- Even smarter Blender support (auto selecting normals and export preset)

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites

I stiil don't fully understand BaseBrush. For example if we select Clay tool (15% degrees) and same for CTRL except (-15% degrees) is this meant to to be normal clay tool. If yes then there is an issue with CTRL effect. It does not work as expected.

Share this post


Link to post
Share on other sites

×