Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.9 BETA testing thread

Recommended Posts

3 minutes ago, sprayer said:

Maybe change gizmo a bit? More like in Blender or other software, remove circle for rotation in view.I am not sure who using it often but it disturb from select moving axes. And plane axes scale not sure who often using, is it more needed than moving on plane axes?

I use circle it a lot :( (with pose tool)

Edited by Silas Merlin
  • Like 1

Share this post


Link to post
Share on other sites

What is changed when pressing the enter key on a surface mesh ?
Up until 4.9.45 that would remesh instantly, which was really cool. Now we get a dialogue. Is that a good thing ? What does it change in how it works, as opposed to right click > resample ?

Share this post


Link to post
Share on other sites
1 hour ago, sprayer said:

Maybe change gizmo a bit? More like in Blender or other software, remove circle for rotation in view.I am not sure who using it often but it disturb from select moving axes. And plane axes scale not sure who often using, is it more needed than moving on plane axes?

You can disable the plane axis scale  in the gizmo options, if it is the thing I think you are talking about.

And we will keep the screen space rotation circle thank you very much... which by the way you can disable in the gizmo options...also.

Share this post


Link to post
Share on other sites
7 hours ago, Silas Merlin said:

It seems that the only time I see them is when I try to close 3dc and the confirmation dialogue opens. image.thumb.png.eaecb5536685edaee38c10e56081de77.png

I've never seen that. The ones that I'm referring to appear in the render room in "mid-air", not on the model.  The longer I let it render a frame the more appear.

Share this post


Link to post
Share on other sites

Philnolan, I never seen similar problem... Looks like something with drivers. Try different versions please - DX, GL. Try also one of previous Coat's versions.

Also, please show me the render settings.

Share this post


Link to post
Share on other sites

Is this being looked at. Faceting when splitting/ cutting off .This bug has been going on for a while .Its mighty annoying have to keep switching off the new curves which I am slowly getting to like. I think I have done a couple of cut off/splits that have worked correctly but I think it was when I was just testing it on a sphere. When you really need it its annoying.

Split.jpg is new curves

Spit2.jpg is old curves

Split.JPG

split2.JPG

Share this post


Link to post
Share on other sites

@Silas Merlin Please test shift+smooth on move switching on/off Tool options > Voxelize...

Both options works fine ?

Voxelize.jpg

Share this post


Link to post
Share on other sites
19 minutes ago, Carlosan said:

@Silas Merlin Please test shift+smooth on move switching on/off Tool options > Voxelize...

Both options works fine ?

Voxelize.jpg

Oh....
I don't understand.. I did not touch this option, and smooth worked yesterday, I had it ticked off, I'm sure !

Today it does not work :(

1. Voxelize immediately OFF : Shift smooth does not work
2. Voxelize immediately ON : Shift smooth works as expected

Share this post


Link to post
Share on other sites

Wow i just played with new cloth tool and i Love it . Thank you so much awesome updates. :brush:

Share this post


Link to post
Share on other sites
4 hours ago, Andrew Shpagin said:

4.06.20 4.9.47 (stable)

- Gizmos got some "invisible thickness" for ease of capturing.

It makes a world of difference...

Such a relief ! Thanks !

Share this post


Link to post
Share on other sites

I think I understand better what the problem was with the gizmo, at least in my own experience :

I'm using a wacom most of the time

-First it was difficult to find the correct spot to make the element you wanted to turn yellow...
-And then, by the time you actually brought down the stylus to the surface of the tablet, you might have moved a fraction of a milimeter, and you were no longer spot on the element. (With pose tool, this meant that you were adding to the selection, and you basically had to start over expecially when working with symmetry, undo being somewhat unreliable)

Share this post


Link to post
Share on other sites
On 6/1/2020 at 1:14 AM, Andrew Shpagin said:

Philnolan, I never seen similar problem... Looks like something with drivers. Try different versions please - DX, GL. Try also one of previous Coat's versions.

Also, please show me the render settings.

Now that you mention it maybe it is a driver issue. It only happens on my laptop, which uses Intel graphics. It also only happens when I add a light.

Share this post


Link to post
Share on other sites

=> Possible Bug: Paint Room -> Fill Tool - Fill w/ Freeze -> Sculpt Room = Small holes appear.

I already tested it twice. The first time was with the bust and the second time with the spherical in Surface Mode - Sculpt Room.
From the Sculpt Room I went to the Paint Room.
I selected the Fill Tool. After I chose the desired Pattern, I selected the Fill with Freeze command option and clicked on the geometry.
After having Freeze, I went back to the Sculpt Room. And when I rotate the geometry, I noticed the appearance of several small holes in the geometry.
I tried to use the command to close the holes, but it was not possible.
So, I thought it was just a visual problem on the screen, but when I brushed over the small holes there were strange behaviors in the mesh deformation.
I tried to use all the tools to close the holes and it didn't work.
It seems that 3D-Coat does not see that there are small holes in the mesh surface.

1470907733_smallholes.thumb.jpg.b9d2f9207d7e600b23f80abf691c5c91.jpg

Share this post


Link to post
Share on other sites

Hi Rygaard, I tried to repro the problem you described above, but I didn't notice any small holes.

Only the preview window inconsistency was the same with your attached image.

I used the same version with you (4.9.47 GL), in case this wasn't present in DX version, also turned on wireframe to check more precisely.

 

 

Share this post


Link to post
Share on other sites

Hi @geoath thanks for testing...

I recorded a quick video of the problem.
Weird isn't it?

 

 

Share this post


Link to post
Share on other sites

7.06.20 4.9.48 (stable)

- Fixed freeze+holes problem.

- Fill tool got an important option - limit the expansion by the angle between faces.

- New options in preferences for AO/Curvature layers - calculate default values/ask with dialog/skip calculation.

  • Like 3

Share this post


Link to post
Share on other sites
8 hours ago, Andrew Shpagin said:

- Fixed freeze+holes problem.

Thanks for fixing the problem with the small holes that appeared after using the Freeze Tool.

Would it be possible to have the correct preview when the "Fill with Freeze" option in the Fill Tool is activated?
Because after activating this option, the preview shows the geometry all dark and it becomes impossible to know the final result.
Unfortunately, the preview only works without the "Fill w / Freeze" option disabled.

image.thumb.png.0cd4a1ac74992effa520ecdbf25f5e03.png

Share this post


Link to post
Share on other sites

how to get rid of these shortcuts ?!!!! I have moooreee better ways to use   QWER than this :help:

wtf.jpg

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, tcwik said:

how to get rid of these shortcuts ?!!!! I have moooreee better ways to use   QWER than this :help:

wtf.jpg

Err... Hardcoded ! oh, no !

and... you can add an additional shortcut, but you can't delete it if you do
image.png.9ddf3dbc3186214b5b2799af69a966e6.png
(delete key becomes the new shortcut)

  • Haha 1

Share this post


Link to post
Share on other sites

Surface Hide (Surface Mode) - Possible bug?

Pressing the CTRL Key to be able to Unhide a certain area does not work the command using the following types of E-Panel:
- Square Lasso, Rectangle Lasso, Vertex Lasso, Stroke Lasso, Circle Lasso, Elipse Lasso and Closed Spline.

image.thumb.png.557b0f7a12bf75b0be75ba185aeba525.png

I tested with the other types of E-Panel and they work correctly with the Ctlr key to unhide certain areas of geometry.

Share this post


Link to post
Share on other sites

Surface Hide - 3D Closed Spline (Surface Mode) :

Using the 3D Closed Spline (E-Panel) type when you press the Enter key:
The result is Unhide a little more of the determined area (even with Radius to a small value), but the strangest thing is that Freeze appears in the area at the same time.

Would this behavior be normal?


surfacehide_freeze.thumb.jpg.3190ad16d75280d2e1bf733fa5a06929.jpg
 

Share this post


Link to post
Share on other sites

right mouse shortcut too change the depth of a brush doesn't work in "Plane Defined by RMB" type of surface option mode.. [logic bug]

xx.jpg

Edited by tcwik

Share this post


Link to post
Share on other sites

×