Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.9 BETA testing thread

Recommended Posts

The off-topic Interface sub-discussion has been moved to a separate topic. Feel free to continue the discussion there, thanks.

Interface discussion

This thread is for new releases and bug report. ;)

Share this post


Link to post
Share on other sites

Why I can't add a shortcut to the Clay tool? is automatically added to the Vox Clay.

Share this post


Link to post
Share on other sites

BUG/Error?  in 4.9.56 that I haven't seen before:

  • I am in Paint Room - Multilayered object with many layers
  • Select Eraser tool
  • Select only to erase normals
  • Select normals layer and unlock it
  • Turn on Symmetry X Enabled
  • Choose the 3rd default fine gradient circle brush
  • Erase some normal displacement on half the face
  • Watch the cursor on the other side of the face move in symmetry
  • BUT NO ERASING on the other half of the face - despite fully symmetric face

Why doesn't normal erasing work for symmetry?

Share this post


Link to post
Share on other sites
On 7/20/2020 at 3:58 AM, celer said:

Can't add new volume to Root volume in Sculpt Tree sometimes

Thanks for your detailed explanation! The problem is present on my Mac too but only in "Release" build of "3DCoat". For some reason buttons [+] works correctly in "Debug" build of "3DCoat". It will take some time to investigate the reason because the debugger is absent in "Release" configuration.

Share this post


Link to post
Share on other sites

Is anyone else having issues with trying to create an AO layer and export them? I'm exporting with a character that has multiple UVs and started fresh(no other textures imported) It exports only a couple  UV/mats but with even/soft distribution of the  base character but not of the height map painted areas except for the head but is smooth AO not the rough dynamic height I painted.  This is for 8K resolution.   I've exported just fine in the past, selected layer 0 and exported everything but this time the areas I painted are pure white. Creating ao with different gama setting doesn't seem to create any difference.  Problems from V 4.9.53+

Share this post


Link to post
Share on other sites

I forgot to mention that I'd have more than one Height layer to have more control so maybe AO is getting confused where to get the depth from to produce the AO?

 

Share this post


Link to post
Share on other sites
On 8/2/2020 at 9:55 AM, popwfx said:

BUG/Error?  in 4.9.56 that I haven't seen before:

  • I am in Paint Room - Multilayered object with many layers
  • Select Eraser tool
  • Select only to erase normals
  • Select normals layer and unlock it
  • Turn on Symmetry X Enabled
  • Choose the 3rd default fine gradient circle brush
  • Erase some normal displacement on half the face
  • Watch the cursor on the other side of the face move in symmetry
  • BUT NO ERASING on the other half of the face - despite fully symmetric face

Why doesn't normal erasing work for symmetry?

Scene will help greatly. On simple samples all works as expected.

Share this post


Link to post
Share on other sites

Question: While drawing, the ui goes blurry, but when I lift the stylus, the ui returns to normal, clear status. Is this a known issue?

 

I'm using a rtx 3080,  ryzen 3900x, and 3dcoat openGL

3dcoat blurry.png

3dcoat Clear.png

Share this post


Link to post
Share on other sites
On 8/11/2020 at 7:44 AM, Andrew Shpagin said:

Scene will help greatly. On simple samples all works as expected.

I'll see if I can send link to a private scene file for you to test or strip it down and post a basic scene.  This object has a lot of layers and blendshapes etc

Share this post


Link to post
Share on other sites

for a long time, my friend and I have said.

  "I want to draw it the out of UV on 2D editor."

  "the out of UV of an imported image is removed . it is not happy."

is this function implemented  in the future?

 

Many improvement points of new version are great. thank you Mr andrew and developers.

2deditor.gif

Edited by jene

Share this post


Link to post
Share on other sites
On 8/12/2020 at 11:12 PM, Hdharris said:

Question: While drawing, the ui goes blurry, but when I lift the stylus, the ui returns to normal, clear status. Is this a known issue?

 

I'm using a rtx 3080,  ryzen 3900x, and 3dcoat openGL

3dcoat blurry.png

3dcoat Clear.png

Am I really the only one with this problem?

Share this post


Link to post
Share on other sites

Never saw this before.

Using DX version do you have the same problem ?

Share this post


Link to post
Share on other sites
8 hours ago, Carlosan said:

Never saw this before.

Using DX version do you have the same problem ?

No, I just tested it and the DX version is fine, so this is isolated to the GL version, at least for me

  • Thanks 1

Share this post


Link to post
Share on other sites

 

19.08.20 4.9.57 (stable)

- Essential render update! Screen space reflections and lights! Much more realistic render. Works if Beta tools enabled and corresponding checkboxes enabled in render room. Videos:

- Stencils supported in brush engine.

- Angular pinch modified to change pinch and flatten independently. Roof pinch brush introduced.

- A bit slowed translation with Space mode for better control, especially in ortho mode.

- Boundary green ref image gizmo part works correctly.

- Opacity slider for the color of the smart material layer. It solves the old standing problem when layers with white color are becoming transparent.

- Fixed problem of N-Gon primitive in voxels when the inner radius is zero.

 

 

  • Like 4

Share this post


Link to post
Share on other sites
On 8/18/2020 at 2:04 AM, Hdharris said:

No, I just tested it and the DX version is fine, so this is isolated to the GL version, at least for me

Probably antialiasing turned ON in video card settings. Turn off all quality enhancements in videocard settings.

Share this post


Link to post
Share on other sites

Cloth Tool - Possible bug:

I Tested with 3D-Coat 4.9.57 DX and GL.
The Pause / Resume button is no longer working during the tool simulation.

The simulation continues even if you press the button to pause the simulation.
 

image.thumb.png.023c7f28d33ad30c5f56893242c7f3f1.png

Share this post


Link to post
Share on other sites

4.9.57 GL/DX

- PAINT ROOM: When activity bar is enabled, the top drop menu that enables painting according to concave,convex, flat, ect  is disappearing!

 

MENU.jpg

Edited by geoath
  • Like 2

Share this post


Link to post
Share on other sites
On 8/16/2020 at 5:37 AM, jene said:

for a long time, my friend and I have said.

  "I want to draw it the out of UV on 2D editor."

  "the out of UV of an imported image is removed . it is not happy."

is this function implemented  in the future?

 

Many improvement points of new version are great. thank you Mr andrew and developers.

2deditor.gif

Capture the UV Map and save as an image file. then you can paint anywhere and still use the image file in your material. What do yo want to do, write notes?

Share this post


Link to post
Share on other sites
1 hour ago, Tony Nemo said:

Capture the UV Map and save as an image file. then you can paint anywhere and still use the image file in your material. What do yo want to do, write notes?

how about this : use the uv plane from the retopo models panel. insert it in your scene and move it to the uv set on which you wish to draw outside islands.
(you can make the plane tiny hidden inside the object, keep it there or delete it later after export) @jene

 

Share this post


Link to post
Share on other sites
7 hours ago, Silas Merlin said:

how about this : use the uv plane from the retopo models panel. insert it in your scene and move it to the uv set on which you wish to draw outside islands.
(you can make the plane tiny hidden inside the object, keep it there or delete it later after export) @jene

 

Hi, Slias Merlin. reply thankyou.

yes, I have used a big dummy plane for now when I have to keep pixel outside UV .

Edited by jene

Share this post


Link to post
Share on other sites
8 hours ago, Tony Nemo said:

Capture the UV Map and save as an image file. then you can paint anywhere and still use the image file in your material. What do yo want to do, write notes?

like this.

for example, the outside of UV is removed in 3D-coat.

OK, I use a dummy plane for only UV so far. thank you.

5121.thumb.png.5663f0a09373bd3662eab8a919363e88.png

I don't care.

Edited by jene

Share this post


Link to post
Share on other sites

I would like the developers to periodically create some kind of work themselves. Because the program has a lot of small bugs, for example, the impossibility of selecting a layer from the first click, the same for toggle wireframe in the uv editor, small artifacts when converting to voxels from surface, and many other glitches, they are not critical, you can cancel and click again, but they not pleasant. They are difficult to reproduce again for a report and they are raised during work, not in tests in an empty scene with primitives

  • Like 3

Share this post


Link to post
Share on other sites

4.9.57  .opacity preview doesn't work. in sculpt room:help:

Edited by tcwik

Share this post


Link to post
Share on other sites

×