Jump to content
3DCoat Forums

3DCoat 4.9 BETA testing thread


Recommended Posts

  • Member

switched from 4.8.20 to 4.9.15 & having a lot of issues, the main one is:

 3D Coat just goes unresponsive and locks up. It should not take this long to save (it never finishes after waiting 30 minutes), so I keep losing work. Scene is 1 voxel layer, low complexity (about 1 million triangles)

Even opening the file with no changes and saving causes it to lock up.

Opening the same file in 4.8.20 and saving has no issues, takes less than 2 seconds to save.

 

What is the stable version of 4.9 ? or is 4.9 not stable yet. The downloads listed 4.9.15 as non-beta.

Edited by XRA
clarification
Link to comment
Share on other sites

  • Advanced Member
13 hours ago, XRA said:

switched from 4.8.20 to 4.9.15 & having a lot of issues, the main one is:

 3D Coat just goes unresponsive and locks up. It should not take this long to save (it never finishes after waiting 30 minutes), so I keep losing work. Scene is 1 voxel layer, low complexity (about 1 million triangles)

Even opening the file with no changes and saving causes it to lock up.

Opening the same file in 4.8.20 and saving has no issues, takes less than 2 seconds to save.

 

What is the stable version of 4.9 ? or is 4.9 not stable yet. The downloads listed 4.9.15 as non-beta.

I keep ending up back at 4.9.02 which works  really good for me.( I think this version was before the new interface was introduced.......not keen, prefer the old but I will eventually get used to it ) I try every other beta that comes out, but there always seems to be some little niggle that sends me running back to .02. But all I really do is sculpt and vertex paint, I dont really do any of that there fancy stuff.

Link to comment
Share on other sites

  • Member

I don't know if its a bug that has been reported already, but I've been aware of it since 4.9 at least.
The problem is that after painting a material, it seems like there are issues with the "transparency" when you try to smooth it. It will smooth color, normals and metalness/roughness/glossiness/specular, but not the transparency somehow...? It is very obvious when materials are using Condition mask texture options like Concave, convex... , so I'm attaching a video which makes it way clearer.

https://streamable.com/h3qpa

 

Maybe am I doing something wrong that makes that happen?

Link to comment
Share on other sites

  • Member

hey!

as a hand painted texture artist, i've been stuck with 4.8.03 for a long time now since there is always some weird issue with new versions :/ 
I'd like to ask two questions and would like to know the answer if possible: 

- is it intentional/or if not is it known that color picker doesn't work from the model in paint room any more? only from ref image and it's working perfectly in the old version. this is a really important and essencial feature for color blending in textures! 

- is there any comfortable way of transfering your brushes with brush settings and everything (maybe already organized too) into your newer version of Coat and I just don't know about it? 

Link to comment
Share on other sites

  • Advanced Member
3 hours ago, tsabszy said:

- is it intentional/or if not is it known that color picker doesn't work from the model in paint room any more? only from ref image and it's working perfectly in the old version. this is a really important and essencial feature for color blending in textures! 

I had no issues with color picker in 4.9.05 or 4.9.15. It's working - picking color from the model.

 

3 hours ago, tsabszy said:

- is there any comfortable way of transfering your brushes with brush settings and everything (maybe already organized too) into your newer version of Coat and I just don't know about it?

Using the Presets window for brushes.
Also you can move everything from you "3D-CoatV48" content folder in your \Documents\  folder to the other place, let's say  D:\3D-Coat-Stuff and create a new environment variable with the name COAT_FILES_PATH and value D:\3D-Coat-Stuff. After that the newer version of Coat will (hopefully) auto-load everything from your older version.

 

But it was told that for pure diffuse-only handpainted texturing it's preferable to use pre-PBR version of Coat, before v4.5. Something like 4.1 - 4.1.17D, i think. There was some change in the brush engine, as i remember.

Edited by druh0o
Link to comment
Share on other sites

21.12.2019 4.9.16 (stable)

- Correct job of Vertex lines/Vertex curves in Voxel mode.

- "Create extension" dialog improved to be easily usable.

- Much faster curvature smoothing in curvature calculation dialog. It allows getting wider curvature "tale" and better quality of edges texturing with smart materials.

- The curvature calculation method (optional) that is less sensitive to padding quality and islands intersections. But less precise if normalmap used.

- Problem of baking with multiple UV sets solved.

- Fixed lags during scrolling

- reported stability issues fixed.

  • Like 3
Link to comment
Share on other sites

  • Contributor

I was testing Sculpt Room, more precisely in Surface Room mode...
And I would like to know if it is normal when you use the VOXTREE button to subdivide the mesh and from the third time pressing Subdivide, 3D-Coat starts entering the
Not Responding state and then there is a long (eternal) delay in completing the subdivide command?

I know that the command causes a multiplication by 4 in the amount of mesh polygons.
And when 3D-Coat has about 2 million polygons, the subdivision process gets slower and slower until it reaches the point of the program no longer leaving "NOT RESPONDING..."

I tried to split a mesh that has 8.6 million polygons and 3D-Coat no longer comes out of the Not Responding message. (Keeps calculating forever).

I had to close 3D-Coat.
I am using a Ryzen 3900X with 128GB of RAM. I think there is no problem in hardware!

image.thumb.png.222a509ed1fce0a5799dcab47bf2e00b.png

Link to comment
Share on other sites

  • Advanced Member

I have some issues with 4.9.15 build:

- tangent smooth doesn't work - there is notification, that I'm trying to paint on invisible layer.

- it seems that sculpt layers are active(paint room), while disabled in preferences

- gpu whine - doesn't matter if VSync is enabled in 3DC preferences or NVidia Control Panel

Link to comment
Share on other sites

  • Contributor
5 hours ago, Andrew Shpagin said:

- Much much faster Res+ command

Thank you for making Subdivision (RES +) faster.

@Andrew Shpagin Unfortunately, I need to report to you the following error that happened to me:
I just chose the (bigger) ball on the Surface Mode Splash Screen. After that I started working with Clay Brush (nothing serious) to test the subdivision (VoxTree = Res +).


1) Positive point:
Up to 34.4 million polygons, 3D-Coat was able to subdivide faster. (Just a little delay when it reached 34.4 million, but successfully.)

2) Negative point:
I tried to subdivide one more time and 3D-Coat gave me an error and crashed the program.

PC Configuration:
Ryzen 3900X, 128GB RAM, SSD 2TB M.2 ADATA pro and RADEON VII graphics card (windows 10 pro).

image.thumb.png.a26f70890018f3ac64187915bd69eb38.png

image.thumb.png.cb287bc7a91deb5420e7b83f6afbb4e5.png

Link to comment
Share on other sites

  • Advanced Member

4.9.17: For both DX and GL versions Ctrl+Z still doesnt work properly for the carve tool especially when you stroke away from the base model into the empty space. Usually deletes a previous stroke and sometimes leave voxels behind. Even deletes the base model if you undo your first stroke.

You guys keep ignoring this so I'll keep checking every new version and post the results.

 

Link to comment
Share on other sites

  • Member

Is anyone aware of the bug in the retopo room where occasionally you will become unable to select/hide retopology object layers, and  have to switch to the sculpt room and then back in order to 'reset' things?

 

like the first indicator that something has gone wrong just visually is layers will either have their names duplicated, or move in the layer stack. Then, when you attempt to select a layer, or hide/show one, nothing will happen. When you then click on the sculpt room (presumably any other room outside of the retopo room) and then back, the problem will be solved temporarily.

Link to comment
Share on other sites

  • Contributor

Hi, Unfortunately, I can't get past 30 million polygons in 3D-Coat. And that's if 3D-Coat allows me to have 30 million polygons.
I don't know if this is an error, but every time I try I get a critical error and before a message to increase virtual memory.

This is hard to understand because I tested and got in Blender 2.81:
201.326.595 triangles, but still sculpting.

image.thumb.png.786af8e480c60fa1c0b9a1def7404b3d.png

And by my curiosity, I tried one more subdivision level and Blender was able to subdivide and I got the result of 805.306.368 triangles (a little unstable).
image.png.2137d32c3109b91f4aea0fe9638b375f.png

So I don't know what to think... It's hard to think about, but isn't 3D-Coat able to subdivide into high amounts of polygons???  :(

Of course, it would not be to sculpt with a mesh with more than 30 million polygons, but so that I could be able to detail the surface of the mesh that I would have already sculpted and ready for the detailing process.

Link to comment
Share on other sites

  • Advanced Member

I thought this was some kind of problem on new versions, but I also noticed that on my computer (gtx 1080 ti, 32 gb ram), on version 4.9.05 (stable) in the same mesh in surface mode, I can not even reach 20 million + polygons. When I try to split the mesh by more than 12-15 million, the program just freezes (I tried to wait 15 unforgettable and fun minutes in the hope that the program would "hang". This did not work). (gtx 1080 ti, 32 gb ram)

Edited by Dmitry Bedrik
Link to comment
Share on other sites

  • Reputable Contributor

I thought this was still a problem with res+ in surface mode.
So, I tried to reach 200 million in voxels then switch to surface.
I was surprised, I could not achieve that.
I managed to reach 45 million with difficulty in voxel mode. Trying to get to 200 million from that using the pose tool resulted in a warning to save my work. So I didn't even get to try turning that to surface.

Link to comment
Share on other sites

  • Contributor

 @lesaint I forgot to say that I tried to subdivide (Res +) in Surface Mode.
I totally forgot to test in Voxels mode because I was seeing that in Surface Mode it wasn't working as it could.

@Dmitry Bedrik  The same thing happened to me until the penultimate version.
The 3D-Coat simply crashed and kept calculating forever until "Not Responding ..." appears. I always had to leave the program since he didn't answer anymore.
In this latest version, 3D-Coat can subdivide (res +) faster to some extent, but it can't get past 16 - 30 million polygons.

My configuration is a Radeon VII, 128GB ram, ryzen 3900x, ssd m.2 2TB adata pro.
So it's odd to say that, but I'm glad I'm not alone in this situation, because otherwise I would be worried about a possible hardware issue.

I fear it is really a problem with this new version that has been redone.  :(
I would very much like these basic functions that exist in a 3d sculpting program to be seen. I believe developers will fix this in future releases.

I would just like to talk about this matter of the millions of polygons that 3D-Coat is failing to get, but I also need to share with you other things that I realized that are not working.

I don't know how many people use this tool, but in Surface Mode, there is the Copy tool.
This tool is able to copy details from one area to another and also has the advantage of simulating something similar to a "vector displacement", since you can select a part you want (eg ear) with the Freeze Tool and then paste as many times as possible you want and anywhere else on the surface of the mesh.
Unfortunately, this Copy Tool (which has existed within 3d-coat for many years) is completely full of bugs and errors to this day.
It is one of the most powerful tools within 3D-Coat, but unfortunately it is abandoned...

Link to comment
Share on other sites

  • Reputable Contributor
5 minutes ago, Hdharris said:

Am I crazy, or does the color picker now pick ALL channels instead of just color now? Did it always do that, because I don't recall fighting the software for painting?

Yes It's been picking roughness/metal for a long time and that's really cool

Link to comment
Share on other sites

  • Member
6 minutes ago, lesaint said:

Yes It's been picking roughness/metal for a long time and that's really cool

it's not for me because now I have to constantly reset things back or else my colors are wrong when I paint, and I have to constantly reset the roughness manually in order to paint according to the materials I use for handpainting, I'm pretty sure it used to JUST pick the color, is there any way to make it do just that? as it is it's pretty much unusable for handpainting like I used to do if this is intended behavior.

 

Unless there was a change in how it's handling material switching, because when I pick a material with a different roughness than I had before it just stays at the original roughness and doesn't work, and then when I use the v shortcut to color pick it acts as if the stroke has multiplication on and darkens the colors. I don't know what's going on but it wasn't doing this recently, like say 4.9.05

Edited by Hdharris
further clarification
Link to comment
Share on other sites

  • Reputable Contributor
4 minutes ago, Hdharris said:

it's not for me because now I have to constantly reset things back or else my colors are wrong when I paint, and I have to constantly reset the roughness manually in order to paint according to the materials I use for handpainting, I'm pretty sure it used to JUST pick the color, is there any way to make it do just that? as it is it's pretty much unusable for handpainting like I used to do if this is intended behavior.

Yes of course, simply disable the black ball image.png.fb46af7c78b4d8de69b8fac9f9480aac.png

On the other hand, if you are using a smart material, it shouldn't be affected at all, surely ? so maybe there is a change there and that's what you're seeing

Edited by lesaint
Link to comment
Share on other sites

1.1.20 4.9.18 (beta)

- Res+ works correctly for really large meshes (may subdivide up to 160 m with 32 gb ram).

- Delete Material Editor layer crash fixed, restored possibility to mode layer up/down and move materials window.

- Baking of intersecting objects without "blur" between layers.

- Correct stamp in the sculpting room.

  • Like 2
Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 4.9 BETA testing thread
  • Carlosan pinned this topic
  • Carlosan unpinned this topic
  • Carlosan locked this topic
  • Carlosan unlocked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...