Jump to content
3DCoat Forums

3DCoat 4.9 BETA testing thread


Recommended Posts

  • Member

Ok, I kinda know what is going on - I went to Paint Room, where I've found couple of layers and some where invisible. After enabling visibility I can sculpt in Sculpt Room.

Funny thing is, I haven't created those layers. What's more, I don't have Sculpt Layers enabled, but I get depth painting anyway.

 

p.s.

I have color information on most of surface and voxel layers(this weird rainbow-ish icon).

Edited by Mihu83
Link to comment
Share on other sites

  • Advanced Member
4 hours ago, Andrew Shpagin said:

- Res+ works correctly for really large meshes (may subdivide up to 160 m with 32 gb ram).

@Andrew Shpagin First, happy New Year to you (and your family) and to all users (and their families)!

--> I am testing 3D-Coat 4.9.18 here (
with a horrible model that I sculpted on the mouse just to test) and I was able to get up to 137 million polygons (Surface Mode) with 128GB of ram, but....

:(When I reached 137 million polygons, 3D-Coat slowed down with some "stuck" in navigation.
Even so, I tried to detail with Brushes on the mesh surface and the experience was very bad, 3D-Coat was extremely slow to apply Brushes on the mesh surface.

:(  And lastly, I tried to subdivide the geometry and I had again problems that I had previously reported to you. After pressing the Res + (voxtree) Button the following critical error messages appear:
1) Out of Memory! Increase the virtual memory!
2) Please save your work! The program become unstable and willnow exit.
3) CRASH !!!

crash_hi_res_model.thumb.jpg.7a83503308b897c58889d70f3b4775bd.jpg

Link to comment
Share on other sites

  • Reputable Contributor
On 1/1/2020 at 10:25 AM, Mihu83 said:

Well, whenever I try to sculpt on an object(Sculpt Room, Surface mode) there is pop-up message on top of a screen "you attempt to paint on invisible layer..." and I can't do nothing. When I switch to Voxel mode it works ok.

It's not referring to your VOXTREE object (sometimes people call it a layer, but it's not really. It's an outliner/hiearchy panel). It's talking about the LAYER panel, which should be located directly to the right of the VoxTree panel. Sculpt Layers cannot record sculpt information on a hidden LAYER in the LAYER panel, thus the warning.

Link to comment
Share on other sites

  • Member
6 hours ago, AbnRanger said:

It's not referring to your VOXTREE object (sometimes people call it a layer, but it's not really. It's an outliner/hiearchy panel). It's talking about the LAYER panel, which should be located directly to the right of the VoxTree panel. Sculpt Layers cannot record sculpt information on a hidden LAYER in the LAYER panel, thus the warning.

I know that, it's just a power of habbit to call this Layers. Anyways, just replace Layers with Vox Tree and whole problem is still relevant.

Link to comment
Share on other sites

8 minutes ago, lesaint said:

When I read the notes for 4.9.12 and then again today for 4.9.19 I thought maybe this issue was fixed but no ?


2020-01-03_1857.thumb.png.f27612fcb38395feba2464d6325051ab.png2020-01-03_1856.png.5a091198300c354080a077f14e18ef7a.png

I

Strange, this is exactly the problem that I was fixing. On all my tests it was functioning correctly. I will re-check.

And fix in 12 was related to other issue. It was related to paint and sculpt, sometimes dot was appearing before the stroke.

Link to comment
Share on other sites

  • Member

Okay I finally thought to screenshot a problem that has been happening for a few versions:

 

when In the retopo room (So far I don't recall it happening in the Paint room), the layers of the retopo meshes and only the retopo meshes, will develop an error where the name and order of the layers will change, and they can't be selected or shown/hidden. The only way to 'fix' this is to go to the sculpt room and then back to the retopo room, at which point the layers will have their proper names and orders, and be interactive again. This is a temporary fix as it will happen repeatedly throughout a project.

Below, you can see that the image with the two layers sharing the same name are displaying the error state.

 

layer error 01.png

layer error corrected.png

Link to comment
Share on other sites

  • Advanced Member
7 hours ago, Andrew Shpagin said:

- Res+ corrected.

@Andrew Shpagin Sorry to report, but it's not working... :( 

image.thumb.png.9d10f97fe4ade3727c0387c60e126b7c.png

When the mesh was 34 million, I tried to subdivide (Res +) the geometry and 3D-Coat took a long time to subdivide into Not Responding mode ... and I let 3D-Coat calculate and after a long time the program was able to reach 137,822,126 million polygons.
image.png.5571362dd958ac8fd3509ecb0048c19c.png

So when the geometry was at 137 million polygons, I started testing the program and I can assure you that 3D-Coat's performance for navigating the screen got slow and when you try to detail the mesh surface the following problems happen:
1- Brushes become very slow.
Depending on the size of the brush it becomes impossible to use any type of brush to be able to detail the mesh surface.
Even when you set a small brush size it becomes complicated to use.
Unfortunately, I have to be honest to tell you that the performance is very bad, becoming very complicated to work with.

2- Drag Stroke is in trouble, because when you drag and hold the mouse so that you can choose the correct alpha size to apply to the mesh surface in real time, nothing happens.
And when you release the mouse, the result is completely unexpected:
Either the alpha detail becomes the size of a small square or the alpha size becomes large.
The user does not have alpha size control when choosing Drag Stroke.

image.png.76659a444a74edb042a1825d6c1c0998.png
image.png.aa39a053627db0abd3a2a0e31c8abf35.png

-> When I tried to subdivide (Res+) once again 3d-Coat goes into critical error mode and closes the program with the same things I said earlier:
- Out of Memory - increase virtual memory.
- Save because the program become unstable.
- Crash ....

image.thumb.png.e8ddb2bfcc2d04876eb44816843f9a54.png

image.png.9a034db872012324a962a943faa93c8e.png

image.thumb.png.e55ba47613fc20cd1d08030caa03c196.png

Link to comment
Share on other sites

  • Contributor
10 minutes ago, Hdharris said:

when In the retopo room (So far I don't recall it happening in the Paint room), the layers of the retopo meshes and only the retopo meshes, will develop an error where the name and order of the layers will change, and they can't be selected or shown/hidden. The only way to 'fix' this is to go to the sculpt room and then back to the retopo room

 

I have this too, at least since 4.9.14

  • Like 1
Link to comment
Share on other sites

  • Contributor
8 hours ago, Andrew Shpagin said:

Does it happen if you are not navigating?

I'm suddenly wondering if many problems I have with 3d-Coat come from the fact that I always work with a scene scale of 100

I'm testing now with a more standard setting, and I'm still getting the error with the sphere tool, but not on every stroke.

I mean, clearly the software is not made to be used at scale 100, because it forces to use some tools like contstuctor with values like 0.001 or even lower for some other things I can't remember right now.

Edited by lesaint
Link to comment
Share on other sites

  • Contributor
16 hours ago, Andrew Shpagin said:

And fix in 12 was related to other issue. It was related to paint and sculpt, sometimes dot was appearing before the stroke.

Sometimes I did get a dot instead of a line with the sphere tool. That doesn't seem to happen anymore.
The dot would appear in the line of sight between my view and the pick point (I think not behind, but not entirely sure)

Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 4.9 BETA testing thread
  • Carlosan pinned this topic
  • Carlosan unpinned this topic
  • Carlosan locked this topic
  • Carlosan unlocked this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...