Jump to content
3DCoat Forums

3DCoat 4.9 BETA testing thread


Recommended Posts

  • Contributor

Displacement in PPP mode version (4.9.72) still has an issue with spikes on the extreme UV sphere I sent you.   I don't know if you specifically managed to reduce the spike problem or if I just hit a miracle with ideal UV & mesh topology but it's not ideal for looser topology/sculpts meaning 3DCoat is too strict if models have to be this perfect to use displacement.

This is a different  sphere I'm testing out with the cleanest/simplest topology,  setup with UV seams split perfectly straight, no zigzags, setup with 8K. In this image it is in low poly view with wireframe, the uv area is also shown off to the  side.  At the UV poles there are no glitches at least and the 8k textures seem to load much faster now! 

  If you didn't make any changes that would change how depth is painted then I'd suggest you try out smart material displacement painting with less clean topology with Zig zags  on the UV edge like the image of the purple sphere below. Perhaps if you didn't fix the displacement issue that currently the only way  a UV or multiple UVs will work is that it is perfectly matched with non edge flow. The Character below is from Reallusion, it should work but it tears at specific areas. I'm showing you the hi poly displacement and what low poly looks like  so you see the topology that 3DCoat is not respecting.  I hope you can come up with a solution @Andrew Shpagin    

image.thumb.png.b885c4f65083aa6cdca00f45270d7f40.png

 

image.png

image.png

image.png

image.png

Link to comment
Share on other sites

  • Contributor

To be clear, 3DCoat will only allow non glitchy displacement with UVs cut out on straight lines, it doesn't like any staircase UV cuts like the purple sphere above and  I have no idea why it wouldn't work in the butt  area there  unless maybe the angle is too extreme?

 

The displacement spikes can arise from both staircase topology or staircases UVs. 

Edited by Ascensi
Link to comment
Share on other sites

  • Contributor

I have always had this issue with the grow tool : from time to time it decides somehow to save the current parameters for the tool, and it will subsequently always revert to those parameters after reopening the software.... Until weeks or months later when it will again decide to save the current parameters....

it's very annoying but today it got worse :

I used tapering the other day, and now tapering is enabled each time I start 3d-Coat, no matter what.

also alpha rotation sets itself to 171 instead of 0 each time I start..

 

Edited by Silas Merlin
Link to comment
Share on other sites

  • Contributor

Here is a bear I created in Zbrush (currently my modeling choice) and I painted it in Zbrush.. my choice would be using 3DCoat.. Zbrush doesn't create crotch holes and other holes unlike what would happen if I use 3DCoat..   it's using a CC3 Character ,  just like the character I shared with you  @Andrew Shpagin to help identify the spikes  and holes that are being created.   I'm only making a reference to Zbrush to show that there is an obvious issue with painting displacement in 3DCoat that needs correction.  So could you now help to fix your displacement painting system?  thanks.

 

 

Link to comment
Share on other sites

  • Contributor
12 hours ago, philnolan3d said:

I can't say I've seen "crotch holes" or other holes in my 3DC works.

Try PPP mode painting characters with displacement.. and if you have a Reallusion CC3 character you'd be able to confirm it.

Link to comment
Share on other sites

  • Contributor
On 3/24/2021 at 9:05 PM, philnolan3d said:

I can't say I've seen "crotch holes" or other holes in my 3DC works.

Just an update to prove the issue and a challenge to anyone that can prove me wrong. @Andrew Shpagin  I wouldn't normally use Zbrush for painting displacement but this is to show that 3DC has a real problem. I find bugs in other programs often but it seems like this one keep getting ignored in 3DCoat so I want to show how obvious it is.  Crotch holes isn't the focus here.. it's holes that appear in various places because 3DC brush seems to be too strict or restricting either based on topology curvature or zigzags in the UV/edge loops.  So this is what I was talking about.. This is the same character in zbrush as my above example. The bear I created is also using the same model just morphed but i used neither program to paint displacement. Instead I painted the fur and turned it into a displacement in a 3rd party app. 

image.thumb.png.50b0d46a88d5e77c44d8739b9684e9bd.pngimage.thumb.png.eb178b77362375cf9a4da470e3504f64.png

Edited by Ascensi
Link to comment
Share on other sites

  • Contributor

Just an update for @Andrew Shpagin , the crotch and other holes don't appear in other programs once exported, so that's a view port issue that should gets some attention to avoid feedback about having holes.. but the displacement spikes still have been visible in other programs like  Marmoset Toolbag and iClone etc.  It's kind of hard to paint if we can't see what or how something is painted.  Perhaps there should be a note at least when people paint with displacement, warning that holes don't actually exist from painting and that the model will be fine once exported (if you choose not to fix the display issue) So here is a quick confirmation image.. but again I can't see that area that I'm painting how it will look and that is still a problem, it was a big crotch hole lol 

 

image.png

  • Haha 1
Link to comment
Share on other sites

  • Contributor
5 minutes ago, spacepainter said:

I am trying to import a textured mesh in the sculptroom, seems not to be possible anymore?

In 2021 ?
Yes and no. It was never possible to import "textured" mesh in sculptroom. However, 3d-Coat bakes the colour from textures to vertex colour, provided the textures are properly assigned.

Import Process is a bit different in 2021 it seems. (no need to tick "import w/o voxelization")
Go to File menu > Import for Sculpt/vertex painting/reference

image.thumb.png.96f1a70b85df5b002fce9acafbc7145e.png

Link to comment
Share on other sites

  • Advanced Member

Normally when importing a prompt appears that gives the choice to import a mesh closed. that is absent now. My models are hollow when they come out of photogrammetry software. O the closing function is working now.

 

Edited by spacepainter
Link to comment
Share on other sites

  • 2 weeks later...
  • Advanced Member

We can't use the beta features anymore in Linux.

Until 3DCoat 2021 comes out of beta it would be really nice to have an extension on the beta tools trial, as Windows users already have with the 4.9.73 and 4.9.74 releases since June 14th.

Edited by Allabulle
Link to comment
Share on other sites

  • Reputable Contributor
50 minutes ago, Silas Merlin said:

The prospect of losing beta tools in 4.9 is traumatic.
 

In all fairness, this is how Beta tools have gone prior to Major releases (V3/V4) in the past. They are just a preview of what is being developed in the next major release, and they are indicated as such

Link to comment
Share on other sites

  • Contributor

In the case of hardware, I can understand that you lose some/gain some when upgrading to a new device. There just comes a point when the old hardware has to be replaced.

This is not the case here. This is software, the old version works just fine.  crippling it by choice is something that is beyond my comprehension. 
 

Link to comment
Share on other sites

  • Advanced Member
4 hours ago, Silas Merlin said:

In the case of hardware, I can understand that you lose some/gain some when upgrading to a new device. There just comes a point when the old hardware has to be replaced.

This is not the case here. This is software, the old version works just fine.  crippling it by choice is something that is beyond my comprehension. 
 

Let's not assume they're "crippling" anything. I think the old GUI is a tangled mess and I'm looking forward to a new redesigned interface.  Let's just wait and see. 

Link to comment
Share on other sites

  • Contributor
3 minutes ago, L'Ancien Regime said:

Let's not assume they're "crippling" anything. I think the old GUI is a tangled mess and I'm looking forward to a new redesigned interface.  Let's just wait and see. 

By crippling I mean the beta tools being stripped off 4.9

As for the new 2021, I take it you have not tested it yet at all ?
It has been available in beta for a long time now, you can get a copy on this thread :

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...