Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.9 Open Beta testing thread

Recommended Posts

"Thank you" for the "stable" work of the program (4.9.17), I just lost the result of ten hours of work due to the bad saving the file (when the program continues to save the file a couple of seconds after closing). 

Edited by Dmitry Bedrik
  • Haha 1

Share this post


Link to post
Share on other sites

I want to be clear on this: all the versions that you can find in this thread are BETA.
When they refer to stable, they found no notable crashes before the release.

There are more stable beta versions and less stable beta versions. But ALL are BETA.
They should NOT be used in production.

They only serve to see and test future new tools, which are currently in development stage and can be changed or modified.

  • Like 2

Share this post


Link to post
Share on other sites

And further note for you Dmitry, it is clearly marked as beta. So saying the team is lying is a lie itself. Find yourself in the corner. Don't post like this anymore. Final warning I'll ever give you.

Share this post


Link to post
Share on other sites

Seems there was one extra file in installation - OpenCL.dll

Delete it manually from installation.

I reuploaded installer, but you need to uninstall 4.9.21 first to get it to work.

Anyway, deleting the file will help.

 

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

Regarding stability and lying. I am trying to get to a stable state day and night, but after so big changes it is not easy. Some builds were marked as stable because there were no obvious problems during testing for several days but in longer-range there were problems...

But without all that changes long-term development is impossible. I understand the frustration when some work lost, but I am trying even more than I usually may...

  • Like 4
  • Thanks 2

Share this post


Link to post
Share on other sites

You're doing a great job Andrew. Don't let one troll get to you. He's got nothing better to do with his time. Positive vibes and keep on doing what you do best, making rad tools. :brush::wizard:

  • Like 3

Share this post


Link to post
Share on other sites

Agree with Jarvis. Andrews doing an incredible job improving this software and allowing us to beta test new features as they go along. I personally love seeing new versions every week to try out. I wish more companies did this.

I don't quite understand why people are trying to use the beta version for any major work. If I have to use 3d coat for work I go back to the release version from months back. I just experiment with the beta versions.

Keep up the good work Andrew and team.

 

Share this post


Link to post
Share on other sites
15 minutes ago, pr1970 said:

I don't quite understand why people are trying to use the beta version for any major work. If I have to use 3d coat for work I go back to the release version from months back. I just experiment with the beta versions.

IMHO the only true test for a build is to use it all the time, not just playing with it for five minutes doing random stuff.

You just have to be careful, Never overwrite an old file. Save incrementally, test the saves, and if it is really important, even export parts, or save them to models/retopo objects panels, and test open the incremental saves.
also test open the auto saves if you want to be extra careful.
And always wait a few seconds after saving before closing.


And also when a new build fixes an annoying/crippling bug, you just don't want to go back to an older version that still has it :)
And to be fair to the bad tempered people, I can't find any older build that doesn't have one big problem or another. So, it's really a matter of compromise.

Edited by lesaint

Share this post


Link to post
Share on other sites

I didn't say anything about 5 minutes of playing. I've spent hours on the beta versions only for it to crash. But I have lots of beta versions of applications but I don't throw my toys out of the pram if they crash on me which they often do.

Beta means just that, expect it to be very unstable and use full releases for production work.

Edited by pr1970

Share this post


Link to post
Share on other sites

4.9.21 Thank you so much for the Smart material editor fixes and additions !!!

A problem remains with drag and drop : the preview on model doesn't appear until you save the smart material.
It is true for cube mapping too, but here I show it with "from camera" to make it more obvious.

Also maybe tooltip could indicate that you can actually drag and drop textures, instead of browse. Drag and drop is so useful for many things in 3d-Coat, but I wonder if it is documented anywhere, and are people aware of it ?


image.thumb.png.f52d9cb984fd1abd75f578cef4fc8af3.png

 

image.png

Edited by lesaint

Share this post


Link to post
Share on other sites
10 hours ago, Andrew Shpagin said:

Regarding stability and lying. I am trying to get to a stable state day and night, but after so big changes it is not easy. Some builds were marked as stable because there were no obvious problems during testing for several days but in longer-range there were problems...

But without all that changes long-term development is impossible. I understand the frustration when some work lost, but I am trying even more than I usually may...

A direct message to you @Andrew Shpagin , please, I ask you... NOT to be "shaken" by random comments (especially when are not constructives).
Your work is unquestionable and certainly an award winner!

I can't get enough of saying, whenever I can...
how much I admire and congratulate you for the daily MAGIC you do together with your team to be able to provide all of us with a unique and fantastic program that is 3D-Coat!
Bugs happen in any program!
Please keep doing your MAGIC!

Congratulations!


Tip of the day:
--> Please, when working on any project, save interactions (File / Save as ...).
Anyone would be at great risk in ANY PROGRAM (whether BETA or NOT) if you work on the same file all the time.

Share this post


Link to post
Share on other sites

I don't know if that would be normal behavior. But I think there is a problem.

When you use geometry from the Retopo Room to the Sculpt Room, the mesh structure of the polygons generated by the Retopo Room is having problems with the appearance of noise in each brush stroke of the Clay Brush.

After that I tested converting the type of structure of the polygon mesh of Retopo Room by pressing the Enter key, defined the same approximate amount of polygons and the behavior of the Brush brush stroke returned to what I expected it to be, that means that each brush stroke was smooth without any noise.

In short: Problem with sculpting the structure of the mesh of polygons generated in the Retopo Room that cause strange noise brushstrokes.

image.thumb.png.7d5de007e55b4696ea6cb2c46342a4fc.png

Share this post


Link to post
Share on other sites
18 hours ago, Javis said:

it is clearly marked as beta.

Excuse me, but


Screenshot_2.thumb.jpg.e663d5e4e2ab210732c9f0115a33fc6d.jpg

 

and

 

Screenshot_3.thumb.jpg.f3bbb51c56002ea4b8238cd42dd43252.jpg

 

Oh, and 4.9.05 is now marked as beta in this thread?! Really confusing.

Edited by druh0o
  • Like 1

Share this post


Link to post
Share on other sites

@druh0o You are right, this misinformation was reported to our web developer. Hope to be solved soon.

Share this post


Link to post
Share on other sites
31 minutes ago, druh0o said:

But i'm kinda lost. What was the latest stable release?

This is a problem. Initially, we were sure that 4.9.17 is more stable than 4.9.05. But after several weeks of testing seems that 4.9.05 is more stable. 4.9.17 is generally very different from 4.9.05, a lot, lot of announced functionality included (several months of the job), but it seems it is less stable than 4.9.05. We can't set it back to 4.9.05 (that is a bit more stable) because of scenes compatibility.

The only solution that I actually see is to get really stable build as soon as possible.

But 4.9.05 is not so much better than 4.9.17. They have some common problems. Some of 4.9.05 problems fixed in 4.9.17. Some new problems appeared in 4.9.17. For example, lack of some UI elements in material editor.

For example caching problem present in both of them, it generally exists since the origin of caching. Only now I understood when it happens. And fixed it in 4.9.22.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, druh0o said:
 
 
 
1
1 hour ago, druh0o said:

Excuse me, but


 

 

and

 

 

 

Oh, and 4.9.05 is now marked as beta in this thread?! Really confusing.

I stand half corrected. Thanks. :) I never visit that site, only the forum where it is labeled correctly. Thanks for passing that along.

Share this post


Link to post
Share on other sites
On 1/20/2020 at 8:11 PM, SilverCity said:

BaseBrush: I'm having some issues with the Curve controls that affect depth.

1.  The command to "Copy settings from the Regular" doesn't transfer a custom depth curve.

2.  I can't get my custom depth curves to stick on any of my BaseBrush presets. I reinstalled 4.9.20 and it still is a problem. "Update Preset" also doesn't work .

Both of these bugs are still present in this latest build.

Also two other issues:

1. Moving these 2 points in the Edit Brush Shape window is hard because of the small area the cursor must be positioned.

2. Renaming a preset causes the Curve parameters to change.

BB-EditBrushShape.jpg

BB-Rename.jpg

Share this post


Link to post
Share on other sites

×