Jump to content
3DCoat Forums
Andrew Shpagin

3DCoat 4.9 Open Beta testing thread

Recommended Posts

43 minutes ago, Andrew Shpagin said:

21.10.2019 4.9.06 [BETA]

My sincere congratulations on the tremendous amount of work you and your team have done with 3D-Coat!
I haven't tried this new version yet (first I'll back it up), but I realize it will be a work change for the better!
And sure, worth waiting for this new version! :)

@Andrew Shpagin , I know you did a lot for this version, but I have a curiosity.
When do you think you can launch the version of 3d-coat that has the new alphas and brushes system? (
I'm counting the days for this.)

Once again, congratulations!
You guys are awesome!

Edited by Rygaard

Share this post


Link to post
Share on other sites

great effort.
Thanks a lot.

p.s.
the download from 3dcoat.com has problems and cannot be downloaded.
The download from pilgway works fine.

Edited by puntoit
found the problem after posting the initial post

Share this post


Link to post
Share on other sites
34 minutes ago, Rygaard said:

My sincere congratulations on the tremendous amount of work you and your team have done with 3D-Coat!
I haven't tried this new version yet (first I'll back it up), but I realize it will be a work change for the better!
And sure, worth waiting for this new version! :)

@Andrew Shpagin , I know you did a lot for this version, but I have a curiosity.
When do you think you can launch the version of 3d-coat that has the new alphas and brushes system? (
I'm counting the days for this.)

Once again, congratulations!
You guys are awesome!

The end of December is the deadline for many features. So, definitely earlier. I suppose within 2-4 weeks.

  • Like 2

Share this post


Link to post
Share on other sites
4 minutes ago, Andrew Shpagin said:

The end of December is the deadline for many features. So, definitely earlier. I suppose within 2-4 weeks.

@Andrew Shpagin

I'm so glad to hear that! Thank you for the information!

I just installed the new version over version 05.
It looks like my presets have been modified in the new version 06.
I went to the Edit Flatten Curves, and all my presets got a linear line.

image.png.1575079d4514f7201f6a9b4a4440f56a.png
Will I need to reimport my presets or is there anything I can do to retrieve my brushes?

Thank you

Share this post


Link to post
Share on other sites

Please write all the reports there, I will fix all immediately and do builds frequently.

This version really needs to be well tested.

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, Andrew Shpagin said:

Please write all the reports there, I will fix all immediately and do builds frequently.

This version really needs to be well tested.

Andrew,
This is very important. All of my presets I had do not work as before.
3D-coat version 06, ignored all my presets.


I will test more....

Share this post


Link to post
Share on other sites
7 minutes ago, Andrew Shpagin said:

Please open 05, save presets and send me

I will.. just a moment... I am installing 05 again....

Share this post


Link to post
Share on other sites
34 minutes ago, Andrew Shpagin said:

Please open 05, save presets and send me

Andrew,
I tried to install version 05 over version 06. And it didn't work, so I tried to open 3d-coat appeared version 06 instead of 05. I installed it in the same folder. There would be no way this could happen but I will have to keep version 06.


I finally managed to install version 05 over version 06.
I went to see my presets and they are working again with my saved settings .... (Edit Flatten Curves) .. all right!

I don't know how to make my presets work on version 06.


I sent my presets that I had (always backed up) to your email.

Edited by Rygaard

Share this post


Link to post
Share on other sites

still artifacts,holes and mesh corruption when using SoftBooleans with Cutoff tool.

Super easy to reproduce just use circle a few times on default sphere.

If you are unable to fix I would recommend not including this feature when you release the official build

.

image.thumb.png.b6dbf0a662bff2f7ddabf6cf7ff8ed22.png

Share this post


Link to post
Share on other sites
11 minutes ago, lesaint said:

Sculpt layers "available for the limited time period", may I ask, why is that ?
Thanks.

Sculpt layers are intended for the future major release. In 4.9 they are just for preview/testing. All new big things for next major release we will include in 4.9 builds but with note that they are only for preview (so time-limited till big release).

  • Like 3

Share this post


Link to post
Share on other sites

I don't see this line next to the download link, or in the notes : " This is essentially BETA build, be careful with re-writing saved scenes. Too many changes were done. We tried to check and test carefully, but need your help to check if all workflows work correctly. Thanks for testing. "
Maybe it would be a good idea to add it in big letters ?

For some time now I  try to remember to "save incrementally" all the time. Losing a saved scene is quite scary.
When you do lose a file (crashes 3dc on opening it), I have found that sometimes you can recover at least some of it.
One way is to open with a different version of 3dc.
For example you might be able to open a broken sculpt layers file with a non sculpt layer build, but you of course lose the sculpt layers information in the process.
One way to recover a sculpt object with its sculpt layers and painting is to open a new instance of 3dc and use the File > import object in the sculpt room to open the broken .3b file.


It is probably a bit early to say but it seems that the problem I had with sphere tool losing track of pick point resulting in the start of a stroke being bad, or the camera going crazy, I think that issue disappeared.
Yesterday on the discord someone else had a similar issue with the quad tool in the retopo room.
 

Share this post


Link to post
Share on other sites

Freeze tool on voxels is a cool addition. I understand if it can only be made to work with surface tools in voxel mode, and to make a selection for the pose tool.
However it is disturbing that if you switch to a voxel tool, you lose the freeze selection and cannot get it back.

also, you can use the move tool, for one stroke, then the freeze selection vanishes. (that's not very useful).

Share this post


Link to post
Share on other sites

Vox Tree News:  version 09!
Finally, some time ago, I made one video about this: Some kind of previsualization when you drad layers between layers in VoxTree:
Now ...... We have!
Thank you  @Andrew Shpagin

image.png.276c84e91c2d876de26b038a508635be.png

image.png.967d88e5203ab85c84b6f0d9b132e55b.png

Edited by Rygaard

Share this post


Link to post
Share on other sites

Thank you @Andrew Shpagin, Another fantastic thing about 3d-coat 06!

We can't use Proxy Mode to sculpt or fix something without destroying anything in Sculpt Layers. All details remain intact as long as the program can hold.
Great this!

But....................
The only thing I realized is that the carving I did when I was in Proxy (8x) didn't stay 100% when I left Proxy and went back to normal.
When I got back to normal, I noticed a 20% - 40% change from what I had done on Proxy, not 1: 1.


In the eye region, rather, the eye socket, in the left socket of the image, I had carved the eyelid, but in the image as you can see, it's gone!
In what looks like a nose in the image, I had carved a nose through the nostril holes, but the end result was gone too.


But it worked, all changes made to the Proxy are stored in Sculpt Layers.


image.thumb.png.932b92a287fdfaf251ec02af891cf43d.png

 

Share this post


Link to post
Share on other sites

Another fantastic thing

 

RenderPass.jpg

  • Like 1

Share this post


Link to post
Share on other sites

I don't remember in the previous version of 3d-coat if it could do the same, but in version 06 I can use Brush Noise, apply and BUMMMM, Sculpt Layers accepts the texture of Noise Tool!

FANTASTIC!

I tested with Copy Brush (surface mode - Sculpt Room), but unfortunately this tool is a bit forgotten!

image.png.63aa30276b3fd41873ac4b95f00e42c5.png

Copy Brush doesn't work with Sculpt Layers yet ...
Who knows one day this tool will be redone or updated. A tool that no other program has!
Great for various types of techniques and detailing.
I think the Copy brush is a bit like Vector Displacement and still copies any detail or surface. :)

Share this post


Link to post
Share on other sites

Just use the clone tool in paint room it works fine with sculpt layers, you only have to make sure what you want to copy is actually stored on a sculpt layer. I have a video how to achieve that if you need.  (First make a smooth version of your mesh, then use the reproject tool to get the actual detail of your original mesh. what you reproject is stored on sculpt layers, thus can be cloned with the paint room clone tool).

 

Share this post


Link to post
Share on other sites


3d-coat 06= In Split Tool, the procedure does not require pressing ENTER. Split works automatically after I make the selection.

Was it supposed to have a button to confirm the operation with Split Tool?

Here below, I make the selection and automatically Split Tool separates the object automatically without having to confirm or pressed Apply button ... anything.

image.png.5f467368b2c452d7d8f2b8253c014c55.png
Is this correct in version 06? The tool works fine, but I dont need to confirm the operation.... 

Share this post


Link to post
Share on other sites
13 minutes ago, lesaint said:

Just use the clone tool in paint room it works fine with sculpt layers, you only have to make sure what you want to copy is actually stored on a sculpt layer. I have a video how to achieve that if you need.  (First make a smooth version of your mesh, then use the reproject tool to get the actual detail of your original mesh. what you reproject is stored on sculpt layers, thus can be cloned with the paint room clone tool).

 

Of course, thanks for the Clone Tool tip in Paint Room. ;)
I already knew that the clone tool works perfectly with Sculpt Layers. That's great!

But unfortunately the Copy brush in surface mode - Sculpt Room, doesn't work! 
This tool has great possibilities.

Share this post


Link to post
Share on other sites

Still talking about Vox Tree ...
image.png.e1807eb0bf65baa521cbf152be3f7d18.png
We also have preview on boolean operations. As soon as you drag a Layer from an object with the Shift key to another layer in VoxTree, we have a new indicator of the boolean operation being performed!
Fantastic! These are small things that make big differences in the end. Long time I expected this in the 3d-coat interface!

Regarding all of these indications in Sculpt Layers' Layer dragging, unfortunately, there is no such preview or graphical indication in Sculpt Layers as there is in VoxTree. I believe that in the future we will have the same things in Sculpt layers or other 3d-coat palettes.

Congratulations also for changing the icons and elements in the interface! They were beautiful!
--------------------
Now about some Palettes....
In the Preset palette, I think the space is being "misused". Usually we have a lot of brushes (presets), and honestly, I would like to have a better advantage of the many brushes being viewed at the same time with information about the brush when the mouse was over.
Usually, I have to stretch the entire Preset palette vertically to see as much of my Brushes as I can. And it's the Presets palette that I use a lot.

I know I can only see by the brush name in the Preset palette listing, but I like to have a brush preview that I will use .....
image.thumb.png.e8415c6d1d50cc6c48c7af41d0d4154c.png

Share this post


Link to post
Share on other sites

Odd issue, a bug ?

I deleted some paint layers, one called emissive, the other paint. Then I started painting on brand new ones.
so I'm painting on layer 3, then I create a new layer, it's called Layer 6. I go to layer blending and use layer 3 as a mask, no problem.
I create a new layer, called layer 7, and go to layer blending because I want to use layer 6 as a mask....
the dropdown menu shows the old layers now, emissive and paint, which no longer exists.

Saving the file, exiting, and reloading made the layers in the scrolldown menu display correctly.

Share this post


Link to post
Share on other sites

×