Jump to content
3D Coat Forums
yoohasz

[Solved] UDIM style UVs import incorrectly (v4.9.04)

Recommended Posts

Hi guys!

 

I do need urgent help here, so please consider this: I have a turbosquid .obj file (purchased legally) and I need to open it (flying dino) it's an obj. It has UDIM style UVs 3 tiles to be exact: 1001,1002,1003 and everytime I try to open it with different settings (default import, clicking import tiles as UV sets etc) I have no luck. First I had crashes, but that was due to having multiple mesh islands combined having overlapping UVS and multiple UV sets (probably a  no-no) solved that. I can import the single mesh piece finally but  now at least one of three tiles  gets abnormally scaled in U or V direction?! making it useless. The best result so far was having two intact UV tiles 1001 and 1002 but the third tile for some reason goes nuts. if anyone can open it in any 4.x version of 3DCoat I'd be greatful to learn about what I'm doing wrong. Thank you for any and all help:

The .obj in question is here: 

p.s: I'm using the latest 4.9.04. version. And the model works fine in a special UDIM branch of blender (all UDIM tiles are intact), but I'd rather paint textures in 3DCoat for obvious reasons.

ptera_body.obj

udim_bug.gif

blender_udim.gif

Edited by yoohasz

Share this post


Link to post
Share on other sites

I hope this is enough info to at least have an idea of what could be wrong. Thanks again. 

Share this post


Link to post
Share on other sites

Yes, that model crash 3DCoat. Confirmed.

But after opening it on Blender and exporting no more crashes.

Bug reported

ptera_body.obj

ptera.zip

Share this post


Link to post
Share on other sites

New test.

Crash happen if Treat material as... is ON

Can you confirm if switching this option off model can be imported without troubles ?

off.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites

Oh, wow such a quick response. Tomorrow afternoon I can test it again. Thank you both, God bless!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×