Jump to content
3DCoat Forums
Anders68

AUTO retopo crashes 3dcoat on OSX

Recommended Posts

Hi! I use 3D coat 4.9.02 (GL64) Trial version on my iMac Pro with MacOS Mojave version 10.14.6 (18G95). Everytime i try AUTO retopo 3D Coat crashes when i click the third "Next" dialog button.

It does not matter if i choose a very simple shape or not. I get the same crashes on a different Mac Book Pro too. I can export to .obj and run Instant Meshes without problems though.

Is this a known bug?

//Anders

Share this post


Link to post
Share on other sites

Hi

Hope this help

On 7/1/2017 at 2:20 PM, SERGYI said:

"3D-Coat" crashes because macOS isolates "3D-Coat" executable from its data - typical problem under macOS Sierra. To solve it please do the following:
1. Remove folder "/Applications/3D-CoatV4-7".
2. Make sure that you have checked "System Preferences > Security & Privacy > Allow apps downloaded from: App Store and identified developers" before downloading disk image with "3D-Coat" on your Mac.
3. Download "3D-Coat 4.7.32" for macOS from here and drag & drop it onto "Applications" alias as usually:


In case these 3 steps will not solve the problem then please do these additional steps:
4. In Terminal go into "Downloads" folder:
$ cd ~/Downloads
5. Check extended attributes of downloaded disk image with "3D-Coat 4.7.32".
$ ls -l@ 3D-CoatV4-7-32.dmg
Among them should be "com.apple.quarantine".
6. Delete quarantine attribute:
$ xattr -d com.apple.quarantine 3D-CoatV4-7-32.dmg
7. Check that attribute "com.apple.quarantine" has gone:
$ ls -l@ 3D-CoatV4-7-32.dmg
8. Remove previous folder "/Applications/3D-CoatV4-7". Open in "Finder" this disk image with "3D-Coat 4.7.32" on which you have removed "com.apple.quarantine" attribute and as usual drag & drop it into "Applications" icon.

 

Share this post


Link to post
Share on other sites

I have the same problem with Autopo crashing. I reverted to 4.8.40 as suggested but the crash continued. I have now tried the latest 4.9 beta but still getting the crash. I am working on a Mac Pro 2010 with an AMD RX590 GPU. Mojave 10.14.6. Any suggestions would be appreciated.

Share this post


Link to post
Share on other sites

 Have you tried another model?

Share this post


Link to post
Share on other sites

Same as me AUTOPO crashes no matter what you do. Its not even possible to add materials or any addon model..

Maybe they will make this software better in the future but if you have OSX you cant use it as intended as is

Share this post


Link to post
Share on other sites

By installing old "3DCoat" builds under macOS one-by-one it turned out that between "4.8.38" and "4.8.39" actions "Perform Retopology" and "AUTOPO" had been broken. "3DCoat 4.8.38" is the last build where they are working under macOS (please see attached screenshots):
http://www.pilgway.com/~sergyi/3DCoat/3DCoat-4.8.38.dmg
Currently we are unable to fix them in new "3DCoat" build because for today we have compiled all 1077 source files under macOS and we are going to the second stage of building - linking.
 

Perform Retopology.jpg

AUTOPO.jpg

Share this post


Link to post
Share on other sites
25 minutes ago, SERGYI said:

Testing 4.9.31 under macOS. Sculpting, retopo, baking, and smart materials painting are working.

3DCoat 4.9.31 macOS.jpg

 

Share this post


Link to post
Share on other sites

I'm also using the latest version (OSX 3.9.40), and I'm seeing the same behavior (The program crashes).

All extended attributes are cleared, and the crashes are consistent every time I attempt AUTOPO. 

"Instant meshes" doesn't appear when I right click on the object.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×