Jump to content
3DCoat Forums
verystrange

Import Mesh For Voxelization Problem

Recommended Posts

Hi all,

I installed 4.9.12 today and when importing a mesh (.obj format) via the "import mesh for voxelization" menu, I am getting an undesired outcome. Please see attached image for reference.

The last working version that I can use is 4.8.16 for Windows due to: 1- import issues on 4.9.xx versions and 2- the "scale" option was missing or not working as intended on newer releases.

 

Issue 1: Importing

4.8.16 Method: Voxel Scultping --> Selecting Empty Plane/Grid Icon --> File --> Import --> Import Mesh for Voxelization --> Auto Scale (once) --> Scale (by  desired %) --> Apply --> Preserve Dimensions Popup --> Yes --> Click once on any tool, ex: Grow. Import model status is OK.

4.9.12 Method: Same import method as above but I get the weird result as shown in image (compare.png).

Issue 2: Scaling

4.8.16 Method: Voxel Scultping --> Selecting Empty Plane/Grid Icon --> File --> Import --> Import Mesh for Voxelization --> Auto Scale (once) --> Scale (by  desired %) --> Apply --> You are about to voxelize a big enough mesh (39 million). Poly count selected when scaling was 3.9 million. --> Apply --> Preserve Dimensions Popup --> Yes --> Click once on any tool, ex: Grow. Import model status is BAD.

 

I haven't changed any settings in v 4.8.16 or in v 4.9.12. Both imported the same way using the same file on the same PC. Both versions are currently installed. Using GL mode on both, not DX. Suggestions?

 

Thanks in advance!

 

compare.PNG

import-settings.PNG

39million.PNG

disappointment.PNG

Share this post


Link to post
Share on other sites

Hi

Try switching ON import without voxelization

Share this post


Link to post
Share on other sites

Thank you, Carlosan. Importing it as a surface then converting it to voxels worked fine.

Any idea why this is happening? Could it be GPU related? I have two GTX 980 TI's in SLI (bridge installed but SLI setting is set to off in Nvidia's control panel).

Share this post


Link to post
Share on other sites

I remember this as an old bug. 

Older versions triangulate the mesh before import for voxel.

Current version dont. Ngons destroy the geometry at import.

Share this post


Link to post
Share on other sites

×