Jump to content
3DCoat Forums
OsiyoStudio

3DCoat crashes when trying to AUTOPO running Mac Catalina

Recommended Posts

On 12/5/2019 at 3:41 PM, SERGYI said:

That build has some problems (commands "UV unwrap" and "AUTOPO" cause "3DCoat" to silently exit). Therefore under macOS try "3DCoat-4.8.40" which is more stable:
http://www.pilgway.com/~sergyi/3DCoat/3DCoat-4.8.40.dmg

 

Share this post


Link to post
Share on other sites

tried all versions 4.8 to latest beta - nothing works - either hangs or silently crashes - now I'll have to go to the dark side and use Substance Painter

Share this post


Link to post
Share on other sites

On Windows (4.9.15) it works great. I just used it to Auto-Retopo over a dozen parts and no crashes. Did you test it on a scene from the splash screen or new blank scene, with a primitive? That would help indicate whether it is a problem with the Voxel object underneath or with the application. Trying to underestimate the Polycount can cause problems....like trying to estimate a 1000 polys on a shape that needs 5000 (as an example) or more to account for all the different contours and details.

If you have voids or pockets inside an object, that can cause problems. It's why it's a good idea to RMB the layer and click FILL VOIDS on Voxel objects. This has been mentioned in many Auto-Retopo videos.

Share this post


Link to post
Share on other sites

3D coat keeps crashing on me as well when trying to do basic retopology.  I can't even import my FBX. It keeps giving me the warning that it's too big, but everything is in the 0-1 space. I even did auto-mapping on every object first and scaled everything down to fit.  I also tried the most recent version and that crashed, so I tried your advice on using 4.8.4, but that keeps crashing as well. My model was created in Maya and is all quads and is under 10k faces. I originally had an older version running, but it started getting buggy, so I tried to update.  Now I can't get it to work at all.  Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

By installing old "3DCoat" builds under macOS one-by-one it turned out that between "4.8.38" and "4.8.39" actions "Perform Retopology" and "AUTOPO" had been broken. "3DCoat 4.8.38" is the last build where they are working under macOS (please see attached screenshots):
http://www.pilgway.com/~sergyi/3DCoat/3DCoat-4.8.38.dmg
Currently we are unable to fix them in new "3DCoat" build because for today we have compiled all 1077 source files under macOS and we are going to the second stage of building - linking.

Perform Retopology.jpg

AUTOPO.jpg

Share this post


Link to post
Share on other sites

 

1280px-MacOS_wordmark_(2017).svg.png

macOS Catalina [4.9.41]:

http://www.pilgway.com/~sergyi/3DCoat/3DCoat-4.9.41.dmg

"3DCoat" for macOS has been signed and notarized with Apple. Ensure to check "System Preferences > Security & Privacy > General > click the "lock" > select "App Store and identified developers". When only the "App Store" is selected an error message is displayed "3DCoat-4.9.xx.dmg" can't be opened because it was not downloaded from the App Store. Your security preferences allow installation of only apps from the App Store.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×