Jump to content
3DCoat Forums
dexsoft

Bake with smoothing angle not recorded in normal map

Recommended Posts

When I have retopo model and want to transfer it to paint room (without baking normal map) with only smoothing angle, or with marking sharp edges I get prefect model in paint room.

Depend on smoothing angle I get nice smooth round part just like I do with standard baking high to low poly. Only problem when I export model that info it is not recorded in normal map.  How can I bake that info from paint room onto exported normal map. When I use exported model in unity it is ok because I can control there also roundness with smoothing angle and hard edges, but I need this info into normal map

 

smmoth.png

smooth2.png

normal_Normal.png

Edited by dexsoft

Share this post


Link to post
Share on other sites

Yes I always calculate curvature, and then occlusion. Like good trick I double curvature map and mark it like overlay and that way I get great nice edges

 

 

Share this post


Link to post
Share on other sites

On second thought, If you select no baking option, there is no reason for normals to be baked even with smoothing groups on. So you should try to go with bake normals and it will work. I think its by design.

Share this post


Link to post
Share on other sites

Yes I thought so :(

Maybe there is a way to bake this nice roundings and sharp edges made via smoothing groups into normal map from paint room.

Share this post


Link to post
Share on other sites

Texture Baking Tool could be a solution, you only need to bake High poly to low poly

 

TextureBakingTool.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×