Jump to content
3DCoat Forums
Gary Dave

Keep local axis on object creation?

Recommended Posts

I'm surprised it's taken me this long to notice, but it seems you can only keep an objects local axis if the centre of its mass was created at 0,0,0 without any rotations. So if you're following a reference and have to create primitives in different places, you immediately lose a lot of symmetrical benefits. Here's an example: 

Left = current default behaviour.
Right = what I would like the behaviour to be when creating an object.

Symmetry.thumb.jpg.610dfad23d9780be50f1ac4f896faac6.jpg

The only workaround at the moment is to create each piece as you need it, making sure it's matching your reference planes, and then reset its position and axis before applying it, then applying it and moving it back to where you had it before. Mind boggling!

I don't know if this is just a recent issue, or maybe it's always been like this, or if most of my work up until now has never needed this. But I am now discovering that most of the blockout work I've done over the last 2 days will need to be re-done, because I need to keep the objects local axis in place.

On the other hand, I'm reeeaaally hoping that maybe I'm missing something and being stupid. I'm using version 4.9.17

Edit:

Oh I should mention that I am well aware of the symmetry options like "Pick from bound box" but that does not work if your objects have rotations.

Edited by Gary Dave
predicting someones solution.

Share this post


Link to post
Share on other sites

Let me check

Share this post


Link to post
Share on other sites

I enabled symmetry, moved the center to nonzero location, transformed. Symm planes were transformed correctly as expected.

Share this post


Link to post
Share on other sites

But had you already created the object? Because sure if I create the object at 0,0,0 without rotations and then move it, everything is fine. What I'm trying to do is not create all my objects at 0,0,0, I would like to create them where I need them, and to have them keep their local axis. 

Share this post


Link to post
Share on other sites

Hopefully this video shows what I'm talking about:

The first example (in the first 20 seconds or so) is creating an object at 0,0,0 and without rotations, so everything is fine. The second example shows the problem:
 

 

Share this post


Link to post
Share on other sites

Sorry for the replies! I also see no difference when using the Global Space or Local Space option in the symmetry popup.

Share this post


Link to post
Share on other sites

You are right! The local space doesnt work (4.9.28). If i am not wrong, the local space alignment should be based similarly to "main axis in transform". The general case is pretty hard to get it correctly aligned.

Share this post


Link to post
Share on other sites

version 4.9.29

From my side is working fine (before any transform i used pick1 command)

 

pick.jpg

From my side is working fine.jpg

Share this post


Link to post
Share on other sites

Another example

Another Example.jpg

Share this post


Link to post
Share on other sites

Isn't the "Pick 1" used to set the position only of the symmetry manually?  I will have a look for the 4.9.29 download and see if it works for me.

Share this post


Link to post
Share on other sites

Okay so I just tried 4.9.29 and it's the same problem. Fresh install of 4.9.29, new scene, new layer:

Just to clarify: First object (sphere) shows root position creation = All is fine.

Second object shows non-root creation position, also scale/rotation differences. = Cannot get symmetry to align with what should be this objects local axis.

Third object = same as second, but created at the root, and then moved. = All is fine (except for the fact that you have to make all your objects at the root)

For the "Pick 1" option, I do not see how it helps. Am I missing something? 

Share this post


Link to post
Share on other sites

Exactly, because need to be children of first object.

I usually create an empty layer (V or S, dont care) and put all my models below hierarchy as children's.

Symmetry settings are not globally assigned but by layer.

 

Share this post


Link to post
Share on other sites

Hmm, I've just tried that but got the exact same (wrong) results. I have a strong feeling that my issue is not being understood, or I am not explaining it well enough.

Share this post


Link to post
Share on other sites

Yes, now I see the problem more clearly. Thx

Always i put the model on Global Scape, activate symmetry and then apply transform. 

From what I see, reversing the steps causes inconvenience.

Reported. Thx.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×