Jump to content
3DCoat Forums
lemsway

[Solved] 3DCoat applink to blender

Recommended Posts

12 hours ago, lemsway said:

 

HI i un install blender and install again...updated 3d coat and blender version and install the IOzip...

i tested it send to 3dcoat but when i hit the "getback" button ti gives me this error:

 

Traceback (most recent call last):
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 339, in invoke
    workflow1(ExportFolder)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1353, in workflow1
    blender_3DC_blender(texturelist)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1127, in blender_3DC_blender
    tex.matlab(objekti,mat_list,texturelist, is_new)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 697, in matlab
    readtexturefolder(objekti,mat_list,texturelist,is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 300, in readtexturefolder
    createnodes(index_mat, texcoat, create_group_node, objekti, ind, is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 441, in createnodes
    with open(json_address, encoding='utf-8') as data_file:
FileNotFoundError: [Errno 2] No such file or directory: 'C:\\Program Files\\Blender Foundation\\Blender 2.83\\2.83\\scripts\\addons\\io_coat3D\\data.json'

location: <unknown location>:-1

Share this post


Link to post
Share on other sites
15 hours ago, lemsway said:

 

HI this is an old file that i textured using the applink. now i dont work anymore. putting here the error message from blender

 

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\addons\io_coat3D\__init__.py", line 579, in invoke
    bpy.ops.export_applink.pilgway_3d_coat()
  File "C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\modules\bpy\ops.py", line 201, in __call__
    ret = op_call(self.idname_py(), None, kw)
RuntimeError: Error: Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\addons\io_coat3D\__init__.py", line 661, in execute
    objekti.data.materials.append(newmat)
AttributeError: 'AreaLight' object has no attribute 'materials'

location: C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\modules\bpy\ops.py:201

location: <unknown location>:-1

08162020.thumb.png.59dbc19dbb37e97b76fe2a3015a30911.png

08162020.thumb.png.5b7e1069f1cccc1611c670db9f928941.png

 

Edited by lemsway

Share this post


Link to post
Share on other sites

You have selected light. Applinks wants only meshes. I will update the script that it will ignore all other selected types except meshes.

Share this post


Link to post
Share on other sites

That other error is again saying that data.json file is not found in io_coat3D folder and this puzzles me cause it should be there automaticly.

Share this post


Link to post
Share on other sites
17 hours ago, lemsway said:

 

hi thanks again...now i got this message..which 1 i delete? thanks

image.thumb.png.760fc296763111fa15289c185abbe257.png

 

Edited by lemsway

Share this post


Link to post
Share on other sites

It seams that you have installed one applink version and it will conflict now with the one that comes with blender. Try to remove these addons and then replace zip file with /program files/blender fou.../.../addons/io_coat3d/

Share this post


Link to post
Share on other sites

When I send these zip files its better to replace blenders default addon with them. Using 'install external addon' is not good option in this case.

Edited by haikalle

Share this post


Link to post
Share on other sites
18 hours ago, lemsway said:

 

so i deleted the "IO" in the program files..did a test..but when i press the "getback" this error:

 

Traceback (most recent call last):
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 339, in invoke
    workflow1(ExportFolder)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1356, in workflow1
    blender_3DC_blender(texturelist)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1130, in blender_3DC_blender
    tex.matlab(objekti,mat_list,texturelist, is_new)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 697, in matlab
    readtexturefolder(objekti,mat_list,texturelist,is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 300, in readtexturefolder
    createnodes(index_mat, texcoat, create_group_node, objekti, ind, is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 441, in createnodes
    with open(json_address, encoding='utf-8') as data_file:
FileNotFoundError: [Errno 2] No such file or directory: 'C:\\Program Files\\Blender Foundation\\Blender 2.83\\2.83\\scripts\\addons\\io_coat3D\\data.json'

location: <unknown location>:-1

Share this post


Link to post
Share on other sites

Its again that data.json error. Can you check if there is data.json file in C:\\Program Files\\Blender Foundation\\Blender 2.83\\2.83\\scripts\\addons\\io_coat3D\\data.js

location

Edited by haikalle

Share this post


Link to post
Share on other sites
18 hours ago, lemsway said:

 

hi initially thers no "IO folder" i decided to make a copy of what you sent me..the "Getback button" works..but still the textures is jumbled up.

 

the other screenshot is i believe the duplicate copy.

image.thumb.png.b04573bd3eac523a518f6118510b2e81.png

image.thumb.png.6fd8114a803fc2e0f096a60f921a60af.png

Share this post


Link to post
Share on other sites

Could you send me a file to test out? You can send private message if you dont want to share it with every one.

Edited by haikalle

Share this post


Link to post
Share on other sites
On 8/15/2020 at 7:29 AM, lemsway said:

ok, but how come my other models..which i worked using 3Dcoat applink before..is not working now? other than this ship..i sent other samples. thanks for being patience.

When I have trouble getting the applink to work, the first thing I do is delete or move the BLENDER folder from MYDOCS/APPLINKS/3D-COAT/EXCHANGE. Then,  export something from Blender to 3DCoat, to re-establish a connection.

Share this post


Link to post
Share on other sites
16 hours ago, AbnRanger said:

When I have trouble getting the applink to work, the first thing I do is delete or move the BLENDER folder from MYDOCS/APPLINKS/3D-COAT/EXCHANGE. Then,  export something from Blender to 3DCoat, to re-establish a connection.

thanks will try this.

Share this post


Link to post
Share on other sites

Hello guys,

Same issue here. After installing Blender 2.90 I had the same problem. I removed the addon that came with Blender with the one above. Also, tried what Carlosan suggested, no luck.

___________________________________

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\addons\io_coat3D\__init__.py", line 579, in invoke
    bpy.ops.export_applink.pilgway_3d_coat()
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\modules\bpy\ops.py", line 201, in __call__
    ret = op_call(self.idname_py(), None, kw)
RuntimeError: Error: Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\addons\io_coat3D\__init__.py", line 613, in execute
    coat3D.exchangedir = set_exchange_folder()
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\addons\io_coat3D\__init__.py", line 137, in set_exchange_folder
    if(source != coat3D.exchangedir and coat3D.exchangedir != '' and coat3D.exchangedir.rfind('Exchange') >= 0):
UnboundLocalError: local variable 'source' referenced before assignment

location: C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\modules\bpy\ops.py:201

location: <unknown location>:-1

_________________________________

Thank you for your support!

 

Edit: If it helps, I also have Hops and Boxcutter installed, just like Lemsway has. Just saying....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×