Jump to content
3DCoat Forums

[Solved] 3DCoat applink to blender


lemsway
 Share

Recommended Posts

  • Member
12 hours ago, lemsway said:

 

HI i un install blender and install again...updated 3d coat and blender version and install the IOzip...

i tested it send to 3dcoat but when i hit the "getback" button ti gives me this error:

 

Traceback (most recent call last):
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 339, in invoke
    workflow1(ExportFolder)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1353, in workflow1
    blender_3DC_blender(texturelist)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1127, in blender_3DC_blender
    tex.matlab(objekti,mat_list,texturelist, is_new)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 697, in matlab
    readtexturefolder(objekti,mat_list,texturelist,is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 300, in readtexturefolder
    createnodes(index_mat, texcoat, create_group_node, objekti, ind, is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 441, in createnodes
    with open(json_address, encoding='utf-8') as data_file:
FileNotFoundError: [Errno 2] No such file or directory: 'C:\\Program Files\\Blender Foundation\\Blender 2.83\\2.83\\scripts\\addons\\io_coat3D\\data.json'

location: <unknown location>:-1

Link to comment
Share on other sites

  • Member
15 hours ago, lemsway said:

 

HI this is an old file that i textured using the applink. now i dont work anymore. putting here the error message from blender

 

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\addons\io_coat3D\__init__.py", line 579, in invoke
    bpy.ops.export_applink.pilgway_3d_coat()
  File "C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\modules\bpy\ops.py", line 201, in __call__
    ret = op_call(self.idname_py(), None, kw)
RuntimeError: Error: Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\addons\io_coat3D\__init__.py", line 661, in execute
    objekti.data.materials.append(newmat)
AttributeError: 'AreaLight' object has no attribute 'materials'

location: C:\Program Files\Blender Foundation\Blender 2.83\2.83\scripts\modules\bpy\ops.py:201

location: <unknown location>:-1

08162020.thumb.png.59dbc19dbb37e97b76fe2a3015a30911.png

08162020.thumb.png.5b7e1069f1cccc1611c670db9f928941.png

 

Edited by lemsway
Link to comment
Share on other sites

  • Applink Developer

It seams that you have installed one applink version and it will conflict now with the one that comes with blender. Try to remove these addons and then replace zip file with /program files/blender fou.../.../addons/io_coat3d/

Link to comment
Share on other sites

  • Member
18 hours ago, lemsway said:

 

so i deleted the "IO" in the program files..did a test..but when i press the "getback" this error:

 

Traceback (most recent call last):
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 339, in invoke
    workflow1(ExportFolder)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1356, in workflow1
    blender_3DC_blender(texturelist)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\__init__.py", line 1130, in blender_3DC_blender
    tex.matlab(objekti,mat_list,texturelist, is_new)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 697, in matlab
    readtexturefolder(objekti,mat_list,texturelist,is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 300, in readtexturefolder
    createnodes(index_mat, texcoat, create_group_node, objekti, ind, is_new, udim_textures)
  File "C:\Users\I9-9900K\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\io_coat3D\tex.py", line 441, in createnodes
    with open(json_address, encoding='utf-8') as data_file:
FileNotFoundError: [Errno 2] No such file or directory: 'C:\\Program Files\\Blender Foundation\\Blender 2.83\\2.83\\scripts\\addons\\io_coat3D\\data.json'

location: <unknown location>:-1

Link to comment
Share on other sites

  • Applink Developer

Its again that data.json error. Can you check if there is data.json file in C:\\Program Files\\Blender Foundation\\Blender 2.83\\2.83\\scripts\\addons\\io_coat3D\\data.js

location

Edited by haikalle
Link to comment
Share on other sites

  • Reputable Contributor
On 8/15/2020 at 7:29 AM, lemsway said:

ok, but how come my other models..which i worked using 3Dcoat applink before..is not working now? other than this ship..i sent other samples. thanks for being patience.

When I have trouble getting the applink to work, the first thing I do is delete or move the BLENDER folder from MYDOCS/APPLINKS/3D-COAT/EXCHANGE. Then,  export something from Blender to 3DCoat, to re-establish a connection.

Link to comment
Share on other sites

  • Member
16 hours ago, AbnRanger said:

When I have trouble getting the applink to work, the first thing I do is delete or move the BLENDER folder from MYDOCS/APPLINKS/3D-COAT/EXCHANGE. Then,  export something from Blender to 3DCoat, to re-establish a connection.

thanks will try this.

Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat applink to blender
  • 3 weeks later...
  • New Member

Hello guys,

Same issue here. After installing Blender 2.90 I had the same problem. I removed the addon that came with Blender with the one above. Also, tried what Carlosan suggested, no luck.

___________________________________

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\addons\io_coat3D\__init__.py", line 579, in invoke
    bpy.ops.export_applink.pilgway_3d_coat()
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\modules\bpy\ops.py", line 201, in __call__
    ret = op_call(self.idname_py(), None, kw)
RuntimeError: Error: Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\addons\io_coat3D\__init__.py", line 613, in execute
    coat3D.exchangedir = set_exchange_folder()
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\addons\io_coat3D\__init__.py", line 137, in set_exchange_folder
    if(source != coat3D.exchangedir and coat3D.exchangedir != '' and coat3D.exchangedir.rfind('Exchange') >= 0):
UnboundLocalError: local variable 'source' referenced before assignment

location: C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\modules\bpy\ops.py:201

location: <unknown location>:-1

_________________________________

Thank you for your support!

 

Edit: If it helps, I also have Hops and Boxcutter installed, just like Lemsway has. Just saying....

Link to comment
Share on other sites

  • Carlosan changed the title to [Solved] 3DCoat applink to blender

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...