Jump to content
3DCoat Forums
popwfx

Spline painting help needed

Recommended Posts

I'm having trouble painting splines and having them go on the correct faces - I don't fully understand the difference between the Spline tool and the Brush tool using Shapes/Splines to paint.

Most of the time it works and I can get things to paint in the way I expect.  But sometimes when wrapping a closed shape around a wrist or in this case, trying to paint inseams in the inner leg for jeans, I get unexpected errored results - see the attached pics please:

I use "Ignore Back Faces" on and that doesn't seem to make a difference.  These errors seem to happen based on the camera view - I thought the brush would be applied onto the surface based on the spline regardless of where the viewport camera was???  What am I doing wrong or is this a bug?  thanks!

 

Screenshot 2020-12-13 225630.png

Screenshot 2020-12-13 225607.png

Share this post


Link to post
Share on other sites

Try using it on Texture editor and paint it as 2D plane

Share this post


Link to post
Share on other sites

Thanks - does that mean this is a known bug?   This is a very clean lowpoly model with a 4K texture but I have this sort of thing happening a lot with spline painting on any model.  Is this something that is or can be fixed by Andrew?

Share this post


Link to post
Share on other sites

I was using the Spline in the brush tool.  But I also used the Spline tool which has an icon that looks like a bike chain.  Both seem to exhibit this weirdness - regardless of Symmetry setting and regardless of "Ignore Back Faces"  so I'm stumped - this has been happening on and off with this type of painting for many versions and many types of objects (all clean - I usually double check that there is clean geometry and no extra vertices etc first).  

The bug is definitely related to camera view - can you please confirm that both spline tools work like I expect - i mean that the stroke is to be painted/filled at the normal direction of the spline on the surface and has nothing to do with the viewport camera when applied?   (Unless you are using Camera mappiing in a Smart Material)

thanks!

 

Share this post


Link to post
Share on other sites

This is something that can be fixed by Andrew, please send bug report at

andrewshpagin@gmail.com

Thanks !

Share this post


Link to post
Share on other sites

I think I figured out some of it.  I thought the spline tool paints on the normal projection of the 3D topology of the surface.  It does not in the Paint room it paints only from camera projection.  Which means you can't easily paint around fingers or large stitches and seams on rounded or organic objects.  I noticed there was a 3D spline tool in the Paint room but it is greyed out.  Is it only available in Sculpt?  how do we paint with it?  This is a very important feature for painting - Not all of us use sculpting, sometimes we just need to paint on imported models.  Any help would be greatly appreciated to do this. thanks!

  • Like 1

Share this post


Link to post
Share on other sites

I am testing Curves Beta on Paint Room

Closed Spline stroke is working fine

Brush Along Stroke using Strips is working fine

Could you please give a try ?

Thx

//edited

ClosedSpline.jpg

BrushAlongStroke.jpg

Share this post


Link to post
Share on other sites
2 hours ago, Carlosan said:

I am testing Curves Beta on Paint Room

3Dspline stroke is working fine

Brush Along Stroke using Strips is working fine

Could you please give a try ?

Thx

 

ClosedSpline.jpg

BrushAlongStroke.jpg

Thank you for replying! Could you elaborate a little how to do that? It looks like the 3d spline is grayed out for you too in the paint room? Thanks!

EDC4EE0E-6DA4-4FE8-AD13-8E295B49516B.jpeg

Share this post


Link to post
Share on other sites

You are right, my bad sorry

I am using curves Beta tools + Closed Spline + Snap Curves to Surface (RMB over the curve)

Snap.jpg

Share this post


Link to post
Share on other sites

I suppose those tools may work well for many case (paint on smooth surfaces as convex) , but maybe OP case (path need to align  with concave, or  large angle curve, it may  need to change almost 90 degree in 2 point  (eg paint around cube with use those curve paint tools)

I experienced strange issue before.. so I hoped if 3d spline tool will work for paint room too. maybe attach problem scene can help to test by Carlosan.-_-

  • Like 1

Share this post


Link to post
Share on other sites
On 1/7/2021 at 3:05 AM, tokikake said:

I suppose those tools may work well for many case (paint on smooth surfaces as convex) , but maybe OP case (path need to align  with concave, or  large angle curve, it may  need to change almost 90 degree in 2 point  (eg paint around cube with use those curve paint tools)

I experienced strange issue before.. so I hoped if 3d spline tool will work for paint room too. maybe attach problem scene can help to test by Carlosan.-_-

I will try to make a video of it or attach a stripped down file

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×