Jump to content
3DCoat Forums
Thalamophora

[Bug] Artifacts on all "Paint UV mapped Mesh" textures

Recommended Posts

Hello,

I am getting weird artifacts all over my textures when painting with any standard brush in the paint room after choosing the "Paint UV mapped Mesh" workflows.

The artifacts are mainly lines that seem to run through the middle of all polygons and seem to occur on all layers/texturing-types (normal, colour, roughness etc.), but show most extremely in the normal map. It seems to be cause by some kind of smoothing/anti-aliasing problem at the edge of each polygon when painting.

Initially I thought that I was exporting/importing my objects (from blender) incorrectly and so tried all the different settings I could think of, but couldn't get rid of the problem. I also tried the Blender app-link, but this had the problem as well.

I then discovered that it is even doing it in 3D Coats built-in tiled-texturing workflow (from the new-project/start-up menu), so it doesn't seem to be an import/model issue after all.

This seems like a pretty fundamental problem that would make 3D Coat totally unusuable for painting imported models and tiled-textures, so I am guessing it is some kind of settings issue or user error, but after trying lots of different things and looking all over the forums and tutorials I can't find a solution.

The attached images show the problem just in the tiled-texture workflow (not my models/uvs).

I am using version 4.9.68 of 3D coat and have tried the GL and DX versions.

My computer set-up uses Intel, Windows 10 64bit (up-to-date), with an Nvidia RTX2070 super (drivers up-to-date).

Can anyone please give me a clue of what settings/operation I need to stop it doing this?

Thanks.

ZoomedOut2.thumb.png.752716c2c19b0980332f9b788e859497.pngZoomedOut1.thumb.png.6db5d62a6f0c92ae4253b0c2c37d692a.pngCloseUp1.thumb.png.67d3b127ce7533f49128203e95090797.pngCloseUp2_wireframe.thumb.png.505befe65742d01b017b52cf8bb20420.png

Share this post


Link to post
Share on other sites

Hello

May be you have Stencils active ?

Try turning it off

Windows panels stencils -> press over the X icon.

Windows panels stencils.jpg

Share this post


Link to post
Share on other sites

Hi Carlosan,

Thanks for your answer.

I don't think it is an "accidental stencil on" problem (that was the first thing I wondered when I noticed it).

But just in case, I followed your steps and it didn't get rid of it.

To show that it isn't caused by a "line stencil" I have attached a couple more screen captures after using a diamond stencil to paint.

You can clearly see the "line" artifacts in the painted "diamond" areas (as with a plain brush alpha) and nowhere else. This is the same with other stencil shapes.

Also, the lines always seem in the same place/pattern regardless of the stencil projection method (from camera, cube mapping, etc.) and if it was a stencil issue I would expect the position to move when I move the view angle (with From Camera).

On the other image I have turned the wireframe on again and you can clearly see that the lines are through the middle of polygons (in case this is a clue). Could it be a setting that is affecting smoothing/blending of brushstrokes between polygons (but not UV islands)?

Any other ideas?

Thanks.

Stencil.png.66d00a3463b6cb51b802b3537eb96866.pngStencil_wireframe.png.d1405779b722d091a472736e83b80ed0.png

 

Share this post


Link to post
Share on other sites

Try switching from DX version to GL.

Graphic driver are up to date ?

Share this post


Link to post
Share on other sites

The problem occurs in both DX and GL versions.

My graphics drivers are up to date (461.40 - which is the latest for my RTX card).

I also wondered if it was a texture/paint problem or just a GL/DX display problem, so I exported the textures (cropped colour texture example attached) and in a photo editing package you can still see the single lines of pixels that runs diagonally across the texture (where the two triangles of a square polygon meet on the model/tile). This seems to indicate that it is a problem with the way 3D Coat is painting across polygons and not just a display problem.

Has anyone else had this problem?

To replicate:

1. Start a new scene (Ctrl+N)

2. From the start window/menu select "Paint UV Mapped Mesh (Per Pixel)".

3. Select either "Tile" option.

4. Click "Ok" on the "Import Object" panel that pops-up (I have all check-boxes off).

5. Start painting with a standard round brush on Layer 1 (or a new layer if you like) with depth, colour and glossiness all active.

The lines then instantly appears for me.

 

Thanks

 

ExportedColourTexture.thumb.png.9d5debf22ed19fd58f5c9475cc539cbe.png

  • Thanks 1

Share this post


Link to post
Share on other sites

Bug confirmed and reported at support@3dcoat.com.

Thanks for your detailed report.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×