Jump to content
3DCoat Forums

3DCoat 2021 Open Beta test !


Recommended Posts

  • Advanced Member

Any idea when the face extrusion tools will be fixed in the modelling room?

I'm seeing some of the amazing demo videos of 2021 on YouTube but I cant understand how the author has created such models with this tool completely broken.

There are many issues with it as I described earlier still with V2021.B47:

  • Deselecting doesn't work when clicking off/away from the model
  • When selecting a new face the normal direction gizmo doesn't update unless I manually re-select the tool. 
  • If I have all faces selected while I have the free move selected and click off screen (my other monitor) the objects moves to a random position in space sometimes VERY far from the original position.
  • Most of the extrude tools just move faces rather than actually extrude them. As far as I can tell only 'Normal Extrude' works partially, the others (smart extrude etc) do nothing useful.

For me It's probably the most useful tool (or it would be) in the room's toolset, but at the moment it's completely broken. This is preventing me from even starting to get into detail on a more complex model as the basic 3d modelling process is step one in creating anything.

Is no one else seeing these issues?

Cheers

Edited by Grimmy
Link to comment
Share on other sites

21 minutes ago, Grimmy said:

Most of the extrude tools just move faces rather than actually extrude them

To make Extrude, press Enter.
Has been working on the Transform tool for a long time.
With the Smart Extrud tool, you can move, rotate and scale.

Link to comment
Share on other sites

  • Advanced Member

Yes, thanks. I know that hitting enter commits the extrude but after you extrude once and select other faces the gizmo remains in the same place as the old extrude. The other problems I mention still exist.

Also, hitting enter is a very cumbersome way to commit the extrude (it's the opposite side of the keyboard to where most hands are resting (on the left side)) and would be far quicker to do something like double click/right click (Ideally something that doesn't require a keyboard shortcut)  or have an icon on the gizmo that commits the extrude.

Actually having said that I think the commit should just happen automatically and maybe holding shift or something takes you temporarily to the transform tool so you can tweak the position after if you need to...otherwise just dragging again creates another extrude.

Obviously this is a design decision but I've tried using the tool as it is many times to create simple extruded shapes, but it really feels very clunky (unusable in fact) for what should be a rapid building experience. 

  • Like 2
Link to comment
Share on other sites

57 minutes ago, Grimmy said:

Obviously this is a design decision but I've tried using the tool

What Tool are we talking about?
You write - but it really feels very clunky (unusable in fact) for what should be a rapid building experience. 
Why is he bad?

Thank.

Link to comment
Share on other sites

  • New Member

I am way too excited for this version of the application. My favorite addition is the low poly modeling room (Where I have been playing!). I hope transitioning between rooms is streamlined as well (Rather than treating them as separate applications, it would be nice to be able to transfer directly between them. Maybe you could before and I just never figured it out!).

An issue I found almost immediately in the Low Poly room:
Untitled.thumb.png.9e42cad55ffad0a357a46f1c01941ee9.png

Reproduction steps:
1: Create a default cube (Where it all begins)
2: Select 3 of the top faces (It was an accident, but whatever finds the edge cases, right?)
3: Rotate the selected faces (Toward the unselected face. Again... accident. Getting used to the tool, haha)
4: Use the Spine tool and pull the selected faces out a few times into a loop (Kind of like the top of a lock)
5: Try to undo it all.

Link to comment
Share on other sites

  • Advanced Member
4 hours ago, Gorbatovsky said:

What Tool are we talking about?
You write - but it really feels very clunky (unusable in fact) for what should be a rapid building experience. 
Why is he bad?

Thank.

I'm talking about the extrude face tools. This brief video should highlight some of the issues. In The video I just try to extrude a few faces on a cube using the tools but pretty soon it turn disastrous and I dont think I'm dont much wrong...

Some of the problems I can instantly see in this short 90 second video and some other ones I found before..

  • The tool switches to the rotate surface tool
  • The tool gizmo axis does not update with the face selection
  • Some tools move faces rather than extrude them
  • Faces are unselectable in the smart extrude
  • A second mesh seems to get created when I use smart extrude?!?
  • Deselecting doesn't always work when clicking off/away from the model
  • If I have all faces selected while I have the free move selected and click off screen (my other monitor) the objects moves to a random position in space sometimes VERY far from the original position.

Maybe its me that's doing something wrong, but I don't see any tutorials about this anywhere and I would have thought it should be fairly intuitive to use.

Here is a video of me  doing the same in Cinema4D. Its so simple. I don't need to hit enter each time to commit an extrude. I just let go of the mouse. Note that also in C4D I can also move,scale or rotate the face/s at anytime using the gizmo that's always there. If I were you, I'd just rip off this workflow as is. Its perfect.:)

 

 

 

Edited by Grimmy
  • Thanks 1
Link to comment
Share on other sites

  • New Member
2 hours ago, PoshIndie said:

I am way too excited for this version of the application. My favorite addition is the low poly modeling room (Where I have been playing!). I hope transitioning between rooms is streamlined as well (Rather than treating them as separate applications, it would be nice to be able to transfer directly between them. Maybe you could before and I just never figured it out!).

An issue I found almost immediately in the Low Poly room:
Untitled.thumb.png.9e42cad55ffad0a357a46f1c01941ee9.png

Reproduction steps:
1: Create a default cube (Where it all begins)
2: Select 3 of the top faces (It was an accident, but whatever finds the edge cases, right?)
3: Rotate the selected faces (Toward the unselected face. Again... accident. Getting used to the tool, haha)
4: Use the Spine tool and pull the selected faces out a few times into a loop (Kind of like the top of a lock)
5: Try to undo it all.

Just noticed I was in an outdated Beta (B39. I got it from the main page announcement banner. Didn't know this thread had an updated one). Might still apply, but it did lose some cred now, haha.

Link to comment
Share on other sites

  • Advanced Member

Is there any way to bind a hotkey to Curves -> Delete all curves? It's the command I use the most on that menu.

Set coordinates and Delete all curves are the only commands on the Curves menu that don't seem to have that option.

 

Edited by L'Ancien Regime
Link to comment
Share on other sites

5 hours ago, L'Ancien Regime said:

Is there any way to bind a hotkey to Curves -> Delete all curves? It's the command I use the most on that menu.

Set coordinates and Delete all curves are the only commands on the Curves menu that don't seem to have that option.

You just need to select several curves and press the key Delete.

  • Like 1
Link to comment
Share on other sites

  • Advanced Member
4 hours ago, Gorbatovsky said:

You just need to select several curves and press the key Delete.

Also, I've tried this both in 4.9.72 and also in  2021 B47 there's the option of creating  hotkeys for the various primitives (sphere, cube, ovoid etc). I can assign them but they don't stick. If I go to another room then return they've lost their hotkey settings.

 

Link to comment
Share on other sites

  • Contributor
1 hour ago, L'Ancien Regime said:

Also, I've tried this both in 4.9.72 and also in  2021 B47 there's the option of creating  hotkeys for the various primitives (sphere, cube, ovoid etc). I can assign them but they don't stick. If I go to another room then return they've lost their hotkey settings.

 

do you mean in the models panel for the sculpt room ? if yes, and if it is like in 4.9,  the panel needs to be showing the folder the primitive is on for the hotkey to work.
For example, if you have a hotkey for sphere in the default folder, but the greebles folder happens to be open, then the hotkey for sphere won't work until you reopen the default folder.

  • Like 1
Link to comment
Share on other sites

  • Advanced Member
2 hours ago, Silas Merlin said:

do you mean in the models panel for the sculpt room ? if yes, and if it is like in 4.9,  the panel needs to be showing the folder the primitive is on for the hotkey to work.
For example, if you have a hotkey for sphere in the default folder, but the greebles folder happens to be open, then the hotkey for sphere won't work until you reopen the default folder.

5V4ZHYh.jpg

 

Primitives panel in Sculpt Room. I can create that hotkey ALT + A and it works but if I move to the Paint room or any other setting and come back to the Sculpt Room  the assigned hot key is gone.

Edited by L'Ancien Regime
  • Like 1
Link to comment
Share on other sites

  • Advanced Member

I create some blobs using the blob tool and I'm left with with large white lines that wont ever go away. I tried tried switching tools and switching rooms but the lines are always present. The lines around the created blob wont go either. Version B47

image.thumb.png.91ce7ca54c7eed58941228edd3e0e29a.png

Edited by Grimmy
Link to comment
Share on other sites

  • Reputable Contributor
3 hours ago, Grimmy said:

Would it ever be possible to add actual  transform positioning of lights in the render room rather than having to guess from light height and light angle?

Thanks

Yes. I have asked for that more than once and also for a Shadow Catching material

 

  • Like 1
Link to comment
Share on other sites

  • Advanced Member
8 hours ago, Grimmy said:

Would it ever be possible to add actual  transform positioning of lights in the render room rather than having to guess from light height and light angle?

Thanks

I would love a lighting system like in Maya or at least Zbrush. It's actually essential for serious sculpting.

Link to comment
Share on other sites

  • Advanced Member

The sculpt layer sculpted on Layer 0
Can't it be erased with Erase SL brush?
When I try to erase on Layer 0 it erases a completely different layer.

Erase SL works fine for added layers such as Layer 1 and Layer 2.

 

 

2021-05-10 014410.jpg

Edited by Yousung
Link to comment
Share on other sites

@Yousung  Never do any work on Layer "0". It is reserved for 3DC use only. 

//edit

Displacement is exported using the difference of a vertex's position and its position on Layer 0.
Vertice positions will be taken from Layer 0. This is the preferred option for low-poly export.
New user dont know about it, and there is a eternal asking about layer0 and why not to paint it.

Link to comment
Share on other sites

  • New Member

Hi all - RE: BUG HUNTING

 

Nothing major but the Symmetry Tab is not automatically visible on the tool bar and has to be toggled on via the preset panel. 1256790326_symmetrynotvisible.png.a7f25b98d3449c4caf573a90170d3103.png2058758112_presetpanel.jpg.3a55365bb69cdf22db62a6d3c6245895.jpg

 

Also I encountered a bug with the DIAMETER Slider not working. The Gizmo and text inputs work but the mouse slider action doesn't image.png.fb941b6287e4fe7489652fffa142895e.png

 

I hope this is of some use. Keep up the great work!

DIAMETER NOT WORKING.png

Link to comment
Share on other sites

  • Member

Can anyone import iges into the curves tree? Seems a bug over here 

(PS has anyone ever used this fuction? I don't think it's ever worked for me)

- Rich

Edited by -rb-
Link to comment
Share on other sites

Layer 0 itself is not ''reserved for 3DC use only", it's just a normal layer, however there are some functions that have a design flaw where they rely on a "layer 0" existing and having certain colors to function properly. The correct solution for this problem is for said functions to be fixed, not to lock down the layer they're relying on (as that'll just confuse new users further).

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...