Jump to content
3DCoat Forums

3DCoat 2021 development thread


Recommended Posts

  • Advanced Member
1 hour ago, Silas Merlin said:

First thing I wanted to try with new build caused a crash.
I tried to capture it in video but could not (no crash after restart)
Steps :

-choose voxel sculpting on splash screen
-choose bust
-right click build tool > duplicate
-hover over build > end key > CTRL+1 (to assign hotkey)
-hover over new copy of build tool > end key > CTRL+2

-press CTRL+1
-press CTRL+2 > instability warning > save > 3dc closes

upon reopening 3d-Coat the hotkeys are still there, they work correctly, no more crash.
I could not start over because new problem : it seems that it is not possible to remove a hotkey (I expected del key to delete my temporary hotkey).

 

 

could not recreate this.

Link to comment
Share on other sites

9 hours ago, Silas Merlin said:

First thing I wanted to try with new build caused a crash.
I tried to capture it in video but could not (no crash after restart)
Steps :

-choose voxel sculpting on splash screen
-choose bust
-right click build tool > duplicate
-hover over build > end key > CTRL+1 (to assign hotkey)
-hover over new copy of build tool > end key > CTRL+2

-press CTRL+1
-press CTRL+2 > instability warning > save > 3dc closes

upon reopening 3d-Coat the hotkeys are still there, they work correctly, no more crash.
I could not start over because new problem : it seems that it is not possible to remove a hotkey (I expected del key to delete my temporary hotkey).

 

 

BackSpace deletes hotkey.

And I also was not able to reproduce.... If you have crash.txt in documents, please send it to me.

Link to comment
Share on other sites

  • Member
Posted (edited)
20 hours ago, SERGYI said:

Thanks for your kind words and thanks that you have noticed details! I have a question for you. There are two Linux-users who reported that the menu "Bake > Bake w/ Normal Map" crashes "3DCoat". They both are using "21.04". But I am unable to install "21.04" on my system (black screen after EFI, no errors from GRUB). "Bake w/ Normal Map" is working ok on my "20.04". Are you using "21.04"? Is "Bake w/ Normal Map" working on your system?

I am using Fedora 34 at the moment. Have another laptop with 21.04.  Will check do I get that error with it. About black screen, you are probably using Nvidia GPU? Secure Boot is off in BIOS? What driver version? (maybe separate topic?)

Edited by SreckoM
  • Like 1
Link to comment
Share on other sites

  • Contributor
Posted (edited)
3 hours ago, Andrew Shpagin said:

BackSpace deletes hotkey.

And I also was not able to reproduce.... If you have crash.txt in documents, please send it to me.

crash.txt
 

creation date of the file above corresponds to when this happened


EDIT :
I used backspace now
to delete hotkey.
restarted, did the steps again and no crash, sorry :/


 

Edited by Silas Merlin
Link to comment
Share on other sites

  • Advanced Member
Posted (edited)
3 hours ago, Andrew Shpagin said:

No more 3d-crash

For me i am never saw crash log, it's just never created in 2021, and program freeze more often than crash.
Here just crash at import model for per pixel painting with keeping uv, model from marvelous designer it looks heavy for 3dcoat to bake AO and also it produce artifacts on some parts.
And no crash logs in Documents\3DCoat-2021
949409095_screenshot2021-07-31001.thumb.png.542a807e60d358a341d6922f02315c52.png

Hoodie Front pocket zipper.7z crash

Hoodie Front pocket zipper-fix-no crash for AO.7z for AO

Edited by sprayer
Link to comment
Share on other sites

  • Advanced Member
3 hours ago, Andrew Shpagin said:

And if a crash happens, please send automatic bugreports. I am looking at crash reports these days often. My goal now is to make Coat a super stable and polished product. Huge thanks to everyone in this thread. You made this program much, much better. No more 3d-crash)

I like to test beta, but one small issue is when I use windows un-install aprication (from windows menu), it usually remain old beta version coat data.. And I can not remove those orphan data from this menu any more.

I usually use the tool (windows offer) to un-install many beta versions app, then it run un-install exe,and remove most of files. and directory.  but each version of 3d coat remain there.

(eg in this pic, I actually un-install most of beta version 3d coat use, un-install.exe of each version, but windows keep to show it as remain, and can not remove it)

So if you offer correct way to clean un-install, I keep try to install new version.. (recently, remain those old orphan data is somehow annoying  for me)

uninstallclean.thumb.JPG.3afd6fda82d9b69df31250b745c996b6.JPG

 

if you describe clean un-install way for betas (to up date new one) and windows (for my case), I appreciate. 

Link to comment
Share on other sites

  • Advanced Member

I'm finding the brush engine in 2021.16 rather erratic. Video shows basic setup in the Paint Room using a Wacom Intuos Pro ( drivers up to date ). When making the strokes there is a definite lag on the brush when lifting the stylus to start the next stroke causing a drag line in some cases and no stoke being placed at all (1:10 mins) on the 'k'. The quality of the 2021 stroke is very good, but its having to think once the stylus if lifted and that small pause interrupts the painting. Testing with V4 the stroke quality is not as good 2021 but there is no drag line between strokes.

 

  • Thanks 1
Link to comment
Share on other sites

  • Contributor
17 minutes ago, tokikake said:

I like to test beta, but one small issue is when I use windows un-install aprication (from windows menu), it usually remain old beta version coat data.. And I can not remove those orphan data from this menu any more.

I usually use the tool (windows offer) to un-install many beta versions app, then it run un-install exe,and remove most of files. and directory.  but each version of 3d coat remain there.

(eg in this pic, I actually un-install most of beta version 3d coat use, un-install.exe of each version, but windows keep to show it as remain, and can not remove it)

So if you offer correct way to clean un-install, I keep try to install new version.. (recently, remain those old orphan data is somehow annoying  for me)

 

 

if you describe clean un-install way for betas (to up date new one) and windows (for my case), I appreciate. 

I used CCleaner to remove early 2021 builds :
-Tools > uninstall

-then > registry > scan for issues > review selected issues > no > fix all selected issues > close
-after that, folders remain in start menu. To remove them, go to c:programs and delete folders of old builds : they will vanish from start menu

Link to comment
Share on other sites

  • Advanced Member
Just now, Silas Merlin said:

I used CCleaner to remove early 2021 builds :
-Tools > uninstall

-then > registry > scan for issues > review selected issues > no > fix all selected issues > close
-after that, folders remain in start menu. To remove them, go to c:programs and delete folders of old builds : they will vanish from start menu

Ah thanks  I may try CCleaner ,, I got some trouble about other registry Cleaner aprication (do not remember the name though) those app often try to install un-necessary aprication (with installer option),  and the app cause problem then force me to up-date almost all week. so I have not used those app.

CCleaner is stable enough? 

Link to comment
Share on other sites

1 hour ago, tokikake said:

I like to test beta, but one small issue is when I use windows un-install aprication (from windows menu), it usually remain old beta version coat data.. And I can not remove those orphan data from this menu any more.

I usually use the tool (windows offer) to un-install many beta versions app, then it run un-install exe,and remove most of files. and directory.  but each version of 3d coat remain there.

(eg in this pic, I actually un-install most of beta version 3d coat use, un-install.exe of each version, but windows keep to show it as remain, and can not remove it)

So if you offer correct way to clean un-install, I keep try to install new version.. (recently, remain those old orphan data is somehow annoying  for me)

uninstallclean.thumb.JPG.3afd6fda82d9b69df31250b745c996b6.JPG

 

if you describe clean un-install way for betas (to up date new one) and windows (for my case), I appreciate. 

Easiest way to remove old shortcuts:

press on WIN key in the left bottom. Type "control", click on "Control panel". Select Programs there. Then Programs and features. Then rmb over the shortcut, uninstall. Windows will offer to delete the reference. 

  • Like 2
Link to comment
Share on other sites

  • Advanced Member

@SERGYI Is there anyway you can tell us how to generate some debug info for you in linux?

Link to comment
Share on other sites

2 hours ago, insignet said:

I'm finding the brush engine in 2021.16 rather erratic. Video shows basic setup in the Paint Room using a Wacom Intuos Pro ( drivers up to date ). When making the strokes there is a definite lag on the brush when lifting the stylus to start the next stroke causing a drag line in some cases and no stoke being placed at all (1:10 mins) on the 'k'. The quality of the 2021 stroke is very good, but its having to think once the stylus if lifted and that small pause interrupts the painting. Testing with V4 the stroke quality is not as good 2021 but there is no drag line between strokes.

 

Does it happen with both approaches - WinTab & TabletPC?

Is there lag with mouse?

And please turn off vertical synchronization in prefs and try again.

 

  • Like 1
Link to comment
Share on other sites

  • Advanced Member
2 hours ago, Andrew Shpagin said:

Easiest way to remove old shortcuts:

press on WIN key in the left bottom. Type "control", click on "Control panel". Select Programs there. Then Programs and features. Then rmb over the shortcut, uninstall. Windows will offer to delete the reference. 

Thanks it worked to remove those un-used short cut for un-install.   I may try to clean registry later.

  • Like 1
Link to comment
Share on other sites

  • Advanced Member
1 hour ago, Andrew Shpagin said:

Does it happen with both approaches - WinTab & TabletPC?

Is there lag with mouse?

And please turn off vertical synchronization in prefs and try again.

 

Confirmed there is no lag with the mouse.

WinTab solves the problem of the lag but I can can only use a single monitor

The  issue when using WinTab is it doesn't work with dual monitors as the cursor/brush is offset when painting ( see dual monitor video ).

Link to comment
Share on other sites

  • Advanced Member

The Wet Clay brush is fantastic. The whole brush engine has been greatly improved in almost every area. The FPS and speed of strokes is amazing. Think I said it before, but I'll say it again. Keep up the good work Andrew and all the developers.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • Contributor

Oh !
I notice just now the "soft scrape" tick box for the scrape tool !
This is fantastic, because that means you can leave Cuda on in geometry menu and untick "soft scrape", instead of constantly having to disable Cuda when you (I, at least) want to use Scrape tool.

Yet, I have this question again, like for the muscle tool : why are the tool options for those tools on the top bar where you could fail to see them for months or years, instead of in the tool options panel ?

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...