Jump to content
3DCoat Forums

3DCoat 2021 development thread


Recommended Posts

  • Advanced Member
3 hours ago, Andrew Shpagin said:

Is it scene dependent? If so, please send example of sense to andrewshpagin@gmail.com. Are there any other conditions?

It can happened on any project. Just if I don't noticing auto save countdown and don't making the pause in brush movement while it saving.

Link to comment
Share on other sites

  • Advanced Member
Posted (edited)

@SERGYI Cloth tool in new scene with a simple sphere freezes 3D Coat. Create a new scene from start menu selecting voxel sculpting -->large sphere. Select cloth tool. Move cloth shape above sphere. Select start simulation. Nothing happens. 3D coat freezes. After force quitting 3d coat it still has a running process eating up 98% of cpu. Have to kill it from sysmonitor.

Edited by ebitz
Link to comment
Share on other sites

  • Advanced Member
5 hours ago, ebitz said:

@SERGYI Cloth tool in new scene with a simple sphere freezes 3D Coat. Create a new scene from start menu selecting voxel sculpting -->large sphere. Select cloth tool. Move cloth shape above sphere. Select start simulation. Nothing happens. 3D coat freezes. After force quitting 3d coat it still has a running process eating up 98% of cpu. Have to kill it from sysmonitor.

I cant seem replicate this... I've increase the sizes bigger and bigger but still works fine.

can you provide exact dimensions etc

cloth.jpg

Link to comment
Share on other sites

  • Advanced Member
19 minutes ago, jimhatama said:

Clay engine brushes bugged, they sometimes rotate alpha and depth randomly creating tears in mesh, especially in reverse mode. TrspNSD.png

 

With steady stroke a bit smooth but i agreed what it a bit rotating alpha. Also it may shrink alpha in half, i cannot find how to replicate behavior so didin't report about that

Link to comment
Share on other sites

  • Advanced Member

@Elemeno All the dimensions are default. I change nothing. What linux distros and kernel versions are you guys use, where these issues aren't present? 3Dcoat crashes on baking maps and freezes using the cloth tool. @linnos Do you experience this issue with the cloth tool?

Using POP OS (Ubuntu 21.04) Kernel 5.11.0-7620-generic

Link to comment
Share on other sites

  • Member
58 minutes ago, ebitz said:

@Elemeno All the dimensions are default. I change nothing. What linux distros and kernel versions are you guys use, where these issues aren't present? 3Dcoat crashes on baking maps and freezes using the cloth tool. @linnos Do you experience this issue with the cloth tool?

Using POP OS (Ubuntu 21.04) Kernel 5.11.0-7620-generic

@Elemeno @ebitz The cloth tool does freeze for me. Steps:

1. New file with voxel sphere

2. Go to cloth brush and position

3. Click start

Freezes 3D-Coat, it just stays there and I have to forcibly exit the program.

Using Pop!_OS 21.04 x86_64,  Kernel: 5.11.0-7620-generic 

Link to comment
Share on other sites

  • Advanced Member
Posted (edited)

Screen space subdivide dialog looks like have missing description.

after applying, undo should be pressed 3 or more times to revert changes

and it seams it's adding artifacts, if you apply res+ after Screen space subdivide and undo,  it will look like this:

nyV2xPO.jpg

qbzDEEv.jpg

 

Edited by sprayer
Link to comment
Share on other sites

  • Advanced Member

I have a simple request. Could we get a visual highlight on which active HDRI (environment map) is being used to light our scene?

  • Like 1
  • Thanks 2
Link to comment
Share on other sites

  • Advanced Member
Posted (edited)

The "Hide Left Tool Panel" in preferences, does not hide that menu permanently. If I use "Tab" to hid all panels, and "Tab" again to bring them back, it also brings back the Left Tool Panel even though I have the "Hide left tool panel" check in preferences. My way of thinking is that if I make a change in the preferences dialog, that is going to be global permanent change rather than a temporary one. Especially when I can just make the temporary change in the viewport itself. These aren't show stoppers, just some polishing things IMO.

Edited by ebitz
  • Like 1
Link to comment
Share on other sites

  • Advanced Member

I have just been using the Proxy Caching and they are fantastic. The reduce is just fast, and the decimate keeps a lot of the detail even with 4x or 8x reduction (at cost of speed of course).  Nice work.

Link to comment
Share on other sites

  • Advanced Member
Posted (edited)
4 hours ago, linnos said:

@Elemeno @ebitz The cloth tool does freeze for me. Steps:

1. New file with voxel sphere

2. Go to cloth brush and position

3. Click start

Freezes 3D-Coat, it just stays there and I have to forcibly exit the program.

Using Pop!_OS 21.04 x86_64,  Kernel: 5.11.0-7620-generic 

Same here,

3DCoat 2021.06

Ubuntu 20.04, Kernel 5.8.0-59-generic

Edited by Allabulle
Link to comment
Share on other sites

  • Advanced Member
7 hours ago, Allabulle said:

Same here,

3DCoat 2021.06

Ubuntu 20.04, Kernel 5.8.0-59-generic

using windows 10 but it still works.. i even bumped up res lot!!

however this is still here the cloth collision failing 
 

breaking.jpg

Link to comment
Share on other sites

  • Contributor
1 minute ago, Elemeno said:

fixed artefacts .... I needed to thicken the mesh more.

that looks like a mesh that was voxelized then turned to surface (maybe you used resample ?)

do you still have the mesh that was not thickened ?
try importing it this way :
File > import > import mesh for voxelization
then, before apply tick "import W/o voxelization"

(by the way, when you do that you get the splash screen, I think that is a bug)
 

  • Like 1
Link to comment
Share on other sites

  • Advanced Member

@SERGYI @linnos After further investigation "Crash On Bake", If I leave these options on "Name Correspondence For Baking" and "Import Tiles As UV Sets", 3D Coat will create a paint mesh in the paint room without an immediate crash. A normal map is baked, however there is no height info. Essentially it acts like "Retopo to Paint Room with no bake" option. Problem may lie with the "Treat Materials As Separate Textures" or "Import Tiles As UV Sets".

Link to comment
Share on other sites

  • Advanced Member

@SERGYIBug? New scene-->Voxel-->Large Sphere-->Retopo Room-->3D Primitives-->Choose any primitve and apply-->Switch to a different tool-->Mesh disappears and is not created. Can anyone else confirm @linnos?

Link to comment
Share on other sites

  • Advanced Member
Posted (edited)
1 hour ago, ebitz said:

@SERGYIBug? New scene-->Voxel-->Large Sphere-->Retopo Room-->3D Primitives-->Choose any primitve and apply-->Switch to a different tool-->Mesh disappears and is not created. Can anyone else confirm @linnos?

It worked here, but the new primitive stays "inside" the large sphere, if I hide the layer in the sculptTree I can see the primitive generated.

Edited by Allabulle
Link to comment
Share on other sites

  • Advanced Member
Posted (edited)

Ok. I got the 3d primitive working in the retopo room. Deleted the user config files in Documents and restarted 3D Coat. Some conflict resolved I guess. Nope Ignore that. The Preferences-->Beta TAB-->Treat Retopo groups as materials is the culprit. If I disable it the 3d primitives mesh is not generated in the viewport.

Edited by ebitz
Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 2021 development thread

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...