Jump to content
3DCoat Forums

3DCoat 2021 development thread


Recommended Posts

  • Reputable Contributor

Windows version: 2021.58

Input for the beta bevel.

Stretching Problems.  On more complex curves the outer sides, the triangles are more stretched out. The inner area has some stretching as well just not as much.  Adding more subdivision levels make no difference, also choosing vertex average or vertex normal makes no difference either.  First two pictures.

-----------------------------------------------------------------------------------------------------------

The below is for improving the tool.

Is it possible to add a sharp cut off at the ends of the curve for when we what only a partial bevel a certain length on an object. 

Last picture show the area I am talking about. 

-----------------------------------------------------------------------------------------------------------

Side Note: You can see even on a simple bevel in my last picture the outer edges are a little ragged. I increased the subdivision, helped but did not completely solve the problem. Now I can run a "Smooth" on the simple curve to get rid of the ragged edges but you lose a little sharpness of the bevel. Running smooth helps a little on the complex curve but does not fix the stretching problem. 

Maybe adding the "remove stretching" selection to the bevel tool will help. I do not know of course, just an idea.

 

stretching.jpg

stretching_02.jpg

Sharp.jpg

Link to comment
Share on other sites

On 10/5/2021 at 1:57 PM, ajz3d said:

@Andrew Shpagin

Is AngelScript's split method of the string data type implemented in 3D Coat 2021?

I keep on getting:

My current code:

Vox v;
const string s = v.names();
array<string> lrs = s.split(',');

I think I'm misinterpreting the definition of this method, as it seems to be using AS object handle (@), which I'm not familiar with:

array<string>@ split(const string &in delimiter) const  

Could you please provide an example of how this method is supposed to be used?

Seems we need to update the Angelsript to the latest version. We will do it gradually.

  • Thanks 2
Link to comment
Share on other sites

  • Advanced Member
4 hours ago, poeboi said:

@insignet Hello, could you also try Windows → Restore This Page Layout ?
Means you will have to set the layout up again but, I believe there was a problem a few builds past where after updating and setting a new layout, it would obscure new tools added since the build the layout was created on 
Maybe worth a shot

thanks... it was my custom page layout. Reset to Default solved the issue.

  • Like 2
Link to comment
Share on other sites

  • Reputable Contributor

Windows version: 2021.58

Bevel Tool:

First I like to say the ability to create complex bevels is great!  Thanks again for the new bevel tool... Shown in second picture.

More testing:

I found one reason for the stretching using the bevel tool.

I used it over an area that I had used the pose tool on.

Pose tool creates a different polygon elongated structure. Shown in the picture.

Res+ does not change the structure.

Using the subdivide tool is just like the Res+

Resample: Creates more of a voxel type of structure.  

If possible have the Resample to a change the mesh like when you go from Voxel mode to surface mode.  However it is done. Through relaxing or reordering the polygon mesh. This has been discussed before so I am not rehashing here but since the bevel tool has been added it is more important now. 

Maybe adding a remove stretching selection to the Pose Tool would be a solution. 

---------------------------------------------------------------------------------------------

Faceting. I noticed that using the default shader, the faceting is hidden by a large degree but changing shaders revels the faceting when using the new curves in some situations. The faceting has been reported by other users off and on in the forums.

 

elongated.jpg

complex.jpg

  • Thanks 1
Link to comment
Share on other sites

  • Member
On 9/26/2021 at 8:05 AM, milhouzz said:

thanks for the last update guys :)

sometimes the ctrl+z is only going back one step in the history, i have to go in edit and do undo manually to go back further

Similar in Textura 2021.57

not sure if this is a bug:

Can't hold ctrl+z to go back multiple steps, have to keep pressing the key. In Photoshop you can hold to keep undoing or scroll back through the history panel. Does this not exist in 3Dcoat?

Edited by #000wizard
Link to comment
Share on other sites

- Adding Smart material new icons are not working, confirmed.

- Adding new texture Folder icon is not working.

- Roughness, Metalness or Glosiness ? Bad typo ?

Roughness.jpg

  • Thanks 1
Link to comment
Share on other sites

  • Reputable Contributor

 Windows Version: 2021.59  "Most of reported problems related to bevel solved. Complex cases of bevel lines intersections taken into account, even mixed convex-concave. No more faceted surfaces. More accurate edge between the bevel and the rest of surface."  

The above is from the information given about version 2021.59

Beta Bevel Tool:

So far in my limited testing all the above is fixed as stated. A big thanks for these quickly done fixes. 

I will test more and report back. 

Side note: The Bevel Tool is a new beta so continue to test and give constructive feedback.  Since we have open beta, our user feedback helps any new tool added to 3DC. Yes it takes time but is worth the effort if you have time do so. 

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member

Hi, i am testing the latest 3dc2021 and loving it so far, my only issue is the shader for undercuts is not ideal for sculpting. 

Hope you add some options there. Thank you.

Capture.JPG

//edit

Fixed on version 2021.61

Edited by Carlosan
uptodate info
Link to comment
Share on other sites

  • Member

The .60 version has great corners, but freeze and subdivision edges will conflict with each other. If you first use freeze and then use subdivision edges, the frozen area will automatically disappear. Have you noticed this problem?

Edited by Tubor
Link to comment
Share on other sites

  • Member

Anyone having any issues with 3DCoat on Windows 11? I have experienced a script error when initiating the interactive tutorials and also whenever I activate the voxel surface mode and pick a 3d primitive, "Sphere for instance," It displays the grid but no mesh. Would love to get your feedback. 

Link to comment
Share on other sites

3 hours ago, Jimmie said:

Anyone having any issues with 3DCoat on Windows 11? I have experienced a script error when initiating the interactive tutorials and also whenever I activate the voxel surface mode and pick a 3d primitive, "Sphere for instance," It displays the grid but no mesh. Would love to get your feedback. 

It is fixed in 60

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member

In Sculpt room, 'Auto Pick' doesn't work as I would expect it (it might be intended to work this way, not sure about that).

What you can pick in the viewport with 'Auto Pick' activated depends on what is selected in the SculptTree (when a surface object is selected initially, only surface objects in the viewport can be selected by clicking on them. Same with voxel objects).

It should be possible to have a surface object selected, and then use Auto Pick to click-select a voxel object in the viewport, and vice versa, in my opinion. I see no reason to limit the functionality in this way. Or is there a reason for this?

There should also be functionality to activate the checkbox temporarily (hold down keyboard key: activate, release key: deactivate). I constantly need to click the checkbox to de-activate it after selecting an object, because I'm selecting other nearby objects accidentally when sculpting.

When the object selected is set to not visible in the SculptTree, nothing else can be selected in the viewport by clicking an object, neither voxel nor surface objects. Undesirable behavior.

Edited by wilson66
Link to comment
Share on other sites

  • Advanced Member

having massive issues with the move tool in .59   After a while strange things start happening...hole in the mesh, etc...see the attached video.  This is just tapping the mesh with the move tool.  The mesh is pretty simple as well, just a 100K base head, nothing crazy.  Please take a look at this ASAP, in the meantime I will downgrade. 

  • Sad 2
Link to comment
Share on other sites

2 hours ago, nobackup said:

having massive issues with the move tool in .59   After a while strange things start happening...hole in the mesh, etc...see the attached video.  This is just tapping the mesh with the move tool.  The mesh is pretty simple as well, just a 100K base head, nothing crazy.  Please take a look at this ASAP, in the meantime I will downgrade. 

I am not able to reproduce.All works as expected. I tried on the head from the start menu. Please show the full screen to see the tool settings and vox tree.

Link to comment
Share on other sites

  • Member

In the last version can't export glossiness, always exported roughness.

Update, 3d-coat restart after I had changed glossines export option helped to export right texture, but I think that program restart isn't normal way to solve some issues.

Edited by Arvart
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...