Jump to content
3DCoat Forums

3DCoat 2022 development thread


Recommended Posts

I plans (after complete cleanup cycle) I plan to improve automapping to produce less count of seams. 

1 hour ago, kain_ty said:

I see the same phenomenon with objects in BrassPipes.
I can place the SoftBrick, SoftBrickEdge, and SoftbrickSmall in the Default folder, but for the others, the model does not show up and only the green joints increase.

20210804_164310.jpg.f4acc30861125c65d8f0779d309ec68a.jpg

Please run 3DCoat, try to place "invisible" joints models, then exit, find file Documents/3DCoat-2021/log.txt and attach the file to the post or send me to andrewshpagin@gmail.com

Link to comment
Share on other sites

  • Member
56 minutes ago, Andrew Shpagin said:

I plans (after complete cleanup cycle) I plan to improve automapping to produce less count of seams. 

Please run 3DCoat, try to place "invisible" joints models, then exit, find file Documents/3DCoat-2021/log.txt and attach the file to the post or send me to andrewshpagin@gmail.com

In the case of KitBash, there was a strange behavior right after startup, so I'll report it here.
Start Menu > Select KitBash
Click on "model" in JointWindow
For some reason, it switches to the Curve tool.
Click on the Joints model again.
It switches to the Joints tool, and when I click on the main window, the green joints are placed.
For some reason, it switches to the Flatten tool.
That's all I've done until the end.

Translated with www.DeepL.com/Translator (free version)

Log.txt

Link to comment
Share on other sites

36 minutes ago, kain_ty said:

In the case of KitBash, there was a strange behavior right after startup, so I'll report it here.
Start Menu > Select KitBash
Click on "model" in JointWindow
For some reason, it switches to the Curve tool.
Click on the Joints model again.
It switches to the Joints tool, and when I click on the main window, the green joints are placed.
For some reason, it switches to the Flatten tool.
That's all I've done until the end.

Translated with www.DeepL.com/Translator (free version)

Log.txt

Please select Surface mode in the start menu, empty scene. Then manually select the joints tool in the tools list. Click on some model in the Brass pipes. Ensure you are still in joints tool. Try to add pipe to scene. What happens?

Link to comment
Share on other sites

  • Member
26 minutes ago, Andrew Shpagin said:

Please select Surface mode in the start menu, empty scene. Then manually select the joints tool in the tools list. Click on some model in the Brass pipes. Ensure you are still in joints tool. Try to add pipe to scene. What happens?

I selected Surface Sculpting, activated the Jonts tool, selected the Brass_Fit_Straight model and placed it.

Again, only the green joints were placed.

Log.txt

Link to comment
Share on other sites

15 minutes ago, kain_ty said:

I selected Surface Sculpting, activated the Jonts tool, selected the Brass_Fit_Straight model and placed it.

Again, only the green joints were placed.

Log.txt

I noticed some problems when joints activated from the voxel mode. It is solved, look next build. But if you already in surface mode, it works correctly on my side. Could be good to get fullscreen video, from the start menu. I need to see tool parameters and VoxTree panel.

Link to comment
Share on other sites

  • Member
1 hour ago, Andrew Shpagin said:

I noticed some problems when joints activated from the voxel mode. It is solved, look next build. But if you already in surface mode, it works correctly on my side. Could be good to get fullscreen video, from the start menu. I need to see tool parameters and VoxTree panel.

I recorded it.
It's very comfortable with the available joint models.

This feature seems to have a lot of uses in map editors and other applications if painted models can be used.
If it is possible to create scenes with painted models, it would be great.
If it is possible to create a scene by placing painted models, I think the value as a rendering tool will improve dramatically, and I look forward to its future development.

Translated with www.DeepL.com/Translator (free version)

Link to comment
Share on other sites

4.08.21 2021.21

- Finally fixed the problem when the voxel object disappears if the second stroke starts.

- Problem of the "bulky" build tool is fixed, actually Build may work correctly only in Buildup mode, so this option was just removed, and now Build works always in Buildup mode.

- Falloff is taken into account in the voxel brush engine.

- Closing cross in start menu now works correctly.

- If the joints tool is activated from the joints thumbnails panel, the new surface object will be created, because joints may work correctly only in the surface mode.

- Text correcting system (by user) writes timestamp and author to the textual XML for ease of future merging. It is important for translation the text by multiple users, done now mostly because of Japanese user's requests.

 

Mac&Linux builds are in process, will be available soon as well for the 21 build.

  • Thanks 3
Link to comment
Share on other sites

  • Member

@SERGYI
This log should help with the crashing on bake issue. It seems like is has something to do with the sRGB profile. Some posts ive been seeing say it could be tied to PNG images: 

Aug  4 12:35:54 pop-os touchegg[1306]: libinput error: client bug: timer event9 debounce short: scheduled expiry is in the past (-5ms), your system is too slow
Aug  4 12:35:54 pop-os /usr/libexec/gdm-x-session[2514]: (EE) client bug: timer event9 debounce short: scheduled expiry is in the past (-5ms), your system is too slow
Aug  4 12:35:57 pop-os systemd[2220]: tracker-extract.service: Succeeded.
Aug  4 12:35:58 pop-os touchegg[1306]: libinput error: client bug: timer event9 debounce: scheduled expiry is in the past (-8ms), your system is too slow
Aug  4 12:35:58 pop-os touchegg[1306]: libinput error: client bug: timer event9 debounce short: scheduled expiry is in the past (-21ms), your system is too slow
Aug  4 12:35:58 pop-os /usr/libexec/gdm-x-session[2514]: (EE) client bug: timer event9 debounce: scheduled expiry is in the past (-8ms), your system is too slow
Aug  4 12:35:58 pop-os /usr/libexec/gdm-x-session[2514]: (EE) client bug: timer event9 debounce short: scheduled expiry is in the past (-21ms), your system is too slow
Aug  4 12:36:05 pop-os dbus-daemon[2324]: [session uid=1000 pid=2324] Activating via systemd: service name='org.freedesktop.Tracker1.Miner.Extract' unit='tracker-extract.service' requested by ':1.2' (uid=1000 pid=2317 comm="/usr/libexec/tracker-miner-fs " label="unconfined")
Aug  4 12:36:05 pop-os systemd[2220]: Starting Tracker metadata extractor...
Aug  4 12:36:05 pop-os tracker-extract[344772]: Set scheduler policy to SCHED_IDLE
Aug  4 12:36:05 pop-os tracker-extract[344772]: Setting priority nice level to 19
Aug  4 12:36:06 pop-os dbus-daemon[2324]: [session uid=1000 pid=2324] Successfully activated service 'org.freedesktop.Tracker1.Miner.Extract'
Aug  4 12:36:06 pop-os systemd[2220]: Started Tracker metadata extractor.
Aug  4 12:36:07 pop-os org.gnome.Nautilus[344616]: libpng warning: iCCP: known incorrect sRGB profile
Aug  4 12:36:08 pop-os systemd[1]: systemd-hostnamed.service: Succeeded.
Aug  4 12:36:12 pop-os org.gnome.Nautilus[344616]: libpng warning: iCCP: known incorrect sRGB profile
Aug  4 12:36:23 pop-os kernel: [190172.749723] [UFW BLOCK] IN=enp4s0 OUT= MAC=01:00:5e:00:00:01:44:d4:53:7b:52:52:08:00 SRC=192.168.1.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0x00 TTL=1 ID=54745 DF PROTO=2 
Aug  4 12:36:12 pop-os org.gnome.Nautilus[344616]: message repeated 2 times: [ libpng warning: iCCP: known incorrect sRGB profile]
Aug  4 12:36:33 pop-os org.gnome.Nautilus[344616]: The futex facility returned an unexpected error code.

  • Like 1
Link to comment
Share on other sites

  • Advanced Member
8 hours ago, Silas Merlin said:

I have not tested but I think I don't need to : In 3d-Coat a paint object cannot be without UV's, therefore, if you have not marked seams/unwrapped before baking, 3d-Coat will do it for you.
I think this is perfect, no change needed in that respect.

Though you think it  work for you  but I think the  auto UV map not good clean uv. 3d coat generate auto-UV map for primitives in paint room when bake, but retopo mesh still not have any UV map.  (then generated UV map is not good clean uv which I epxect)  then after all I may need to send back with UV to retopo room and manually set seam to check it in retopo room.

If you check other modeling aprication  primitive witch come UV, you may understand why I expect it for 3d coat retopo  (and modeling room) primitives. even though I model complex one, as start point good UV is more easy to edit.  you may actually compare primitive default UV maps (blender).  and 3d coat auto un-wrap UV (when bake).  I suppose after all if 3d coat offer those default UV (or auto seam for those primitives)  you never complain it. 

BUVsphere.thumb.JPG.745412176a71d623dd06b329b5ccc825.JPG

 

auto generated UV of UV sphere (in 3d coat)

coatUV.thumb.JPG.684d0ee32366de83875926d1effddebb.JPG

cylinder

Bcylinder.thumb.JPG.a0a61191d8db8c5d73e5b29f241cd45b.JPG

3d coat auto UV for cylinder

coatcylinder.thumb.JPG.c969bdb4cfedf617193c8a1682c6a550.JPG

I may not need to add other UV for primitives. so I do not say 3d coat need to becom same , but simply hope to see clean default UV for primitives. without any work.

Link to comment
Share on other sites

  • Reputable Contributor

Windows version  20.21

Microvextex import into the paint room.

Render room renders the color of the model black in the render room.

Steps to reproduce:

From the New Menu. Choose  Paint w/deep displacement (Micro-Vertex)

Select the creature. Do one subdivision upon import.

Fill a color over the entire model.

Switch to the render room. Model is black.  Render room is using 3D Coat hardware. 

Tested with just Real time render on and Real time render on with Screen space reflections and illuminations. Same result. 

(Side Note: The model is black even if you fill with no color)

If you turn off real time render the color appears. 

Uploaded picture is from the render room.  

 

black.jpg

Link to comment
Share on other sites

  • Member
2 hours ago, digman said:

Windows version  20.21

Microvextex import into the paint room.

Render room renders the color of the model black in the render room.

Steps to reproduce:

From the New Menu. Choose  Paint w/deep displacement (Micro-Vertex)

Select the creature. Do one subdivision upon import.

Fill a color over the entire model.

Switch to the render room. Model is black.  Render room is using 3D Coat hardware. 

Tested with just Real time render on and Real time render on with Screen space reflections and illuminations. Same result. 

(Side Note: The model is black even if you fill with no color)

If you turn off real time render the color appears. 

Uploaded picture is from the render room.  

 

black.jpg

This happens on linux as well, specifically for Ubuntu 21.04:

Steps to reproduce:

New file > Big Sphere (Or any object) > Render room > Black model

Link to comment
Share on other sites

  • Member

There was Crease Clay that I loved to carve wrinkles in Live Clay. Now it has gone with that great Live Clay, I'm looking for an alternative one.

I thought Pinch could be a successor cray for Crease Clay. For now this one won't put so sharp wrinkle to my model, but my face.

How can I get an equiv result to Crease Clay?

 

 

image.thumb.png.60bb03062a707ece4a9f3114f671f8ba.pngimage.thumb.png.32ee816e93e0c3e319f05692f5c4f12e.png

Link to comment
Share on other sites

  • Member
18 minutes ago, digman said:

You want something like this. 

Not demonstrating human skin just my preset pinch tool.

 

 

Oh that's scales. Sure that Pinch is nice to draw scales.

I wanted to make like this image (made in 4.x) again in 2021, too.

 

ss3dcoat.jpg

Link to comment
Share on other sites

  • Member
17 minutes ago, digman said:

Instead of posting here, I will start a 2021 thread on the creation of brushes. Everyone can jump in and ask for a brush, show and or share their preset brushes. 

Sorry, I agree and will start it over again after I read this.

 

 

Link to comment
Share on other sites

  • Advanced Member

 

in Tweak room,

maybe brush stroke length and vertex moving length is different.

(I have to push ctrl+Z twice  when I want to undo. )

is it error ?   is it  in the specifications?

 

Link to comment
Share on other sites

On 7/30/2021 at 3:28 PM, Andrew Shpagin said:

30.07.21 2021.16

- Snake/muscle/toothpaste tools streamlined and polished - more accurate stroke, smoothing, snapping now has sense, huge values of smoothing - as well (if need almost straight line). Muscle was renamed to Tube/muscle and has now two additional profiles - Bar and Alpha.

Could you add Procedural Brush Shape to Tube/Muscle types ?

brush_EditBrushshape.jpg

- Snap to surface = ON

If stroke is paint from the mesh to the outside of the mesh, produces rare endings.

Snap to surface.jpg

Thanks

  • Like 1
Link to comment
Share on other sites

  • Advanced Member

i know this isn't an add feature section but can we get a precise square tool... would act like muscle tool but you click a starting point and it gives you a gizmo and you rotate and then drag out for precise placements of a muscle tool that allows alpha too.... just a lot of the time i concept build and this would speed up my modelling so much

Link to comment
Share on other sites

1 minute ago, Elemeno said:

i know this isn't an add feature section but can we get a precise square tool... would act like muscle tool but you click a starting point and it gives you a gizmo and you rotate and then drag out for precise placements of a muscle tool that allows alpha too.... just a lot of the time i concept build and this would speed up my modelling so much

For precise placement use this - set relaxing to maximum (500), set snapping to surface, then click and drag. Not sure, but maybe it will help.

  • Like 3
Link to comment
Share on other sites

28 minutes ago, Carlosan said:

Could you add Procedural Brush Shape to Tube/Muscle types ?

brush_EditBrushshape.jpg

- Snap to surface = ON

If stroke is paint from the mesh to the outside of the mesh, produces rare endings.

Snap to surface.jpg

Thanks

Just add procedural alpha into the palette. Press add icon in the alphas palette. Create using curves.

Link to comment
Share on other sites

5.08.21 2021.22

- Paint room/airbrush fixed, it works completely correctly with fast strokes regarding opacity, gloss and metalness, ppp/mv/ptex.

- Solved problem when first RMB click over the curve is "skipped" and only the second one works. Now first click triggers the menu as well.

- There was the situation when you start to paint over voxels and the "Cavity layer" was activated as the layer to paint. Now Layer1 will be created for this purpose.

- Multiple UI tweaks for a nice look.

  • Like 1
  • Thanks 2
Link to comment
Share on other sites

  • Reputable Contributor
On 8/4/2021 at 7:21 PM, tokikake said:

BUVsphere.thumb.JPG.745412176a71d623dd06b329b5ccc825.JPG

 

auto generated UV of UV sphere (in 3d coat)

 

sorry no it does not work for me, I did not think it through, all I meant was that 3d-Coat would not let you leave the retopo room without adding uv's, and I thought you were complaining about the possibilitiy of ending up in the paint room without, which is impossible, that is all.

As for uv's like these, 3d-Coat does have them, but they are well hidden, and, granted, not in a primitive.

this won't help you, but just so you know
In the video, please note that nothing seems to happen when I click ok to import : that is because upon import in the paint room, the object is invisible, but it is there, trust me :)
you can do the same thing for the cylinder.

EDIT :
It might be possible to drag the resulting object into the retopo models panel to create the primitives you want with this kind of uv's.
However, 3d-Coat "SL objects" are very fragile, at least they were in 4.9
They break easily probably because of the odd unwrapping that 3d-Coat is not used to working with. you might lose triangles at the poles of the sphere for example.

 

Edited by Silas Merlin
Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 2022 development thread

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...