Jump to content
3DCoat Forums

3DCoat 2022 development thread


Recommended Posts

7 hours ago, tokikake said:

Bake retopo > per pixel (no baking) change uv set order , then it cause wrong texture which I already paint for paint mesh.

my step

1.  import mesh witch have 4 material group (then 3d coat need 4 uv set ) in paint room, then paints. 

2.  I found some layered faces of morphed mesh.  which cause issue (dark spot) when paint, then send paint mesh to retopo mesh by Take mesh from paint room

3.  adjust some edges to remove overwrap, then use Bake retopo > per pixel (no baking) to return geometry only. 

I suppose it keep current UV and paint layers for each UV set,  (I did not edit it) and overwrite paint mesh geometry as retopo mesh, actually it seems work.

but it change UV set order in paint room, or change paint layer infomation. then cause wrong paint for each UV set (material) part.

with check UV and texture of return mesh,  in paint room, I think UVset name and each UV is correct, so there seems some problem to re-attach texture for each UV set . it swap textures between different UV set.  

breakuvset.thumb.JPG.aaa23511c7971985d1d50c25b9a3a37b.JPG

this pic show, the texture which painted for body part (template 2) now used for template1 UV set (head part) after return mesh by Bake retopo > per pixel (no baking) 

paintedtexture.thumb.JPG.a224daf03d7f0281266b3b01adfc6983.JPG

, but I think the UV set and mesh part is same as before. (just to confirm of course I could paint correctlly, when I import mesh to paint room with smart material, so it apply each texture for each UV set part correctly )

I think it was reported before by other user, but the problem seems remain.  Then  we need more stable option  For these work. (edit paint mesh geometry only then return with keep UV and textures), I know tweak room can direct edit paint room mesh , but actually it never work well for detail polgion edit.

(like hide complex part, then move some verts of eye  back faces, to edit such detail,  I must need to work in retopo room with hide many parts and move verts with gizmo)

Please send me the scene to andrewshpagin@gmail.com, I will look.

Link to comment
Share on other sites

  • Advanced Member
5 hours ago, digman said:

@tokikake 

Did you try this setting under the bake menu after you made your adjustments.

update mesh.PNG

Thanks actually I do not clear remember, which tool I actually used to return mesh.. but now I re-try it, and no. I tried, Update Paint mesh with Retopo Mesh corrupt UVorder.

I could confirm it with more simple mesh (and not include product mesh), then will send scene for Andrew. (untill use Update paint mesh with retopo mesh) which can reproduce this issue easy.

paintedmesh.thumb.JPG.06ff10dbd224062ce1b8b4c3262dd944.JPG

retopomesh.thumb.JPG.54e7eeb5cd5f3e42de8cfbe94fe557bf.JPG

update.thumb.JPG.b32d5b004516d3434a6c31b5a4c59ee7.JPG

 

 

Edited by tokikake
Link to comment
Share on other sites

  • Advanced Member
2 hours ago, Andrew Shpagin said:

Please send me the scene to andrewshpagin@gmail.com, I will look.

I sent mail, with more simple scene. which use another mesh (with 4 material), and paint, then send to retopo room.

so try "return retopo mesh to paint mesh. " p;ease >> it change UV layer and break painted textures. 

this time I used Update Paint mesh with Retopo Mesh as digman adviced.  but it show same issue. (so which option I use, actually 3d coat seems swap UV set when there are multiple UV set, when return/bake to Paint mesh. 

(though I understad I may only need ,export textures and re-assgin correctly I suppose though)

I seems attach too many pic for report, then now I can not add new pic so can not offer final image, but it actually swap textures. 

(actually I seems use Update Paint mesh with Retopo Mesh for first report, because now I test ,  Bake reto po > per pixel (no b aking)

it just generate duplicated mesh without texture (then 3d coat complain I have same material groups for 2 object in paint room,, I think it may need to report too. because I suppose there should be case we use same material (surface name) for different mesh. (but load those 2 mesh) , so I suppose we need way, 3d coat manage UV set for each UV object.  (then we can use same UV set (material) name for 2 or 3 object.  

 

Edited by tokikake
Link to comment
Share on other sites

  • Reputable Contributor

Windows Version 2021.30

The measure tool now works correctly (no lag) plus the numbers overlayed on top of the measure line are much easier to read.

The stamp mode tool from the e-panel works correctly now as well.   You can rotate the alpha plus increase size of the brush radius as the tool use to work like. 

Thanks... 

Link to comment
Share on other sites

  • Advanced Member
9 hours ago, Andrew Shpagin said:

Please send me the scene to andrewshpagin@gmail.com, I will look.

Thanks many up-date.

Then I test UV set and texture exchange issue more... 

it  happen even though I export retopo mesh as obj, then in paint room use "Update geometry" option, and import the obj.

I can see, the UV set order change in import dialogue, after that 3d coat miss apply textures as same as before.

The problem seems happen when pick paint room mesh which have multi uv  sets (1 to 4)  to retopo room then export mesh,.  the uv set order (in paint room) change, 

Though we can not check the UV set order, in retopo room, (just change UV set ), but when export the retopo mesh and  import for paint room we can see UV set order change from which we see in paint room. Then it cause swap texture.. (I think 3d coat try to apply each UV set assgin texture,  in paint layer with the order, then texture swap)

(UVset name  and assgin mesh keep same, so it seems caused the UV set order, which 3d coat record)

I can not check code , but I suppose if  use UV set "name"  to set texture,, it may work correctly..  at current I suppose,  when re-import mesh, it may use list key not name to set texture for each UV sets.   UVsets[0],  UVsets[1],  UVsets[2], UVsets[3].  but it can change to check UV set name I suppose. UVset["template1"] ,  UVsets["template2"] ...so even though list order change, can apply texture as same as before.. 

Link to comment
Share on other sites

  • Advanced Member

this is awful. .30 crashed few times reset all my settings, changed somehow camera movement diraction and speed. And stamp mode also bugged in mirror mode. Mirror plane also flickers now when you moving cursor on volume

Edited by jimhatama
Link to comment
Share on other sites

  • Member
On 8/10/2021 at 9:48 AM, Daffyd said:

Hey ho,

found some issues:

QuickAccess

Add preset to QuickAccess slots doesnt work. After choosing the Slot X Nothing happens to the Quick Panel
I am only able to add the Default Tools in QuickAccess 


Modeling unlinked Sculpt Mesh issue 2021.25:

1 create a Primitive (PolyGroup1), 
2 mesh -> sculpt mesh -> unlink -> PolyGroup1_unlinked is created
3 create new PolyGroup2
4 do the same like PolyGroup1 -> only PolyGroup1 creates copies of itself or nothing happens but every time PolyGroup2_unlinked never will be created


In another project, all previous unlinked sculpt meshes disappear as soon as I create a new one. Unfortunately, I cannot reproduce that. And it's not undo-able.

But important is, this bug makes the Modeling-Sculpt Mesh Feature unusable :(

 

Hi I want to make sure that my post has not been overlooked. I think it's a very serious problem that can break projects. 

Link to comment
Share on other sites

1 hour ago, Daffyd said:

Hi I want to make sure that my post has not been overlooked. I think it's a very serious problem that can break projects. 

Hi! Thanks for the message, we didn't miss it. Were busy with other urgent tasks. We will fix this bug shortly. 

  • Thanks 1
Link to comment
Share on other sites

  • Reputable Contributor
49 minutes ago, jimhatama said:

All controls transform gizmo lost its scale controls 

EHADcPU.png

Windows version 2021.30

Confirmed. I should say it has happen to me also. Though at this time I do not have steps to reproduce. It seems to randomly happen at times. If I can reproduce I will post the steps.

Link to comment
Share on other sites

  • Advanced Member

Can we get the ability to select multiple thing in the sculptree and parent them at the same time?  It is super frustrating to have to go through one by one, parenting things if you need to change your hierarchy.  You should just be able to shift select a bunch of layers, and then drag them to a new parent layer.  Currently you can shift select several layers, but when you go to parent them it only does the first layer.  Little usability things like this make all the difference! 

  • Like 3
Link to comment
Share on other sites

  • Advanced Member

Select/Transform tool for retopo mesh >> tool option>> hide gizmo and dialogue not hide gizmo. It temporally hide while I keep click the button.

Gizmo often disturb to select near verts ... but may not hope to change tool as select only just for the purpose ( hope to keep same tool, select>transform>select>transform)

selectgizmo.JPG.7e8ba7bebaa3135019f168c8cd895621.JPG

 

Edited by tokikake
Link to comment
Share on other sites

  • Member
7 hours ago, nobackup said:

Can we get the ability to select multiple thing in the sculptree and parent them at the same time?  It is super frustrating to have to go through one by one, parenting things if you need to change your hierarchy.  You should just be able to shift select a bunch of layers, and then drag them to a new parent layer.  Currently you can shift select several layers, but when you go to parent them it only does the first layer.  Little usability things like this make all the difference! 

Hello, this is not to say "we have this already" and might not exactly be what you're looking for but here's one method on how to group/parent multiple sculpt object, in case it help

Edited by poeboi
vid
  • Like 2
Link to comment
Share on other sites

  • Member

Using Noise in the surface mode, the real-time preview and the confirmed result are too different. If the preview cannot be the same as the result, the real-time preview is worthless, and I hope it can be fixed. This is also a more important carving tool .

image.thumb.png.b77cdff4813e65af7110651b66cdbf35.pngimage.thumb.png.8ae3c7151b3eb49b50e9a6bf1c30353d.png

Edited by Tubor
Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 2022 development thread

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...