Jump to content
3DCoat Forums

3DCoat 2022 development thread


Recommended Posts

  • Advanced Member
1 hour ago, Gorbatovsky said:

Thank you for your feedback.

I really like 3d coat dev working way (try to keep communication for basic user like me) , then just hope 3d coat more user friendly. (I know you are main developer about these new curve tools and thanks you enhance for retopo and modeling room^_^

Then I have some bug? (maybe I think) reports about curve related tools in retopo/modeling room tools.

1.  I can not correctly locate new curve on plane (XY, XZ, YZ)  I tried to use "on plane" option, with set each world XY, XZ, YZ, but even though I set orthographic view , and set plane so, new curve not locate on the world plane. 

2.  when Scene scale not = 1.00,  generated cap (start) change scale but other mesh keep the scale (which decided by Scene scale). then I often need to remove cap only and re-fill it.

About locate/draw new curve on the virtual plane where user intend is my main problem (though I can manipulate each curve point or full transform with gizmo and input location, but I hope to know how you generate new curve on your intend plane like world XY plane strictly.  so if I miss option or usage teach me please if you can. (I believe maybe some other user have same question about "on plane" option) 

I now try to learn all new curve tool usage, then these 2 is current problem for me... (most of other options seems work as I expected, thanks you offer example curve for some tools (auto generate)  so I can try and error without many difficulity. (maybe  I think we may request option, not generate sample curve as future)

I attach google drive link to show the image.. check these please..

https://drive.google.com/file/d/1-17eP6s1iWJ3jKaeLjrBSSYViSdMqPVR/view?usp=sharing

https://drive.google.com/file/d/1-2-sWCcEDhVwJ3ThQwG5iQvNiMi7I1hP/view?usp=sharing

 

Edited by tokikake
Link to comment
Share on other sites

  • Advanced Member
4 hours ago, Gorbatovsky said:

Added me TODO.

Thanks, at first I hope it work for simple world plane with orthographic mode. Or with view , if you can add option which auto locate curve on the current orthographic view. 

I means, when I set Fromt view >>  curve auto generated on the XY plane ..with the options. so we can strictly set curve for modeling then easy use curve tools. (swept gender etc)

At current I often select the curve >> r-click >> then put on world plane for each guide and curves, . but it sometimes change shape (if curve not along with same plane,  put on plane auto project curve on the world plane)

And I do not know how to generate mesh with Surface patch  ^^;;   I made close spline with curve editor. and set the curve ,and set UV counts, I can confrim tool show virtual mesh to check for temp view.   but when I "Apply mesh" it not generate any poligons..    is there any condition to work this tool? 

I got this message "Face deleted due to non manifolded mesh", but I do not think my curve have problem... actually 3d coat show the virtual grid correctly, until I apply it.  

Edited by tokikake
Link to comment
Share on other sites

  • Reputable Contributor

I think there is definitely a bug with baking of light with reflections.
if you choose "separate paint objects", one of the objects will be black on the baked map :
image.thumb.png.0b2681afb252626dd5b026e8db2474e3.png

 

Please test with this file : Test_baking_Light_and_reflections_001.3b


-open file
-go to paint room
-textures menu > light baking tool > light and reflections >> tick the box "separate paint objects"
>bake
result will likely be like in the screenshot above in which the second "T" is entirely black.


This problem also occurs sometimes without ticking "separate paint objects", but I was not able to create a test file that reproduces that yet.

Thank you.

  • Like 1
Link to comment
Share on other sites

  • Member

Start with Tiled box 3x3 in Surface Sculpting.
In the paint room, paint the circles in red, blue, and yellow, and return to the Sculpt room.
I went back to the Sculpt room, went to the File menu, Export, selected Depth Along Y, checked Save Color, and saved the image.
That's how you loaded the image into the Smart Material.
The file name is _Color.tif, so I think it's a color texture.
The image looks the same in the Windows preview as it did in 3DCoat.

Translated with www.DeepL.com/Translator (free version)

Link to comment
Share on other sites

I was testing it and you are right, the color painted is different from the original image color

Thanks for point it up.

As workaround export color as another file format as bmp or png

//edit

fixed on latest version .36

Edited by Carlosan
Fixed
Link to comment
Share on other sites

  • Member
6 hours ago, Carlosan said:

I was testing it and you are right, the color painted is different from the original image color

Thanks for point it up.

As workaround export color as another file format as bmp or png

Hope the software can automatically convert the correct result. In addition, when the AMD multi-core processor is working, the multi-core data processing method is not as fast as the single-core data processing speed, and it is hoped that it can be optimized.

Link to comment
Share on other sites

  • Reputable Contributor

baking light and reflections does not take emissive into consideration.

Is it because  :
-It just was not implemented that way ?
-when you switch to paint room, render room settings are lost (screenspace reflections get ticked off for instance) ? (or are the render room settings lost not when you leave the room but when you return to it ?)

 

asking again since there was no answer

Are there plans to implement point lights and spot lights in render room, or is that already possible with the mysterious nodes that apparently noone knows how to use ?
 

Link to comment
Share on other sites

  • Reputable Contributor

I think I read in the notes that light baking was implemented for sculpt objects ?

Here is a test with painted sculpt objects in the render room :

20210824021319086.thumb.jpg.89b0f3922362295b1568c24ba4ccc060.jpg

 

And here is what happens when you go to paint room and bake light with reflections :

20210824021346138.thumb.jpg.c4de2d19607e79ace3189d6414c2d588.jpg

Here is the file to do the test. you have to match the render room settings yourself, since they do not get saved :

Start_001.3b

Link to comment
Share on other sites

  • Member

.35
The preview of the stencil seems to be different from the actual area of the stencil, the display of the from camera is also wrong, and the image is only displayed in the upper left corner when in tile mode.
Also, when using smart materials and stencils together, roughness, metalness, and depth are ignored by the stencil. Only the colors are properly clipped by the stencil.

Link to comment
Share on other sites

  • Member

Shortcut binding doesn't work correctly for the mesh display settings in the drop-down menu in the Modeling room.

Example in the video:
1. I associate an Alt-W shortcut with the 'Retopo Wireframe' option from the menu
2. I press the shortcut once in the main 3D window, nothing happens.
3. Once Alt-W is pressed near enough the drop-down menu, the whole drop-down menu opens.

So Alt-W doesn't operate as a wireframe on/off toggle, but instead works as a callout for the drop-down menu to unroll.

 

Edited by kt2
Finishing
Link to comment
Share on other sites

  • Reputable Contributor
2 hours ago, Gorbatovsky said:

Send, please file

Windows version: 2021.35

File sent. Simple file. I exported the default creature. Closed 3DC. Opened 3DC and then imported the model for Perform Retopology. 

First Problem. The Perform Retopology tool tip states that the model will be imported into the Retopo Room but the model is imported to the paint room. You have to switch to the Retopo  Room.  Test importing an external model to see this problem.  The file I sent the model is already in the retopo room because I saved the file with the creature in the Retopo Room.

Second Problem. Once in the Retopo Room, the Stroke tool starting in a open spot in the viewport (red stroke) and drawing the stroke across the model does not work.

Starting a draw stroke on the model works. The green stroke is there. 

 

Link to comment
Share on other sites

32 minutes ago, digman said:

Windows version: 2021.35

File sent. Simple file. I exported the default creature. Closed 3DC. Opened 3DC and then imported the model for Perform Retopology. 

First Problem. The Perform Retopology tool tip states that the model will be imported into the Retopo Room but the model is imported to the paint room. You have to switch to the Retopo  Room.  Test importing an external model to see this problem.  The file I sent the model is already in the retopo room because I saved the file with the creature in the Retopo Room.

Second Problem. Once in the Retopo Room, the Stroke tool starting in a open spot in the viewport (red stroke) and drawing the stroke across the model does not work.

Starting a draw stroke on the model works. The green stroke is there. 

 

So, you imported mesh as retopo mesh, not as the reference?

Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 2022 development thread

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...