Jump to content
3DCoat Forums

3DCoat 2022 development thread


Recommended Posts

  • Contributor
8 hours ago, Silas Merlin said:

Yes, I am sorry, what I meant is that there is no preset selection, no saving of preset....
Which means you have to construct the textures every time you export in gltf, which is very painful.

image.thumb.png.37fbfe1bd96de85fe9a577c6c4e847e7.png

Hi Silas!

Yes, that does make sence. All other formats have presets as well, so should gltf.

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member

I feel it had been reported in 2021 topic, but anyway, sculpt room primitives >> Ist Sphere , diameter option ON,

still not work.. (I suppose it is default?)  

eventhough I enter diameter value >> OK , sphere diameter not change.. on the other hand radius (diameter option OFF) work without problem.

And I see "Use Models and Spliens tabs to choose custom primitive",, on Tool Option panel,, but what actually means? 

(is it kind of tips?):wacko:

 

Link to comment
Share on other sites

  • Contributor
On 6/17/2022 at 6:33 AM, tokikake said:

I feel it had been reported in 2021 topic, but anyway, sculpt room primitives >> Ist Sphere , diameter option ON,

still not work.. (I suppose it is default?)  

eventhough I enter diameter value >> OK , sphere diameter not change.. on the other hand radius (diameter option OFF) work without problem.

And I see "Use Models and Spliens tabs to choose custom primitive",, on Tool Option panel,, but what actually means? 

(is it kind of tips?):wacko:

 

Hi!

Let me measure... Yes, the Diameter is broken. Some small things are not yet fixed. I still stumble over Double Icons for Clay and Lute in Sculpt Room (Icon Mode).

'Use Models and Splines' is only a hint.

If you open the panels 'Poly Models', 'Sculpt Models' and 'Splines' with the '3D Primitives Tool' activated, you can use any of them as a 3D Primitive. This is really a great core-function of 3Dcoat for modular construction and kitbashing. It is an Asset Browser, also working in Modelling Room and Retopo.

 

 

 

Edited by Ctc_nick
more positive vibes
  • Like 1
Link to comment
Share on other sites

  • Advanced Member
26 minutes ago, Ctc_nick said:

'Use Models and Splines' is only a hint.

If you open the panels 'Poly Models', 'Sculpt Models' and 'Splines' with the '3D Primitives Tool' activated, you can use any of them as a 3D Primitive. This is really great for Kitbashing, Construction ideas, reusing Modular stuff. Its also sort of an Asset Browser.

Ah I see, I have thought Sculpt models and Splines tool should be used with Primitive tools, but I do not clear remenber, how it worked.

maybe import tool had used those models, I suppose... 

if it work with primitive tool options, it seems more reasonable for me. (thanks dev)

I recently return to up-date 3d coat, then now check all new tools again^^;    And actually after I found the diameter problem, I google then serch your topic in 2021.

Your other report seems confirmed, so maybe the "Diameter" is only one, 3d coat team miss to check it ^^;

So I confirm it again, "Sculpt room > Primitive tool>  sphere (1st) > diameter option not work , please confirm and solve issue for next beta ";)

 

  • Like 1
Link to comment
Share on other sites

  • Reputable Contributor

When clicking on "Create space with identical density and transformation", both the original layer and the new layer are selected.
This is annoying/confusing. I think it would be better to have only the new layer selected.

----

"Merge subtree" does not seem to work consistently with a hotkey.

It works fine when doing right click > merge sub tree, but not every time when using a defined hotkey.

 

----

I think it would be interesting to also have these tools for sculpt volumes :

-Merge up

-Merge down

 

-----

Edited by Silas Merlin
  • Like 1
Link to comment
Share on other sites

Addendum:

Constructive Solid Geometry (CSG) is a modeling technique that uses Boolean operations like union and intersection to combine 3D solids.

image.png

This library implements CSG operations on meshes elegantly and concisely using BSP trees, and is meant to serve as an easily understandable implementation of the algorithm.

All edge cases involving overlapping coplanar polygons in both solids are correctly handled.

Source...

Link to comment
Share on other sites

  • Member

In the process of using the Scult layer in surface mode, if you turn off the layer or adjust the layer height data, sometimes there will be surface wrinkles or layer residues (the eraser cannot completely erase it), making the experience worse, delete it The layer cannot be restored. You can only go back to the original project and re-operate, and the workload is relatively large. I hope it can be solved.

image.thumb.png.819495e947d8e899322d8165f01de377.png

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member
2 hours ago, Carlosan said:

@Elemeno Thanks !

could you please detail step by step how you did it, to be able to repeat the process and find the bug ?

create any shape... zoom close to the object for extra detail and use screen space subdivision while in surface mode and it ruins the whole mesh

  • Thanks 1
Link to comment
Share on other sites

  • Reputable Contributor
2 hours ago, Elemeno said:

create any shape... zoom close to the object for extra detail and use screen space subdivision while in surface mode and it ruins the whole mesh

Can you try something and see if it helps, because I cannot reproduce the issue when I test this feature? Rename your current "MyDocs/3DCoat" directory > restart the application and select SURFACE SCULPTING > choose the Human Bust preset model. Zoom in a bit and click the Screen Space SubDivision option in the GEOMETRY Menu. Sometimes an XML file can get corrupted (perhaps from a crash or something) and make the app exhibit bug like behavior in some area.

Link to comment
Share on other sites

  • Contributor
9 hours ago, Elemeno said:

create any shape... zoom close to the object for extra detail and use screen space subdivision while in surface mode and it ruins the whole mesh

Hi.

I also get the Spaghetti. I reduced the Mesh with 'Enter' to 5000 and then Screen Space Subdivision. although sometimes it works. 

Now 'Clean Surface' and 'Remove Self Intersections' cause similar results, as well at that object. Hmm.

image.thumb.png.df27f37b32bc5497deab214f30a0b512.png

Edited by Ctc_nick
Link to comment
Share on other sites

  • Contributor

My first 'Hello Core' test.

I did not manage to make a smiley yet with utf-8 so I put it here! :rofl:

Core.png

Tip: Do not Compile in VisualStudio just Build, Ctrl+Shift+B. 3DCoat itself is compiling. 

Edited by Ctc_nick
  • Haha 1
Link to comment
Share on other sites

  • Advanced Member
19 hours ago, AbnRanger said:

Can you try something and see if it helps, because I cannot reproduce the issue when I test this feature? Rename your current "MyDocs/3DCoat" directory > restart the application and select SURFACE SCULPTING > choose the Human Bust preset model. Zoom in a bit and click the Screen Space SubDivision option in the GEOMETRY Menu. Sometimes an XML file can get corrupted (perhaps from a crash or something) and make the app exhibit bug like behavior in some area.

736011213_sameresult.thumb.jpg.a3a769354aaebd7968f9a512a45dfca0.jpg

 

thats what i get

  • Confused 1
Link to comment
Share on other sites

  • Reputable Contributor
14 hours ago, Elemeno said:

736011213_sameresult.thumb.jpg.a3a769354aaebd7968f9a512a45dfca0.jpg

 

thats what i get

Is the mesh messed up, or is this a display bug? You can check by toggling wireframe on (W key) and inspecting the mesh. Is it full of holes like this viewport display makes it appear? If the mesh is actually good, then it would seem to point to an issue with the graphic card driver...rather than with 3DCoat, alone. I say this because in my tests, I cannot get it to reproduce this error. When was the last time you updated your graphic card driver?

Untitled-1.png

Link to comment
Share on other sites

On 6/21/2022 at 5:51 AM, Tubor said:

In the process of using the Scult layer in surface mode, if you turn off the layer or adjust the layer height data, sometimes there will be surface wrinkles or layer residues (the eraser cannot completely erase it), making the experience worse, delete it The layer cannot be restored. You can only go back to the original project and re-operate, and the workload is relatively large. I hope it can be solved.

image.thumb.png.819495e947d8e899322d8165f01de377.png

If you have steps to reproduce, it will help greatly!

Link to comment
Share on other sites

  • Member

Not sure if this is a bug but when I import a model into the sculpt room and scale it the pop up to ask if I want to remember the scale doesnt show up. I reset 3doat to defaults and it appears again, then after I try to work on a new model its doesnt appear anymore? Is there somewhere I can access this popup window manually?

Edited by captainbuckfish
Link to comment
Share on other sites

  • Advanced Member
6 hours ago, AbnRanger said:

Is the mesh messed up, or is this a display bug? You can check by toggling wireframe on (W key) and inspecting the mesh. Is it full of holes like this viewport display makes it appear? If the mesh is actually good, then it would seem to point to an issue with the graphic card driver...rather than with 3DCoat, alone. I say this because in my tests, I cannot get it to reproduce this error. When was the last time you updated your graphic card driver?

Untitled-1.png

using latest drivers... still happens

Link to comment
Share on other sites

  • Member

Hello, today got a bug with strips import in the latest versions of 3d-Coat. So looks like imported picture get some "shadow" in programm and resoult of stroke with strip get an artifacts. Just take a look at the picture and you will understand what is the point. Anyway it's minor bug as I see, hope it will be easy to fix it.
 

3dCBug.jpg

Link to comment
Share on other sites

On 6/8/2022 at 10:57 AM, Silas Merlin said:

I have finally decided to switch over to 2022 (I was still using 4.9 up till now and only using 2022 to check out the new features).

The reason I am switching over now is Volumetric Painting.

The reason I have not switched before is that there is loss of functionailty between 4.9 and 2022 and the things lost were essential to me.
I wish those things could be restored of course.... but I'll try to adapt. I have talked about those issues here before, repeatedly, to no avail.
Mainly these two things :
-Grow was a powerful, magical tool in 4.9 now it is mostly useless.
-you can't use CTRL+Extrude to carve into a volume because the sides of the alpha become a solid block image.png.03e0123467349038216a7c9860a5c64d.png

Moreover, there are new annoyances. the most important being the dropdown menu to switch rooms as opposed to visible buttons in 4.9

Anyway, I am now willing to try and switch to 2022 because of volumetric painting.
I am also glad to regain access to awesome features like translation symmetry. (projector kept working for me in 4.9 despite being disabled).

-------------

I notice that decimate works differently now. I think it is much better but need to test it some more.
However, there is something very annoying about it :
If you decimate a second time, the target is... the current polycount, so, you have to enter a new target each time, and click on OK instead of pressing enter key on keyboard, because enter key does something else.

Another point about decimate : This is a tool that would be very useful to have in retopo room, but sadly it has always been missing there.
It would be nice if you had decimate in the "selected" section of the retopo room. So that you could decimate only a selection of the retopo mesh, like you can presently do with the relax tool.


One problem I had with 2022 before was suddenly fixed when I re-associated .3b files to 2022 :
when I opened 4.9 files with 2022, all the shaders would look black.

Now that I have reassociated the .3b extension, here is the behaviour :
If I double click on an old .3b file to open it, the shaders display correctly

image.png.a54314137c7f4efe7501777596d60e67.png

However, if I use File>open, I get this :
image.png.066606a061a6292d0148ef928c180d99.png


 

1. I tried grow and IMO it works similar in 4.9 and 2022. What is the main difference for you?

2. Not understood regarding extrude.

3. I plan to make option to show rooms as tabs or dropdown.

4. When I open 4.9 scene shaders opened correctly if it has same name in 4.9 and 2022. Please send me the scene where it does not work.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...