Jump to content
3DCoat Forums

3DCoat 2022 development thread


Recommended Posts

  • Advanced Member

@Andrew Shpagin
I got it, but I don't understand why this "UVMerge ignoring Material IDs" happens in case I hide (not delete, just hide) the Layer 0 in paint room.
In other words, I could be on any other model having separate UVs per material ID, 3DCoat will still leads to the issue and that's precisely what I would like to see solved in this case. I know it can be fixed through multiple ways, like splitting back in UVRoom or reverting the file and use an older build that doesn't merge UVs on its own, but, well. It would be cool if UVs could simply stay attached to their matID. As long as I didn't merge those IDs, keeping UVs separated should be the default behavior, else it makes user feels like his file is not stable and could messup itself at any time he plays with opacity (that's why I touched the Layer 0, I know it's a specific layer so maybe there is unexpected behaviors that remains after a lot of the code has been reworked since the 4.8.44)

Edited by Vexod14
Link to comment
Share on other sites

  • Member

- Serious lag with the move tool starts around 5mil polys, voxelize OFF

- impossible to work with any brush around 30 mil

- was experimeting in the modeling room with poly modeling, pc fans do not stop working with 10 (ten) polys

i9, 64gb ram, 1080ti

Edited by Koray
move vox off
Link to comment
Share on other sites

  • Member

Hi! I imported a retopo mesh and was about to clean the mesh, everything went fine.  Now it suddenly faces are missing. Every second Triangle is gone on some Parts.

Edit: I found out, the mesh has non-manifold data. And If I delete some selected face on one polygroup, all faces on the whole model have automaticly been removed.  I didnt notice that and I didnt want that either. -I wanted to repair it.

All of the Mesh functions should only work on the selected polygroup. Remove Holes, quadrify etc. 

image.thumb.png.42fae814f0e47deaece5bdeaed269a32.png

 

Edited by Ctc_nick
new information
Link to comment
Share on other sites

  • Member

Hello,

First, well done Andrew and Team on the intense bug fixing recently. This was the main reason that encouraged me to upgrade again a couple of months ago. Things being fixed that I previously needed but haven't been able to use for a long time have got me working with 3D Coat more again. Thank you.

 

So, here is a possible bug, or at least strange behavior that I have found in more recent versions of 3DC:

I love 3D Coats Custom-Hotkey/Navigation Scheme because it allows me to set up my LightWave/Modo (and Blender with emulate-3-Button-Mouse) navigation keys. Because unlike the "non-user-choice" ZBrush :), I can keep using the thousands of hours of muscle memory I have built up.

But, with the latest versions of 3D coat it isn't working quite correctly for the Ctrl+Alt+LMB which I have set to "Scale or Move Forward-Back" in the Customize Navigation window. It seems to work differently depending on which Stroke Mode is currently active. For certain stroke modes it doesn't zoom/scale, it just rotates.

It does work correctly for me in 3D Coat 4.9, but doesn't in 2021.99 or 2022.06 (i think it did in some earlier 2021 versions, but I don't have them installed any more).

The picture shows which modes I am having problems with. Could it be some kind of key conflict or the way the Control key works in these modes?

Thanks

BlenderCustomNavigationBug.png

Link to comment
Share on other sites

  • Member

 

Some time ago I referenced a Shader bug in version 2021.90 MAC when using Smooth in voxel mode.

Now with version 2022.02 and 2022.05 that error has changed.

It only appears when we use a layer in Voxels.

Specifically if I have a tool selected in "ClayEngine" and "Voxel Tools".

If I use Smooth (Pressing Shift) or the tool, errors appear in the mesh (As if they were voxels).

On the other hand, if I have a tool selected in "Clay/Draw" Smooth, it works by pressing shift or selecting the tool.

If I convert the Voxels layer to Surface, everything works perfectly.

 

In the video I try to show what I indicate.

 

At the end of the video I use version 2021.90 in voxel mode and when using smooth the Shader error appears and the system freezes.

Tested with Shader debug mode ON and OFF.

 

I don't know if it's an error due to my system or the versions. My last version where everything worked was 2021.83

 

Thx.

Tomas Aceytuno.

 

 

Link to comment
Share on other sites

  • Advanced Member

When adding 3d primitives to the Modelling Room. The Boolean works on all operations except 'Split'. When selected it just creates a mesh without performing the Split Operation. (v2022.06)

Edited by insignet
  • Like 1
Link to comment
Share on other sites

  • Advanced Member
39 minutes ago, insignet said:

When adding 3d primitives to the Modelling Room. The Boolean works on all operations except 'Split'. When selected it just creates a mesh without performing the Split Operation. (v2022.06)

literally just about to report this ...

but if you used the object side panels (square,cylinder etc)

the split function does work with those but not the actual 3d primitives

Link to comment
Share on other sites

  • Advanced Member
45 minutes ago, Elemeno said:

but if you used the object side panels (square,cylinder etc)

you mean in the sculpt workspace? Yip they work great in the sculpt workspace. I can't get them to work in the modelling room :(

sculpt.thumb.png.d7dfba086cd2350b701a30778b0a60a2.png

Link to comment
Share on other sites

  • Advanced Member

Paint room Bug: the opacity hotkeys O and P doesnt affect the clone tool

while clone tool is up the only way opacity is affected is using the slider

even though o and p visually shows it working it doesnt work

Link to comment
Share on other sites

  • Advanced Member

There are still problems with FFD, it needs to be refined a bit more.

 

1759787559_bandicam2022-02-2101-19-06-963.thumb.jpg.17d5c580b012dd50bbb6dc6c99600fb8.jpg

1. FFD is not framed correctly.
- Even if you do 'Fit, Directional Fit', it does not fit in the pose area.
- The shape of the FFD is intermittently adjusted to the twisted shape.
  - I don't know the detailed cause of this, this problem occurs when using FFD while working, and pressing Reset Axis, Reset Position does not solve the problem and the Pose Tool behaves as if it were permanently damaged.
 - Restarting 3dcoat sometimes solves the problem, but sometimes it is not. (Usually in this case, if you press Fit, the FFD will be 'parallelepiped'.)

 

 

 

 

 


2.When rotating in FFD state
 1). usually when rotating
 2). When you press 'Ctrl' to rotate by 45 degrees
 3). When rotating by a certain number with the spacebar
All of these result in different results.
The shape changes rapidly in the order of 1-2-3.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • Member

2022.06 Windows.
When a tool button that has a sub-menu is scrolled just beyond the top of the list, the tool's sub-menu overlaps the stroke selection UI.
In the gif, you can see this behavior with the Flatten tool scrolled just above the list...
Hope this is an easy one!
Thanks for making this awesome software!

menuBug.gif

Link to comment
Share on other sites

  • Member

raz le bol de ce software, je vais prendre un abonnement zbrush. ça fait des années que c'est le bordel. entre instable, peu convial et un tas de fonctions qui servent à rien. des mises en pages lourdes. non, cette version est pourries . le semi pro, c'est pas du pro.

je ne recommanderais ce software à personne. blender est meilleur. sans le moindre doute.

les voxels, gadget, la preuve il a quand même fallu revenir à  un rooooooom deplus poly. des rooooooms on sait plus quoi en faire avec ce soft. c'est n'importe quoi.

désinstallé!

pas besoin de répondre, y en a marre des ces concepteurs qui utilisent même pas leurs softwares!

ça fini par couter une blinde ces softwares semi professionnel. comme disait un ami, on est pas assez riche pour acheter du bon marché. qui n'est au final pas si bon marché que ça...

 

Edited by ludo_si
Link to comment
Share on other sites

  • Member

Hi, upon re-opening my file, my paint looks broken on all UV seams, because of a "Layer 0" that appeared on top of all, and that is impossible to delete. I can just hide it but it's pretty annoying.
Also when painting by exporting all layer to Photoshop, one of my UV-Set get re-imported onto another UV-set instead of itself, (So the Jacket texture gets applied on the Belt UV-Set, essentially destroying 66% of all my texturing work in one click.) Thanksfully I work on external PSD and copy paste the layers back onto 3DCoat "Layers.psd" so I don't loose everything. But this UV-Set confusion in 3DCoat when updating the layers back in, (thinking jacket is belt for example) is a big blocker.


image.thumb.png.fda4485c9e9bf90c76f480db4b200dbf.png

Link to comment
Share on other sites

Never use Layer0 for paint or layer sculpt, it is used for internal 3DC operations.

Displacement is exported using the difference of a vertex's position and its position on Layer 0.

Vertice positions will be taken from Layer 0. This is the preferred option for low-poly export.

Link to comment
Share on other sites

  • Reputable Contributor
On 2/24/2022 at 11:08 AM, ludo_si said:

raz le bol de ce software, je vais prendre un abonnement zbrush. ça fait des années que c'est le bordel. entre instable, peu convial et un tas de fonctions qui servent à rien. des mises en pages lourdes. non, cette version est pourries . le semi pro, c'est pas du pro.

je ne recommanderais ce software à personne. blender est meilleur. sans le moindre doute.

les voxels, gadget, la preuve il a quand même fallu revenir à  un rooooooom deplus poly. des rooooooms on sait plus quoi en faire avec ce soft. c'est n'importe quoi.

désinstallé!

pas besoin de répondre, y en a marre des ces concepteurs qui utilisent même pas leurs softwares!

ça fini par couter une blinde ces softwares semi professionnel. comme disait un ami, on est pas assez riche pour acheter du bon marché. qui n'est au final pas si bon marché que ça...

 

These kind of posts serve no useful purpose, whatsoever. Just saying "this software sucks" doesn't help anyone. You can see in this thread alone, many interactions between Andrew and the development team, trying to fix bugs, but also add new features almost on a daily basis. Bugfixing is always the priority, so if you had/have a problem, in order to get a solution, all you have to do is send support an email (support@pilgway.com) and/or post your issue here. Providing a screen capture/grab is helpful in getting a solution more quickly, as it shows what the nature of the problem is, more clearly.

I get a bit frustrated at times, too, but overall, it is an outstanding piece of software and at a much lower cost than ZBrush, even though 3DCoat also competes favorably with Substance Painter and has top notch UV layout and Retopo tools. If you want to jump ship and use two different applications to do what 3DCoat can do in one app, that is certainly your prerogative. 

FRENCH: 

Ce genre de messages ne sert à rien, que ce soit. Le simple fait de dire "ce logiciel est nul" n'aide personne. Vous pouvez voir dans ce seul fil de discussion, de nombreuses interactions entre Andrew et l'équipe de développement, essayant de corriger des bugs, mais aussi d'ajouter de nouvelles fonctionnalités presque quotidiennement. La correction de bogues est toujours la priorité, donc si vous avez eu/avez un problème, pour obtenir une solution, tout ce que vous avez à faire est d'envoyer un e-mail à l'assistance (support@pilgway.com) et/ou de poster votre problème ici. Fournir une capture d'écran est utile pour obtenir une solution plus rapidement, car cela montre plus clairement la nature du problème.

Je suis parfois un peu frustré aussi, mais dans l'ensemble, c'est un logiciel exceptionnel et à un coût bien inférieur à celui de ZBrush, même si 3DCoat rivalise également favorablement avec Substance Painter et possède une disposition UV et des outils Retopo de premier ordre. Si vous souhaitez quitter le navire et utiliser deux applications différentes pour faire ce que 3DCoat peut faire dans une seule application, c'est certainement votre prérogative.

  • Thanks 1
Link to comment
Share on other sites

  • Member

Yes, Layer 0 should not exist for the users, I know from having read it many times on the forum that it should not be used, I never use it, but it will still gets "used" accidentally as long as it's visible to the user and named Layer 0, (because even invisible the user could create a layer named 0 and break the system ect..)
Here I just noticed the issue probably came from Photoshop, that refuses to keep a layer named "Layer 0" when dragging back the layers from the backup PSD, to the "Layers.psd" that Coat uses for exporting layers to Photoshop, so when clicking back on Coat, it updates the layer, and probably doesn't find the Layer 0 that photoshop renamed into Layer 1.

Layer 0 is one of the biggest issue in Coat, it causes so many issues, it would be like having a line of code apparent to the user that he can easily add or remove a letter by accident and permanently break the software of the file. In terms of UX it needs to be made invisible if we are to "Never touch it".

This Layer 0 might be the cause of the UV-Set confusion (slapping on UV-Set onto another, losing both if you haven't backed up your PSD externally.)

Link to comment
Share on other sites

  • Member

I could confirm, both my issues 'grey seams' and 'UV-Set confusion' were caused by photoshop renaming 'Layer 0' into 1.
>This made Coat slap a whole UV-Set onto another when updating from SP to Coat, and on file re-open, it re-created the Layer 0 on top of all, with grey squares onver all the UV seams on all UV-Sets.


In my experience the only solution would be to remove the Layer 0 from the user experience, I know perfectly it's not to be used, Carlosan reminded it to me several times, but I will still forget it, precisely because I'm not using it, so I forget about it, and then when it gets affected accidentally, by photoshop for example, I can't see it come.
Thanks for your answer btw Carlosan, I sincerely clearly remembered this about Layer 0, and did not think about it as it's photoshop itself that renamed it. (when dragging layers from backup PSD to Coat PSD.)

Link to comment
Share on other sites

  • Reputable Contributor
On 2/24/2022 at 11:08 AM, ludo_si said:

raz le bol de ce software, je vais prendre un abonnement zbrush. ça fait des années que c'est le bordel. entre instable, peu convial et un tas de fonctions qui servent à rien. des mises en pages lourdes. non, cette version est pourries . le semi pro, c'est pas du pro.

je ne recommanderais ce software à personne. blender est meilleur. sans le moindre doute.

les voxels, gadget, la preuve il a quand même fallu revenir à  un rooooooom deplus poly. des rooooooms on sait plus quoi en faire avec ce soft. c'est n'importe quoi.

désinstallé!

pas besoin de répondre, y en a marre des ces concepteurs qui utilisent même pas leurs softwares!

ça fini par couter une blinde ces softwares semi professionnel. comme disait un ami, on est pas assez riche pour acheter du bon marché. qui n'est au final pas si bon marché que ça...

 

Quote in English:

"Fed up with this software, I'm going to take a zbrush subscription. It's been a mess for years. between unstable, unfriendly and a lot of functions that are useless. heavy layouts. no, this version sucks. the semi pro is not pro. I would not recommend this software to anyone. blender is better. without the slightest doubt. the voxels, gadget, the proof we still had to go back to a rooooooom more poly. rooooooms we know what to do with this app. it makes no sense. uninstalled! no need to answer, we're tired of these designers who don't even use their software! it ended up costing a blind these semi-professional softwares. as a friend said, we are not rich enough to buy cheap. which is ultimately not that cheap..."

 

I wanted to respond additionally and directly to some of these charges, which I very much disagree with. 

1) Heavy Layouts: The default Layouts are no longer "HEAVY." I personally submitted very minimalistic layouts because of some of the criticism like yours. Those simplified layouts are now the default options, largely because the Activity Bar (upper right corner of the UI) makes the panels somewhat unneeded if not a bit redundant. Nevertheless, the UI is extremely customizable, so even if the default layouts didn't/don't suit you, you have the option to make them as simple and as light as you like and save those layouts. You also happen to have the ability to switch to a blank/minimal layout at any time by hitting the TAB key.

2) Voxels are a Gadget: They most certainly are not, especially since Andrew developed the new Voxel Clay Brush engine, and added GPU acceleration (via OpenGL) for some of the tools that were previously very slow and impossible to improve the speed using CPU multi-threading. Voxel Mode Sculpting also let's the user quickly select/switch to any of the Surface Brushes at any time, so the experience is very seamless. It's a true hybrid mode, actually. You no longer need to switch the layer back and forth, between Voxels and Surface Mode. The Voxel Clay Brushes are awesome and on par with the new Surface Brushes, in terms of performance and feel.

3) Rooms/Workspaces are....: Workspaces are what, exactly? Please be specific. The Workspaces are just that...different workspaces for different stages of a pipeline. ZBrush doesn't really need them nor does Substance Painter....because they generally do only one thing. ZBrush specializes in sculpting and nothing else. Substance Painter specializes in Texture Painting and nothing else. 3DCoat, on the other hand, specializes in 4 primary tasks...TEXTURE PAINTING, SCULPTING, RETOPO and UV LAYOUT. This is why you have ROOMS in the first place, to give focus to the specific task or stage of a pipeline. 

  • Thanks 3
Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat 2022 development thread

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...