Jump to content
3DCoat Forums

3DCoat 2022 development thread


Recommended Posts

  • Contributor
46 minutes ago, Andrew Shpagin said:

image.png

I will test on Angel. I used it on preliminary tests (successfully), but not on final build. I will check again.

Tool appears after doing Windows>Reset this page to default.
My guess is that anyone who uses stored workspace like I do, don't see new tools ?

Link to comment
Share on other sites

  • Contributor
43 minutes ago, Andrew Shpagin said:

And this is my result with Angel (took 7-8 min)

 

image.png

 

Is the work on automap finished ?
I think there are still problems. I think you are trying to create bigger islands ? I think yes very small islands are to be avoided most of the time, but those long thin islands are a problem, and also the star-shaped islands.
I was made to understand that it is best to aim for convex islands, because when you decimate to create LODs, concave shapes will end up self intersecting.

here is an example problematic island on the angel image.thumb.png.3b1f683e351c5b77cccef002fa305494.png

what I mean by "star shaped"
image.thumb.png.706454561ada936db5a438cd33bac354.png

Also I think it would be good to try to find straighter paths for seams

image.png.96cb63867b9839f37a79787e9e3c1dcd.png

 

There are still isolated triangles
image.png.0dbb37596b971f26206c830bb8e204c1.png

 

 

Link to comment
Share on other sites

  • Advanced Member
Posted (edited)

Hello!

The Modelling Room

I had successful test with the 3d curve snapping in conjunction with the Swan Surface Tool! :good:

But now the curve snapping is loosing its track like before. I cant get it back to work by restart 3dcoat or a new file. Could you check that?

Snap to curve and Curve point is turned on.

 

-There should generally be an option to turn of the automatic non manifold deletion of faces. It causes uneccesary holes when stiching faces together and no possibility to merge edges by hand.

-If you make a new polygroup, and add polygons snapping to border edges of another polygroup, 3dcoat tries to merge them. There is no way of having separate objects touching at one vertex/edge/face. This is bad because you cant snap to existing edges if you want to build other parts with matching edges.

It would be a great basic helper if there would be snap-able Null Object/Emptys for reference, and alignment for (PolyVertices and CurveVertices, Objects).

It would be fantastic if polygons could snap to curves with Add/Split, Quads, Points to Poly tool.

 

All the best!

Edited by Ctc_nick
Link to comment
Share on other sites

  • Advanced Member
1 hour ago, Elemeno said:

using the anchored brush to drag out a few details seems to be off,

it works but disappears after you get to a certain width

it also affects the opposite side, actually causing more affect than the affected area

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member

All brushes just sculpting in general drags the backface forward .. and im not sure if its just mine or everyones .. but i imported from blender into a surface mode sculpt....  But everytime i went to sculpt detail it was destroying the mesh , dragging the backfaces forward

Link to comment
Share on other sites

  • Member

Apply again, I replied before, when the process is working at the percentage, switch to other software task interface under Windows, the 3Dcoat process will be stuck, and the progress percentage cannot be displayed normally (the software is indeed working, but not responding) Calculated percentage does not display properly. Hope to get normal feedback, at least normal. Show progress percentage. Better for user experience

  • Thanks 1
Link to comment
Share on other sites

  • Member
3 hours ago, Elemeno said:

works for me too, the ui looks like i wouldnt but when you click it sets to the middle perfectly

You are right. It indeed works. I guess what confused me was that with uneven loop edge ring sides, it offsets the center accordingly:
 

 

But great! Thank you and thanks again @Gorbatovsky!

Link to comment
Share on other sites

  • Member
7 hours ago, Gorbatovsky said:

Weird, it works for me.
Let's call Andrew for help

Ok, I figured it out. It does not work in all cases. It only works when auto snapping is turned off:

 

Of course you most of the time wanna have this turned on during retopo. @Gorbatovsky Could this be an oversight? Or am I misunderstanding something?

Link to comment
Share on other sites

  • Advanced Member
2 hours ago, Hardev said:

You are right. It indeed works. I guess what confused me was that with uneven loop edge ring sides, it offsets the center accordingly:
 

But great! Thank you and thanks again @Gorbatovsky!

where this circle is misshapen it takes into account the average an then where to place the center

Link to comment
Share on other sites

  • Advanced Member
Posted (edited)

hello,

probably this is a bug or old setting .  the version is 2022v39

I find a message when I use Bas-Relief.  "The modeling operations require a special license.You may buy it on the 3D-Coat's official site"

but I am using 3D-coat 2022 full version license.  and I can not find "special license" on official web site.

I guess this is old generation setting.  

or, if there is "special license" on official web site,  I want to know where that is.

 

Mr.Andrew, all Pilgway team. Thank you for your development.

speciallicense.thumb.png.cfe6be040202cdfccc2c2c67eefbbd5a.png

Edited by jene
  • Like 1
Link to comment
Share on other sites

  • Advanced Member

Hi!

Duplicated Curves get the same Names.

Please turn off auto extension/connection for new curves (then becoming one curve). Very often wrong curves and even wrong sides of a curve are connected. This is very possible if more then 2 curves end at the same coordinates.

Greetings!

 

 

Link to comment
Share on other sites

  • New Member

I downloaded trial version. i can't edit anything. I start to edit my 3d scan to cleanup, it freezes a lot. my computer is the average one, 8g ram+150g memory.

but wheen i use zbrush or blender i don't have aany problems. what should i do?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...