Jump to content
3DCoat Forums

3DCoat 2022 development thread


Recommended Posts

  • Advanced Member

Thanks for the new Linux build!

I truly appreciate that recently the Linux builds are out in a few days, rather than weeks or months. Thank you @SERGYI and the team for all the efforts, and particularly to make the building and releasing of the Linux version of 3DCoat on par, in practice, to the rest. Kudos! :good2:

  • Like 2
Link to comment
Share on other sites

  • Advanced Member

Hello!

Could you try to combine 'testcurve1' with 'testcurve2' at the selected points to one single curve. (Scroll all the way down in the Curve Tree)

I'm strugelling often with this operation. 

 testfile.3b

All the best!

Edited by Ctc_nick
Link to comment
Share on other sites

i was doing some test but cant replicate. Vox layer use freeze tool to assign zones.

Could you please tell your step to replicate it and explain when use this combination of tools when sculpting ?

Thanks

Link to comment
Share on other sites

  • Advanced Member
9 minutes ago, Carlosan said:

i was doing some test but cant replicate. Vox layer use freeze tool to assign zones.

Could you please tell your step to replicate it and explain when use this combination of tools when sculpting ?

Thanks

ill do one better... i shall record it quickly

Link to comment
Share on other sites

  • Reputable Contributor
29 minutes ago, Elemeno said:

noeditfalloff.thumb.jpg.848a9feace4e89d390d0506b96720ac3.jpg

 

i know its not important but pose paint mode doesnt have an edit falloff bar...
// work around you can go into any of the other modes edit the power and then go back

I believe that is because the EDIT FALLOFF is just for those modes and not for Paint. I am not 100% certain and it's been a long time since I used that feature, but the falloff for the PAINT mode would be dictated by the FALLOFF parameter in the Toolbar...which is for Brush Alpha falloff values. Maybe Andrew can speak to this, but that would be my guess.

Link to comment
Share on other sites

  • Reputable Contributor
46 minutes ago, Elemeno said:

autopo isn't working?? it either doesn't show anything at all or it will show a very broken re-topology that doesn't even resemble the meshes shape

Can you screen record what is occurring in your Viewport/UI when you try to do this? A lot depends on the shape/complexity of the object, and the estimated polycount.  

 

Link to comment
Share on other sites

  • Reputable Contributor
57 minutes ago, Elemeno said:

autopo isn't working?? it either doesn't show anything at all or it will show a very broken re-topology that doesn't even resemble the meshes shape

RMB clicking on a Voxel layer > FILL VOIDS is always a good idea, in case there are any voids inside the volume which can mess with the Auto-Retopo algorithm.

  • Thanks 1
Link to comment
Share on other sites

  • Reputable Contributor
52 minutes ago, Elemeno said:

 

the other poly group i click on was using instant mesh

There could be a bug, but I think I would try a few "house cleaning" tips before proceeding.

1) Delete the empty Piston head Retopo group layer...Autopo always creates it's own new layer using the name of the voxel object

2) RMB click the Voxel layer (Piston Head) and choose FILL VOIDS and then RMB click the layer and choose TO GLOBAL SPACE

3) Switch the layer to Surface mode and then in the GEOMETRY menu (Sculpt Workspace) choose SEPARATE DISCONNECTED PARTS. This should separate those rings on the side, which I think could be messing with the Algorithm since it is so close to the actual piston head. It seems to me that making that its own separate object would give you MUCH, MUCH cleaner results.

4) Choose a lower estimated polycount at the top of the Autopo wizard. 50k seems a bit high. Maybe 20-30k?

5) During the calculation I could see a mess of green strokes. I would recommend clearing those. At the bottom of the Autopo wizard, there is an option to bypass strokes and details painting. Uncheck that and see if those strokes appear when you get to the STROKES creation stage. If you see any, go to the section of the tool panel, called SPECIAL and hit the CLEAR button. That should clear that mess of strokes, which I think is the biggest culprit, here.

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member
1 hour ago, AbnRanger said:

There could be a bug, but I think I would try a few "house cleaning" tips before proceeding.

1) Delete the empty Piston head Retopo group layer...Autopo always creates it's own new layer using the name of the voxel object

2) RMB click the Voxel layer (Piston Head) and choose FILL VOIDS and then RMB click the layer and choose TO GLOBAL SPACE

3) Switch the layer to Surface mode and then in the GEOMETRY menu (Sculpt Workspace) choose SEPARATE DISCONNECTED PARTS. This should separate those rings on the side, which I think could be messing with the Algorithm since it is so close to the actual piston head. It seems to me that making that its own separate object would give you MUCH, MUCH cleaner results.

4) Choose a lower estimated polycount at the top of the Autopo wizard. 50k seems a bit high. Maybe 20-30k?

5) During the calculation I could see a mess of green strokes. I would recommend clearing those. At the bottom of the Autopo wizard, there is an option to bypass strokes and details painting. Uncheck that and see if those strokes appear when you get to the STROKES creation stage. If you see any, go to the section of the tool panel, called SPECIAL and hit the CLEAR button. That should clear that mess of strokes, which I think is the biggest culprit, here.

found the issue... lol not a bug, purely a part of another mesh not actually connected was in the layer lol

fixed.. it works now

 

  • Thanks 1
Link to comment
Share on other sites

  • Reputable Contributor
22 hours ago, Elemeno said:

vox_airbrush tool ... very slow.. it sometimes crashes me depending on how much detail i have

Could you screen record this happening, using a default object like the Splash Screen > Voxel Sculpting > Bust? Maybe increase the resolution to where it is about 1-2 million triangles (count is visible at the bottom of the UI, in the status bar) and try to test it? If it is still a problem, letting Andrew see that it indeed is, can be a huge assist. He used OpenGL acceleration to a few other Voxel Brushes (Fill, Grow and Smooth) and perhaps this will compel him to apply it to Airbrush also.

Link to comment
Share on other sites

  • Advanced Member
18 hours ago, AbnRanger said:

Could you screen record this happening, using a default object like the Splash Screen > Voxel Sculpting > Bust? Maybe increase the resolution to where it is about 1-2 million triangles (count is visible at the bottom of the UI, in the status bar) and try to test it? If it is still a problem, letting Andrew see that it indeed is, can be a huge assist. He used OpenGL acceleration to a few other Voxel Brushes (Fill, Grow and Smooth) and perhaps this will compel him to apply it to Airbrush also.

 

its weird because i dont get fps drops

Link to comment
Share on other sites

  • Advanced Member
Posted (edited)
3 hours ago, Elemeno said:

can anyone check , the vox smart pinch isnt working properly... everything default is just smoothing out the mesh

Can you elaborate on that, please? It seems to work fine, here (3DCoat 2022.47).

Edited by Allabulle
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...