Jump to content
3DCoat Forums

3DCoat 2024 development thread


Recommended Posts

  • Contributor
Posted (edited)

 

Hi folks!

In Blender they changed their Add on Structure to extensions . 

But this is good, because: This means @Andrew Shpagin can now directly upload the newest applink to the Extensions Website.

So maybe that will end the problem with parallel Applink versions, from blender and coat.

 

ATM The included/downloaded Addon from Blender 4.2beta upwards or 3Dcoat do not work, so:

I made Applink work with the new Blender Extensions:

-----------------------------------------------------------------------------------------------------------------

coat_applink_extension_for_42beta.zip

Blenders folder for Applink is now: C:\Users\*USER*\AppData\Roaming\Blender Foundation\Blender\4.2\extensions\blender_org\coat_applink\

<only for testing purposes, but it does work!!>

------------------------------------------------------------------------------------------------------------------

-Export from Blender to Sculpt,Retopo, and Paint working. I have already reported an applink paint bug earlier.

The Object sometimes is un-paint-able, although remapping.

-"Open in Original App" (to Blender) working.

Blender does not respond to "Export To" Button!! would be nice if it does.

@ the developers, the main changes are: 
 

io_coat3D import nodes ====> from .import nodes, including all the other imports from io_coat3D

group_tree.outputs.new("NodeSocketColor", "Color") ===> group_tree.interface.new_socket(name='Color', in_out='OUTPUT', socket_type='NodeSocketColor')

also in tex.py, json adress:

json_address = os.path.join(
                os.path.expanduser('~'),
                'AppData',
                'Roaming',
                'Blender Foundation',
                'Blender',
                f"{bpy.app.version[0]}.{bpy.app.version[1]}",
                'extensions',
                'blender_org',
                'coat_applink',
                'data.json'

All the Best.

Edited by Ctc_nick
  • Like 2
Link to comment
Share on other sites

  • Advanced Member
Posted (edited)

hello.

I tested Reality Capture automation mode.

I have installed Reality Capture. but the start menu of 3D-coat doesn't change.

"Photos/ Video to 3D" doesn't appear.

 

next,  I tested Edit menu -> photos to 3D.

it can be executed from photo to 3D. it is good.  but it can not use mp4 video.

 

3D-coat is very useful to modify a photgrammetry data.

I expect this new function. Thank you.

photogra.thumb.png.69676b1d51c0cbb46606d371e0e5f60c.png

Edited by jene
Link to comment
Share on other sites

  • Advanced Member
Posted (edited)
1 minute ago, Carlosan said:

wait for v2024.21

Thank you. Дякую

Edited by jene
Link to comment
Share on other sites

  • Member
Posted (edited)

The field to add the phototshop exe path does not work, impossible to ctrl+v, impossible to type, clicking it just adds a random path, having the correct path in the clipboard does not help:
image.thumb.png.16f9a80d9127cd36d97b5b478dd5385c.png
right click doesn
't allow to paste the photoshop exe path either.
I'm latest .20

Ok actually all fields have stopped working, 20 minutes ago I could edit the fbx auto export field, now it also does not respond, just "pastes" thsi applink folder when clicked, without this path being in my clipboard..
image.png.026906ba15ccc91aff56d0f49995162b.png

Ok restarting the app fixed it. still leaving this in case something can be done.

Edited by liok
  • Thanks 1
Link to comment
Share on other sites

  • Member
Posted (edited)

The simplified export (auto UV + bake to fbx) always gives a crash, even with a sphere, when using the "To blender via applink" option.
Even if you applink works fine when using file > send to blender.

(using "regular Export" option works fine)
 

Capture d’écran 2024-06-21 012842.jpg

But yea the quality of the face normal
s after the decimation is not really usable:
image.thumb.png.ca479df5493f1e42f16dc458b93d1539.png

Edited by liok
Link to comment
Share on other sites

  • Member
Posted (edited)

I think we still have this annoying bug that baking takes symmetry into account, which there is no reason to, as it takes the symmetry of the current Sculpt object, which we don't really care about in the retopo room as we mostly dealwith retopo objects. And it automatically destroys any bake attempts if symmetry is ON, without providing any usefulness I guess ? as it's either the sculpt objects and/or retopo objects that you want to be symmetric or not, not the bake & paint object independantly.

image.thumb.png.24ce5abdb84fe672700680d0f1092236.png
It seems like 100% of users will bake while having a sculpt object active that has symmetry, and that means that 100% of users will have 100% of bakes failing, destroyed, until they realize they need to create a new dummy
sculpt object without symmetry, select it, and then bake. (without breaking the bake with this random symmetry)

Edited by liok
  • Thanks 1
Link to comment
Share on other sites

  • Member

I mean, I just did that, created a sculpt object without symmetry, then did something, re-baked.. AND it still symmetrized the bake, because obviously I just selected another sculpt object at some point just before baking.
This bug makes it virtually impossible to bake, without a massive headache of having to realize you failed (sometimes after the end, after the export..), then restart from scratch your painting room work by really making sure super sure sure sure that you selected the dummy sculpt object without symmetry active, before re-baking.
That's an urgent bug to address since many years, no one can properly bake at the moment since all these years.

 

Capture d’écran 2024-06-22 051032.jpg

Capture d’écran 2024-06-22 052504.jpg

  • Thanks 1
Link to comment
Share on other sites

  • Member

Hi Carlosan, yes I always keep auto snap ON, as I might use the brush tool or anything to polish the retopo, I deactivate it in very special cases.
I think Auto snap should have no relation to the baking process, if it has some currently. (it would be very counterintuitive, as when you click bake, you're not doing retopo anymore, you want your low poly to just stay as you finalized it.)

A small issue I'm seeing is that any decimated fbx export seems to have totally broken split normals, it's easy to remove, reset, in blender, but I hope retopo obejcts do'nt get this kind of issue (I don't think so, low poly normals are clean), but sculpt obejcts exports always look like this:

image.thumb.png.a1b6feb8e4fd004ee6f11db41bd49323.png

image.thumb.png.7e6e31c18a4a3333f026a5d9e46cf6fb.pngimage.thumb.png.99af8930af0a2c4f3b42ca7afe06eed6.png

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member
9 hours ago, liok said:

Hi Carlosan, yes I always keep auto snap ON, as I might use the brush tool or anything to polish the retopo, I deactivate it in very special cases.
I think Auto snap should have no relation to the baking process, if it has some currently. (it would be very counterintuitive, as when you click bake, you're not doing retopo anymore, you want your low poly to just stay as you finalized it.)

A small issue I'm seeing is that any decimated fbx export seems to have totally broken split normals, it's easy to remove, reset, in blender, but I hope retopo obejcts do'nt get this kind of issue (I don't think so, low poly normals are clean), but sculpt obejcts exports always look like this:

image.thumb.png.a1b6feb8e4fd004ee6f11db41bd49323.png

image.thumb.png.7e6e31c18a4a3333f026a5d9e46cf6fb.pngimage.thumb.png.99af8930af0a2c4f3b42ca7afe06eed6.png

can i see your shader graph? also are you baking for opengl .. ?

Link to comment
Share on other sites

  • Member

Hi Elemeno, here there was no shader, just a sculpt object selected, file > export selected > decimate, and imported as is in blender, no material.
Carlosan said it doesn't do taht on his end so I will do more tests see if I can spot something that does or doesn't gives these split normals. Anyway if it's not generalized it's not an issue, 1 click fix by reseting normals, just should not happen on retopo objects as we don't want to modify the mesh normals after baking its normal texture.
Thanks

Link to comment
Share on other sites

  • Advanced Member
19 hours ago, liok said:

Hi Elemeno, here there was no shader, just a sculpt object selected, file > export selected > decimate, and imported as is in blender, no material.
Carlosan said it doesn't do taht on his end so I will do more tests see if I can spot something that does or doesn't gives these split normals. Anyway if it's not generalized it's not an issue, 1 click fix by reseting normals, just should not happen on retopo objects as we don't want to modify the mesh normals after baking its normal texture.
Thanks

im not getting anything either

Link to comment
Share on other sites

  • New Member

Is there a 3dcoat Discord available? I just downloaded and want to give it another try and get off substance if it suits my workflow but i'd definitely like to be able to engage in real time with a community. Is that available? 

Link to comment
Share on other sites

  • New Member

Thank you for your reply, Is there any way to increase the size of the ui? on a 4k screen the UI is really difficult to see
Ive already increased the font size but thats not quite enough. there are tabs and buttons that are hard to use/press/see. Ive tried a few ways such as forcing it to use its own scaling rather than windows, but thats not working correctly either.

Link to comment
Share on other sites

Try disabling windows scaling in shortcut preference of 3DCoat (needs latest windows 10 build), and increasing font size in 3DCoat preference.

Link to comment
Share on other sites

  • Member
Posted (edited)

I keep having a bug, I'm not sure what triggers it but seems to be when pushing a mesh from blender applink to Coat as voxel, and maybe Crtl+Z a few actiosn later ?
It changes the active/opened file name to "3DC027._001", and ctrl+shift+S does a regular save, so you can't save as your actual file, and you also do'nt even know where this file have been placed, so you're a bit blocked. if you close you don't know where to find this file, and your real file has not been saved as it was not the opened file anymore.
image.png.576cb00d3332e0abf12e377be9feb435.pngimage.png.0da9cd3b1af3f810cb5547402e8d3a6d.png
Ok by closing and re-opening last file, you can actually find where this file was saved:
image.png.89210ad90990d0c7b4d8346949be92a9.png
But it's still pretty confusing when it happens, and increase chances to loose your file, as it gets shifted to this random applink file.
Not a big problem though, and definitely caused by the applink recieving data from blender.

Edited by liok
Link to comment
Share on other sites

  • Member

Here it's not really a temp file, but the active file that gets changed into this /applink .3b file, I think by doing Ctrl+Z, or maybe just when pushing a mesh from blender to Coat.

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member

is there a way to get a stable version .. ive stopped using 3coat because booleans will fail , merging will fail and wipe the mesh , retopology ,tools and even baking will fail and sometimes ruin the hardwork ive put into ,

i know alot of people are requesting new features but i loved the fact 3dcoat has 0 restrictions when it come to topology and you could use traditional modelling inside the sculpt area at high density .. 

but i really need solid stable performance because i can sometimes put days of work into something to find the save has failed and have to go back hours or the whole mesh will dissapear and ctrl+z wont correct this .

Link to comment
Share on other sites

18 hours ago, Elemeno said:

ive stopped using 3coat because booleans will fail , merging will fail and wipe the mesh , retopology ,tools and even baking will fail and sometimes ruin the hardwork ive put into

How can I repeat this so I can tell the developer to fix it?

Link to comment
Share on other sites

  • Advanced Member
2 hours ago, Oleg Shapov said:

How can I repeat this so I can tell the developer to fix it?

there are no steps .. just everyday use and youll find one of them , many have had these problems for years now .. ive had these issues since 4.9

Link to comment
Share on other sites

  • Contributor
Posted (edited)

Coat 2024.20

Hi! Moving tweak tools to paint is a good solution for now! Thank you. It is really good for some quick tweaking.

Better Function, and and one room less. Double Score! :good2:  

The Rectangle Select is a little bit broken.

All the Best

 

Edited by Ctc_nick
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...