Jump to content
3DCoat Forums
Jamie Norton

3DCoat to Blender 2.93 Applink 'Send' not working

Recommended Posts

Hey guys, does anyone have any ideas to solve my issue? installed blender 2.93.1, 3DC 4.972. Clicking 'send' in Blender yields zero result in my open 3DC ? 

Thanks in advance, this is driving me mad. Win 10 64 bit  

Share this post


Link to post
Share on other sites

Thanks @Carlosan! Appreciate how quickly you got back to me. I hope he is able to get it running soon, it is a fantastic tool :) I gather if I go back to an old blender it should work then, in the meantime 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Jamie Norton said:

Thanks @Carlosan! Appreciate how quickly you got back to me. I hope he is able to get it running soon, it is a fantastic tool :) I gather if I go back to an old blender it should work then, in the meantime 

As my test I could export 3d coat V4.972 from Blender 2.93 RC2.(windows 10) Then there have been no change about 3d coat add on I suppose.

Though I sometimes see 3d coat freeze, with show import setting with app link export, but usually when I re-open 3d coat. then export again from blender, solve the issue.

And I notice, for some reason, it seems take some seconds (10 more) untill export it. 

When there is problem, usually there remain some corrupt Exchange directory. did you change 3d coat data directory recently?

I may once open 3d coat, then check your data path by Edit>Relocate data path.

it will be show current your setting path for data.. then you just need to set the Path the data path/Exchange in blender scene 3d coat property.

(if you have installed 2021 beta, it may cause issue because 2021 now use different directory for Exchange I confirm. do not know app link auto set for 2021 = change Exchange path to 2021 without you notice it.

or sometimes I forgot to select mesh, in blender, (then nothing happen. 3d coat add on not auto detect which object you will export ^^;)

 

Share this post


Link to post
Share on other sites

Try modyfing 

C:\Program Files\Blender Foundation\Blender 2.93\2.93\scripts\addons\io_coat3D\folders.py 

lines 45/52

   if(platform == 'win32' or platform == 'darwin'):
        exchangeFolder = os.path.expanduser("~") + os.sep + 'Documents' + os.sep + 'Applinks' + os.sep + '3D-Coat' + os.sep +'Exchange'
    else:
        exchangeFolder = os.path.expanduser("~") + os.sep + '3D-CoatV4' + os.sep + 'Exchange'
        if not(os.path.isdir(exchangeFolder)):
            exchangeFolder = os.path.expanduser("~") + os.sep + '3D-CoatV3' + os.sep + 'Exchange'
    if(os.path.isdir(exchangeFolder)):
        coat3D.exchangeFolder = exchangeFolder

 

 

 

Share this post


Link to post
Share on other sites

I gave up on this Blender link. Too many issues which the developer could not assist me with. Too bad as I love Blender and love the idea of this add-on. But not worth te hair pulling and teeth gnashing.

Share this post


Link to post
Share on other sites
11 hours ago, Carlosan said:

Try modyfing 

C:\Program Files\Blender Foundation\Blender 2.93\2.93\scripts\addons\io_coat3D\folders.py 

lines 45/52

   if(platform == 'win32' or platform == 'darwin'):
        exchangeFolder = os.path.expanduser("~") + os.sep + 'Documents' + os.sep + 'Applinks' + os.sep + '3D-Coat' + os.sep +'Exchange'
    else:
        exchangeFolder = os.path.expanduser("~") + os.sep + '3D-CoatV4' + os.sep + 'Exchange'
        if not(os.path.isdir(exchangeFolder)):
            exchangeFolder = os.path.expanduser("~") + os.sep + '3D-CoatV3' + os.sep + 'Exchange'
    if(os.path.isdir(exchangeFolder)):
        coat3D.exchangeFolder = exchangeFolder

I may try it. I understand what you plan and I suppose it may work (auto set) exchange path for 2021,

But if change so, I afraid it can not set exchange folder for V 4.9 as default.

all win 32 PC may try to use the new applinks path as default path . (but for V4.9 it need to set different path, the exchange directory should be sub directory of 3d coat data.

So I suppose we can not auto set default Exchang path for 2 version 3d coat ,without user set so.

Share this post


Link to post
Share on other sites

I do simple test.

1.  run blender, then set 3d coat Exchange path as new 3d coat 2021 default Exchange path. (because it seems auto generate when I install 2021 I suppose)

2. run 2 version 3d coat (4.9 and 2021) , then export mesh.

3 it only load model for 2021 

4  in blender change 3d coat exchange path for V4.9  (3d coat data path)/ exchange then save the new exchange folda, then save the blend file to confirm. 

5. once shut down 2 version 3d coat, then run again. then export mesh.

6. This time only load mesh for V 4.9.  

About my case, I change the 3d coat data path for V4.9.  then set exchange path is  3d coat data path/ Exchange

but for 2021, I think exchange path is separated from the coat data directory = at current 3d coat 2021 always use new default  exchange path,

even though user manually change 3d coat data path (with setting file)

 

Share this post


Link to post
Share on other sites
18 hours ago, tokikake said:

As my test I could export 3d coat V4.972 from Blender 2.93 RC2.(windows 10) Then there have been no change about 3d coat add on I suppose.

Though I sometimes see 3d coat freeze, with show import setting with app link export, but usually when I re-open 3d coat. then export again from blender, solve the issue.

And I notice, for some reason, it seems take some seconds (10 more) untill export it. 

When there is problem, usually there remain some corrupt Exchange directory. did you change 3d coat data directory recently?

I may once open 3d coat, then check your data path by Edit>Relocate data path.

it will be show current your setting path for data.. then you just need to set the Path the data path/Exchange in blender scene 3d coat property.

(if you have installed 2021 beta, it may cause issue because 2021 now use different directory for Exchange I confirm. do not know app link auto set for 2021 = change Exchange path to 2021 without you notice it.

or sometimes I forgot to select mesh, in blender, (then nothing happen. 3d coat add on not auto detect which object you will export ^^;)

 

This makes me think…I have installed the 2021 trial, which has since expired… maybe it is looking for that, or it is interfering in some way 

Share this post


Link to post
Share on other sites

You are welcome  this add on made by user effort, so I really respect their work. then hope it work for all user (and can maintain always)

Share this post


Link to post
Share on other sites

@Jamie Norton 

------------------------------------------------------------------------------------------

The temporary license for anyone who wants to test, but has not bought a license:

3DCoat.license - valid till 1 August

------------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×