Jump to content
3DCoat Forums

Problem with imported displacement and smart material 'more on' BUMP' applying on surface


TomTom
 Share

Recommended Posts

  • Member

Hello Guys,

here is my problem.
I would like to use some externelly made displacement/height images for some sci-fi panels painted outside of 3D Coat.

My steps:
1. I import the displacement (it appears on the model)
2. I bake occlusion, curvature
3. I would like to check preview (most of the cases preview simple does not shows the imported 'height/bump' effect, but I could survive that as it applies after using fill tool (but it is a bug IMHO)
4. I would like to create an extra layer where dirt, worn parts are INSIDE the lower parts and/or On the top of the higher parts (so the worn is affected by the height map and geometry is NOT affected at all).

- I use 'more on bumped' and 'more on dent' projections, nothing really works.
- I copied the height info to the actual layer's height channel I'm working on (doesn't help)


Do you have any idea how solve this properly?

Thanks

TomTom

image.thumb.png.2dd6b54ea0b5eacf268e248f06ae8a6c.png
image.thumb.png.6df8004c410bf88f66c3c59166640b9b.png
image.thumb.png.63760f1e4fb04273acb2c64941d1f3ac.png
image.thumb.png.c689e617d67f5afe8ce793893727b02d.png

Link to comment
Share on other sites

  • Member

I used to use Paint UV-Mapped mesh as my meshes are UV-mapped already, I need the separate  textures options, etc. How this will solve the problem of my existing project I work on for days? What will it add to the workflow and what will be removed by this? Thanks.

Link to comment
Share on other sites

To work with displacement maps you need high poly density. That is why preview simple does not shows the imported 'height/bump' effect.

Because there is only a grey map that was apply as Color Standard Blend, the mesh dont have lower parts and/or top of the higher parts.

 It is not possible for PPP to calculate what you need for your project due to the lack of information in the object mesh.

Link to comment
Share on other sites

  • Member

In some cases (like Concave, etc.) it shows (see the screenshots), so no high poly needed at all.
It was imported as Displacement as I wrote.
Technically it seems to me a simple bug/bad implementation of a feature. It should work (as it works with other projection types), just somehow there is somewhere a glitch.

 

Link to comment
Share on other sites

  • Member
10 hours ago, Yousung said:

sadly
- More on Bumped
- More on Dent
These two condition options seem to only work on layers with displacement applied.

On separate layers, this option does not work.
 

 

 

 

849257028_bandicam2021-12-1500-52-08-968copy.thumb.jpg.acf4f2710278fe54c768f1370ca3f799.jpg

Here I painted each layer and checked Bumped/Dent.
Layer height is applied individually.

I was not able to get what happens unfortunately. I used this approach, no fun. :(
But I use earlier version of 3D Coat (but it seems the problem exists since 2011 at least).

Edited by TomTom
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...