Jump to content
3DCoat Forums

Fixing AppLink for Blender after upgrading

Recommended Posts

  • Member

Hello! I was asked to mirror the process I found for un-borking my 3DCoat applink. Hopefully someone will find this helpful! Original post found here: 

From the jump:

Hey there! I just finally got the applink to work, after a whole bunch of struggling. The main issue is that old versions of 3dcoat interfere with new ones. The secret is: 

- Delete every applink related folder out of my docs. both the app link and 3DC seems to write text files which contain path strings
-- if any of these files contain a reference to an old directory either 3DC or blender will automatically recreate that old folder.

- Deleting every applink folder includes, in my case:

- Open 3DCoat and close it. This will respawn the 3DC exchange folder. (C:\Users\<username>\Documents\3DCoat\Exchange)

- Open Blender and plug in the freshly spawned exchange folder to Blender plugin exchange path. I was able to leave the object / texture empty

- Send a Voxel object to 3DC. This will spawn C:\Users\<username>\Documents\3DC2Blender folder.

- In 3DC, autopo, automap, and use "export to -> blender". As far as I can tell this will cause 3DC to spawn the C:\Users\<username>\Documents\AppLinks\3D-Coat\Exchange\Blender folder. Choose any fbx name you want.

- Export preset should be either Blender Cycles or BlenderAppLink. I used BlenderAppLink

- Back in Blender, click the "GetBack" button. This will spawn the object exported from 3DC and hook up the PBR shader!

2022-05-27 18_18_02-Alarms & Clock.jpg

2022-05-27 18_18_34-Blender.jpg


As a side note I think the applink code on the blender side is hardcoded to spawn 3D-CoatV4 folder, as it keeps popping up after I delete it when I use "get back" out of blender. Luckily it doesn't seem to interfere with anything so long as the initial setup is clean.


  • Like 3
  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Member
This post was recognized by Carlosan!

wendallhitherd was awarded the badge 'Helpful' and 1 points.

On 5/29/2022 at 8:52 PM, I_was_a_Bullfrog said:

Ok, so I have tried following as best I can, but each time I open 3DC, I still get the warning message followed by a window that says C:\Users\(my user)\Documents\3DCoat - 2022>powershell Start -File "C:\Users\(my user)\Documents\3DCoat\data\temp\copy_applink.bat" -Verb RunAs

Is this normal?

I don't think so! You might have some permissions issues or an antivirus blocking 3DC / blender producing folders? TBH I don't know how it works under the hood

Link to comment
Share on other sites

  • 9 months later...
  • Member

Saved me! I was starting to get annoyed to the point that I did a fresh install of Blender and 3D Coat. But that didn't work. So I tried your method and now everything is back to normal. Orientation and scale of the model remains the same. Originally, the model was facing the wrong way. 

  • Like 1
Link to comment
Share on other sites

  • Carlosan changed the title to Fixing AppLink for Blender after upgrading to 3DC 2023
  • 11 months later...
10 minutes ago, Andrew Shpagin said:

3DCoat uses folders



to exchange data, check if it exists

What version of blender you installed? Was you offered to update applink in 3DCoat (this is super important)?
Was the Blender installed into default folder? (generally coat seeks for Blender everywhere) 

Link to comment
Share on other sites

  • Carlosan changed the title to Fixing AppLink for Blender after upgrading
  • 3 weeks later...
  • New Member
This post was recognized by Carlosan!

Miljan Bojovic was awarded the badge 'Helpful' and 1 points.

This worked for me!
Thank you!

For my situation, after deleting those folder, opening 3D-Coat, it respawned the folder in C:\Users\<username>\Documents\AppLinks\3D-Coat\Exchange
Then I opened Blender, went to settings, searched "3D-Coat" in the plugins and set the ExchangeFolder to the new folder 3D-Coat respawned in Documents.
Now it works again :D

Hope this is helpful. :)


  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...