Jump to content
3DCoat Forums

Was 3d Coat 4.x faster than 2022.x?


phoenixart
 Share

Go to solution Solved by phoenixart,

Recommended Posts

  • Member

I'm watching some tutorials where 3d Coat 4 was being used, and I'm noticing some drastic difference in terms of performance.

For instance, in this tutorial here, the smooth operation is instantaneous

 

When I apply the smooth even to a basic, simple object, it takes definitely longer than in those tutorials

Is there something wrong with the latest 3d Coat releases?

In general, I see this degradation compared to those videos, in other operations of 3d Coat. For instance, when using a build brush with some alpha, when increasing, or decreasing the resolution, when using Autopo.

My PC is definitely not brand new, but it works fine. Here are the specs:

Threadripper 1950x
32 GB RAM
(2) 1080ti
boot NVMe 512gb + data SSD 2TB 

 

Edited by phoenixart
Link to comment
Share on other sites

  • Member

I'm not saying is slower, I'm asking if it is.

As for the mesh, in my examples I'm using less dense meshes, which already says quite something about the performance. 
And as for the hardware, I added my specs to the first post. I also seem to remember when asked what they were using in the video, the specs were also lower, which would make sense if you take into account when those tutorials were released.

So, I'm genuinely asking if there's something off here, if it's something other users who upgraded from 3d Coat 4 have noticed.

I find it hard it to believe that any tool I've used so far while following those tutorials, performs slower than old videos from eight years ago.

Link to comment
Share on other sites

  • 4 weeks later...
  • Member
  • Solution

So, as I suspected, it's indeed a problem with AMD/Threadripper CPUs:

My threadripper worked ok, but I can't say it met the expectations. At the time when it came out, on every 3d forum, it was welcomed as the Intel killer. Another example of how fuss not necessarily equals facts.

X-Particles for C4D suffered the same fate, painfully slow compared to cheaper Intel CPUs.

I've been an Intel user for years, the 1950x was my first AMD CPU. I'll surely stick to Intel for my next build.

To be clear: I'm not saying AMD is worse than Intel. I'm saying it performs worse with the 3D software I use on Windows. That's an important distinction because, at the end of the day, it doesn't matter if something seems more promising on paper. What matters is how well that piece of hardware is optimized for the OS. 
 

Edited by phoenixart
  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Reputable Contributor
On 9/13/2022 at 5:20 AM, phoenixart said:

So, as I suspected, it's indeed a problem with AMD/Threadripper CPUs:

My threadripper worked ok, but I can't say it met the expectations. At the time when it came out, on every 3d forum, it was welcomed as the Intel killer. Another example of how fuss not necessarily equals facts.

X-Particles for C4D suffered the same fate, painfully slow compared to cheaper Intel CPUs.

I've been an Intel user for years, the 1950x was my first AMD CPU. I'll surely stick to Intel for my next build.

To be clear: I'm not saying AMD is worse than Intel. I'm saying it performs worse with the 3D software I use on Windows. That's an important distinction because, at the end of the day, it doesn't matter if something seems more promising on paper. What matters is how well that piece of hardware is optimized for the OS. 
 

I think the common denominator is that some applications use Intel's compilers or libraries...which are optimized for Intel CPU's only. Therefore, it can make AMD CPU's seem slow when these Intel tools are used. If anyone is having similar issues, please let Andrew (support@pilgway.com) know about it. I reported this issue to him a few years ago, and he said he might look at using another compiler, but switching could be a massive undertaking. Nevertheless, AMD CPU's are fantastic at most everything else and it seems unfair to be penalized because the Multi-threading in 3DCoat and other apps use an Intel compiler.

 

Link to comment
Share on other sites

  • 3 months later...
  • Advanced Member

This is an interesting read.  I've been a 3DCoat user for years. Always used Intel PC builds, but went for a Threadripper Pro 5975wx for the latest rig.  

I've found 3DCoat version 4 extremely slow compared to my old i7 hex core.  In fact, I have the old PC still set up, so I might do a comparison.

I was having terrible waiting times with importing a obj/lwo file for use in the paintroom.  UVs already setup and just needed to paint 8K textures.

I will report back when I have done a comparison, as I'm wondering if the latest version of 3DC would be worth upgrading too to resolve this issue, but it sounds like it's still an issue.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...