Jump to content
3DCoat Forums

[Fixed] 3D mouse not working - Linux


Go to solution Solved by SERGYI,

Recommended Posts

  • New Member
Posted (edited)

3D mouse viewport navigation doesn't seem to be working on Linux while buttons do. Switching to new api doesn't seem to work either, after clicking apply the dialog blinks and reverts back to former settings.

Tested with 3DConnexion 3DX-700059 Spacemouse Compact 3D Mouse.

3DxWareUNIX = V1.8.0
Device      = SpaceNavigator
Firmware    = V4.35
 

Edited by matiya
  • Thanks 1
Link to comment
Share on other sites

I don't know about Linux but 3D mouse control is all handled by the 3D conexxion software now. Something I'm personally not happy about with my Spacepilot Pro. It worked perfectly before, now I can't seem to make it work as well.

Link to comment
Share on other sites

  • New Member

I feel you. Let me share a screenshot of the current state of linux driver:
774165044_Screenshotfrom2022-08-2422-47-38.thumb.png.b532f4f35038f7bbfc80411ae6220cc9.png



It doesn't look this driver was subject of any changes since mid 90's so it might be a problem on 3dcoat side in this particular case after all.

Link to comment
Share on other sites

  • 2 weeks later...
  • Carlosan changed the title to [Fixed] 3D mouse not working - Linux

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...