Jump to content
3DCoat Forums

Paint Room bug hunt - report it here

Recommended Posts


In different social networks there are references to bug's in paint room that are unresolved.
To make the search and solution more effective, please add here all the bugs you find in paint room.

It would help a lot if you add this information:

What is the problem?
Steps to reproduce a Bug
Expected Result
Actual Result
Visual Proof (screenshots, videos, text) of Bug
Software version

Link to comment
Share on other sites

  • Carlosan changed the title to Paint Room bug hunt - report it here
  • Carlosan pinned this topic
  • Advanced Member

@CarlosanHey, I know you have responded to this before, but the baking displacement is still giving poor results. Hardened normals result when baking.


1. From Startup menu choose Bust. Merge sub-tree so it is one voxel mesh. Turn on symmetry x axis. Autopo mesh. In retopo room unwrap uvs or auto uv. Bake menu choose "Bake w/per pixel painting w/ displacement". Set scan depth settings accordingly. Import Object for perpixel dialog, set to blender, add initial subdiv, keep UV, no smoothing. set texture sizes. Result in paint room is hard edges on normal map in texture editor and on model. These results are both with per pixel w/displacement and flat displacement from bake menu in retopo room. Expected result is a smooth mesh with displacement.

Linux version 2022.55

OS: Pop!_OS 22.04 LTS x86_64 (based on Ubuntu)

AMD Ryzen 9 5900X (24) @ 3.700GH

NVIDIA GeForce RTX 3080 12GB

Driver 525.78.01

Screenshot from 2023-01-29 18-50-06.png

Screenshot from 2023-01-29 18-53-11.png

Link to comment
Share on other sites


Baking displacement for PPP is really tricky. It has sense mostly for the pipeline when use displacement for the parallax, but using the normalmap for rendering.
Link to comment
Share on other sites

  • Advanced Member

Both Images are from "Baking into Scene (microvertex) and Retopo->Microvertex (no baking). All with 1 or 2 subdivisions in dialog. Nothing with PPP. None of the baking options for microvetex are baking correctly from the retopo room.  Meshes should be smooth without these hard normals. This is happening in Windows as well. Forgive my frustration. Since when are these options used for an obscure operation like parallax. Even if it used for something like "Parallax" these results cant be good for that either. This is a workflow of 3DCoat is it not? Baking and painting displacement. It is very misleading to say you can bake displacement but now its used for a parallax workflow. I've used this workflow before without any problems. Can we at least get it working for the other baking options besides PPP? Seems to work as it should for "Industry Tuts" and the official youtube channel. Nowhere does anyone mention "Parallax". I do appreciate everyone on the team and your massive efforts, but from my point of view, it just seems like no one wants to address it. Baking should be one of the pillars of any 3d application. Thanks again for your time Carlosan. I know you are very involved with the community.


Screenshot from 2023-01-31 20-29-19.png

Screenshot from 2023-01-31 20-41-18.png

Screenshot from 2023-01-31 21-15-43.png

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

solved on version 2022.60,

  • The texture baking dialog jumps back to the middle when you toggle an option.
  • If you click ‘settings’ multiple times, it adds a dialog every time, on top of each other.
  • On undo, the OLD circle was suddenly overlayed onto the new circle.
  • Textures->Import UV does not flip the UV
  • Fixed problem of stamp mode and symmetry in paint workspace.
  • Fixed problem of curves and lines strokes w/symmetry in paint workspace.

Andrew Shpagin wrote:
Forgot to announce in 60, but multiple settings fixed there

Link to comment
Share on other sites

  • Advanced Member

I just discovered a new , first time i see it.

I was setting a smart material texture, one of my simplest setup: one texture in mask, modulate color, cylindrical projection, nothing more.

To get it applied correctly on my model, I had to scale down many times using the yellow square of the gizmo,

then suddenly, it became inefficient and started displaying only down and right arrows.
I tried to scale it up, but it's too late and doesn't react correctly.

As you can see on the screen, the top arrow has coming back while the left side is still missing.

I had to reset parameters to get it back to normal


I can easily recreate the problem by scaling down multiple times any other material:


Edited by blackant Master
more infos
Link to comment
Share on other sites

  • Member

Not a bug per se, but something that does need fixing.

Keystrokes, and pop-up hints for Glossiness, Roughness, and Metalness are mixed up and have been for a long time (since V4 at least - and still the same in 2023.01

1: Glossiness and Roughness sliders are interconnected (understandably), but the keystroke hint tells us that Roughness uses the "<" & ">" keys -

This is incorrect, "," & "." are the keystrokes used for both glossiness and Roughness . Yet in the keystrokes file they are < & > - and they do work.

2: Additionally, Metalness also shows the hints that "<" & ">" keys are used - when metalness has no keystroke assigned.

3: We are shown in the Windows/Sliders Menu that Glossiness Opacity uses keystrokes ";" & "'" but the ' key is used by the Quick Menu, and the ; key does nothing - there is no slider for the Glossiness Opacity on the brush or channel menu, so why is this shown in the Slider Menu along with these keystrokes? 

The Layers Menu has Gloss Opacity, but no keystrokes assigned. This is not what the Sliders menu is referring to.  The manual says the keys are ; and / (which also do not do anything).

4: The terms used are confused. The Channel controls on the Brush menu bar  menu uses Glossiness Intensity, but describes it as Metalness. Intensity and Degree also seem to be used interchangably.



  • Thanks 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...