Jump to content
3DCoat Forums

Autotopo decimation fail

Go to solution Solved by Possibly-mef,

Recommended Posts

  • Member

I have noticed that Autotopo via decimation seems to be broken since 2022.49 I just tried 2023.07 and I it still seem broken.  I have tried it on Windows as will a Mac. I am attaching an image that demonstrate the results I am now getting. I am taking a 4M face mesh down to 400k.  It has worked flawlessly until any of the releases since 2022.49 (mac). 

Screenshot 2023-03-18 at 4.19.13 PM.jpeg

Link to comment
Share on other sites

  • Member

Ok so the problem gets a little weirder - I did as Elemeno suggested:

  1. converted to voxels (went from from 4 011 720  tris to 5 208 516 tris)
  2. Decrease Object 2X (Increase Density)
  3. Autotopo via decimation (500 000) polys

While it did not exhibit the same damaged mesh as in the prior example the resolution is too low for good renders in C4D (or other apps)The result is a 40 000 poly group no matter what value it put in to the dialog. I tried a few values between 300k and 400k). Always resulted in a 40k poly group

BTW I ran this test on a Windows machine using version 2022.58 starting from scratch in a new 3DC document.




Link to comment
Share on other sites

I have thoroughly tested "Sculpt Tree > Retopo via decimation" in "3DCoat 2023.08" for macOS using standard models (Reduction Percent 99%) and the attached scene "Angela" (90%). The results are on the attached screenshots. It seems like the decimation itself is working correctly. Try to rename the user data folder "Documents > 3DCoat" into something like "---3DCoat". Run "3DCoat 2023" and try decimation again. Some data in the user data folder or some setting inside "3DCoat 2023" forces the decimation to work incorrectly.

macOS Angela Dec.jpg

macOS Head Dec.jpg

macOS Man Dec.jpg

Link to comment
Share on other sites

  • Member

Hello Sergyi,  Thanks so much for following up.  I tried a couple of tests with both 2022.60 and with 2023.08. I deleted the Documents->3DCoat folder between each test.

I am running this test on at 2017 iMac Pro (8-core Xenon W - 32Gb) running Ventura 13.2.1.  I seem to be getting the same sort of results. See attached screen shots. The results are slightly different but still not right. Although likely not significant I noticed that after I deleted the 3DCoat file from Documents, each time I started the app a 3DCoatV4 folder was create as well at 3DCoat.  

And also as a side note it seems the the imported object in 22.60 and 23.08 is now centered vertically in the grid.  Is that an expected change?? 

Screenshot 2023-03-24 at 2.45.23 PM.jpeg

Screenshot 2023-03-24 at 3.02.54 PM.jpeg

Link to comment
Share on other sites

  • Member

I ran the same test on a Windows machine and on an M1 MacBook Pro using different initial data (i imported a different scanned mesh with 4M triangles.)

Same results.

One notable thing I discovered was no matter value I put in for the Polygon Reduction (200k, 400k, 1M) it alway resulted in a 40k retopo PolyGroup



Link to comment
Share on other sites

  • Member
  • Solution

Additional insight -- found workaround for Autotopo Decimation Fail


If I explicitly enter a value for the Reduction Percent, the decimation is fine.
If enter a numerical value for the Reduced Polygon Count,  the decimation is mangled.
I also noticed that when I enter a numerical value for the Polygon Reduction, the percentage value
does not change to reflect the new value.
2. Consistent with an earlier observation following @Elemeno suggestion:
After converting to Voxels, Decrease Object by 2x and then decimate the decimation is fine but no matter what I value I enter into the Reduced Polygon Count, I get at 40k tri, result.


  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...