Jump to content
3DCoat Forums

How do I disable Sticky Keys ?


ijac
 Share

Recommended Posts

  • Member

I have custom hotkeys for most of my retopo tools that I use.  I don't use Stack Keys or Sticky Keys.  There is a function of Sticky Keys that I really, really dislike.

The problem ... I have D assigned to the Points to Polygons tool.  When I press D multiple times it switches to the last tool I used, then back to Points to Polygons tool.  I hate this :D When I press D I want to know that it's selecting the Points to Polygons tool and nothing else ... ever.   I assume this is part of the Sticky Keys functions. 

How do I disable Sticky Keys?

Thanks for your help :)

Edited by ijac
  • Like 1
Link to comment
Share on other sites

:huh: That's not intended behavior, and sounds like a bug. Which build are you using ?

There is a workaround which could be useful

---------------------------------------

Export hotkeys from [Edit] - [save hotkeys].

Open it with text editor, replace all

<AllowStack>true</AllowStack>

to

 <AllowStack>false</AllowStack>

And reimport

Link to comment
Share on other sites

  • Member
Carlosan
This post was recognized by Carlosan!

ijac was awarded the badge 'Great Support' and 1 points.

Thanks for the info.

I was seeing this in 2023.16.  I just updated to 2023.29 and the behavior is the same.  Nothing has changed.

I exported the hotkey file and did as you explained.  Most were already set to False.  Only one was set to True.  I changed it to False and reimported the hotkeys.  The behavior is still the same.  Nothing has changed.

It's behaving exactly as described in the official Sticky Keys video ... 3:12 minute mark.  This is what I want to disable. 

 

  • Thanks 1
Link to comment
Share on other sites

  • Advanced Member
12 hours ago, ijac said:

I have custom hotkeys for most of my retopo tools that I use.  I don't use Stack Keys or Sticky Keys.  There is a function of Sticky Keys that I really, really dislike.

The problem ... I have D assigned to the Points to Polygons tool.  When I press D multiple times it switches to the last tool I used, then back to Points to Polygons tool.  I hate this :D When I press D I want to know that it's selecting the Points to Polygons tool and nothing else ... ever.   I assume this is part of the Sticky Keys functions. 

How do I disable Sticky Keys?

Thanks for your help :)

Same problem for me (sticky keys), which I had already reported/requested some time ago. Thanks for this report.

Edited by rubeos
  • Thanks 1
Link to comment
Share on other sites

  • 4 months later...
  • Carlosan changed the title to [Solved] How do I disable Sticky Keys ?
  • Member
Posted (edited)

As of v2024.13 this is not solved.  Behavior hasn't changed at all.  I have "Don't Use Sticky Key" checked on in Preferences.  I restarted 3D Coat after checking it on fyi
 

image.png

Edited by ijac
  • Thanks 1
Link to comment
Share on other sites

  • 4 months later...
  • New Member

Seems it is problem for me as well... Tried everything, reinstaling, updating, turning sticky keys in prefs, nothing works, and tool always swaps between last used, while pressing a key twice. 

Link to comment
Share on other sites

  • New Member

Hi, basically every tool/hotkey behaves the same. If for example were using a Pose tool, and switching to Sphere tool with a hotkey, hitting it twice will get me back to Pose tool. 

  • Thanks 1
Link to comment
Share on other sites

  • Carlosan changed the title to How do I disable Sticky Keys ?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...